Unable to ping MAIL host on W2K DNS Server

I have a W2K DNS server on the internet. I can ping host.mydomain.com, www.mydomain.com, etc. That all seems to respond just fine. I entered an MX record and called it mail.mydomain.com and put the IP address of a sendmail Linux fedora box I am using to test some work. All the FQDNs I listed above go to this same Linux box.

I can ping the other host names, I can ping by IP address, I CAN NOT PING BY NAME TO "mail.mydomain.com".

I made sure it WAS an "MX" record.

I tried little things like making sure the firewall was temporarily taken down to test between these boxes if the ping went through. But whenever I try to ping mail.mydomain.com I get an Unknown host error. No error when I type ping host.mydomain.com, www.mydomain.com, etc. I entered another A record, and I can ping that.

I have cleared the cache on my internal DNS, and run ipconfig /flushdns on my client windows machines.

I even get Unknown host error when I trying to ping mail.mydomain.com FROM THE DNS SERVER!

Yet I see the darn recording in the domain folder for the domain in question, pointing to the IP address (also tried pointing the MX record to another host name that leads to the same Linux box)

I have run nslookup on the windows and Linux machines and tried to get it to tell me the IP of mail.mydomain.com and get *** Can't find mail.mydomain.com: No answer or NOTHING on the windows machine.

I either don't know something, or I forgot something I knew once.

ANY SUGGESTIONS??
gplemos071400Asked:
Who is Participating?
 
Chris DentPowerShell DeveloperCommented:

MX Records should be:

mydomain.com. IN MX mail.mydomain.com.

Then the A Record for the mail server...

mail.mydomain.com. IN A <IP Address>

Using IPs in MX Records disagrees with certian RFCs... I can probably find it if you want.

If your MX is mail.mydomain.com. IN MX... Then you're trying to tell it to recieve mail sent to the domain mail.mydomain.com (that is @mail.mydomain.com) to your sendmail IP.
0
 
Chris DentPowerShell DeveloperCommented:

RFC 974 and 1035. It's fun reading... honest...
0
 
gplemos071400Author Commented:
Thanks!  But hey, I am not reading RFC's unless they put a gun to my head :-)

That was enough info for me to think -- I then just needed to review something in my minasi windows server book, and that got it straightened out.

Thanks for the help and memory slap!
0
 
Chris DentPowerShell DeveloperCommented:

Can't say I blame you.. RFCs are a bit heavy ;)

Glad it helped anyway :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.