[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4174
  • Last Modified:

userid disabled or restricted in DB2 8.1.7

Hi,
I am seeing a weird problem with DB2 8.1.7 When we connect to the
database using the following command in db2 CLP
 
db2 connect to <dbname> user <user> using <passwd>

I get the following error,
"userid disabled or restricted"

For this the DB2 suggests the following.
1.open the DB2 CLP
2.Type the command db2 connect to <dbname> user <user> using <passwd>
3.If you encounter error such as userid disabled or restricted, type
the command
        db2secv82 /u <usergroup>
4.Start the db2 (db2secv82 command stops the database)
5.They also say that this is because of the new security feature
"Enable OS Security" option during installation or migration of DB2 8.1.7

     The problem is that every time (say after a system restart)i need to
reissue this command for the users to access the db2 objects


Is there any way to permanently resolve this issue in DB2 8.1.7

Thanks
Nagki
0
nagki
Asked:
nagki
  • 4
  • 2
1 Solution
 
ghp7000Commented:
Add the Everyone group to the DB2ADMNS and DB2USERS groups.
0
 
nagkiAuthor Commented:
Hi..
Thanx for ur quick response

I found "DB2ADMS" and "DB2USERS" groups in my computer groups list..

But i din't find "Everyone" group there..is "Everyone" group will exist or ur meaning is that add all the users for whom we want the previlege of accessing DB2.

db2admin user is there in both groups..
I logged in as db2admin..even then it's given same error

SQL30082N  Attempt to establish connection failed with security reason "19"
("USERID DISABLED or RESTRICTED").  SQLSTATE=08001

Hope this error statment may be helpful for you..
0
 
ghp7000Commented:
Have you added the users who will use the database to the DB2USERS group? If not, add them now.
Next, add the users to the DB2ADMS group who will have administrative rights on the instance, database and Control Center.
Next, with no users connected to the database, and no administrators making any other changes to the database/instance,  run this command:
db2secv82 /u /a
The system should now be setup properly.
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
nagkiAuthor Commented:
Hi ghp7000,

I added the user to both groups DB2USERS AND DB2ADMS groups..

I ran that command with no users connected to database and no administrators are making changes to database..

After that i logged-off and logged-in again..

Now i got new error
SQL1042C An unexpected system error occured.

and DB2 didn't turn up at start-up..what might be problem?

and one more doubt will it be ok if i run that command "db2secv82 /u /a" once or need i to run that command for every reboot/logoff.

If u want any logs/eventlogs information i can post..

0
 
ghp7000Commented:
no, you shouldnt have to run the command every time.
Are you logging on to Windows with the same user id that you are using to connect to the database? If not, log on to Windows with the same user name that is in the DB2USERS group. If that doen't work, I would try stopping and starting the instance
db2stop
db2start
re try to connect. If still same error, run these commands again
db2secv82 /u /a, then
db2secv82 /r
stop and start the instance again.
Re try to connect. You should now have "userid disabled or restricted"  error

0
 
ghp7000Commented:
are you sure that the user in question is not disabled on Windows?
go to administrative tools, computer management, users and groups, highlight the user in question, right click, choose properties, make sure the account is not locked out, the password has not expired, or the account has not expired.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now