• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 216
  • Last Modified:

Laptop sound not working after moving from Mandrake 10 to 10.1 (fresh install)

Hello Everyone:
Since I installed (fresh) Mandrake 10.1, I have no sound from the built in speakers in my laptop. With old version 10.0, the sound worked fine right out of the box. Symptoms: KDE (and Gnome) THINK sound is playing, only there isn't any from the speakers. I checked the mixer and all volumes are are 80%, nothing is muted or turned down. When I play music files, the visualizations show that Amarok THINKSS it's playing the song, only there's no sound. This may be a problem with the newer kernel, because I had the exact same problem with the latest SUSE and Fedora Core, but when I reinstall Mandrake 10.0 , it works just fine!
Here is the results of lsmod, if that helps:
Module                  Size  Used by
speedstep-lib           3364  0
i830                   74516  2
nfsd                  189408  8
exportfs                4736  1 nfsd
lockd                  58344  2 nfsd
sunrpc                127652  2 nfsd,lockd
rfcomm                 32348  0
l2cap                  19876  5 rfcomm
bluetooth              39076  4 rfcomm,l2cap
snd-seq-oss            31232  0
snd-seq-midi-event      6080  1 snd-seq-oss
snd-seq                47440  4 snd-seq-oss,snd-seq-midi-event
snd-pcm-oss            49480  0
snd-mixer-oss          17376  1 snd-pcm-oss
snd-intel8x0           30124  0
snd-ac97-codec         69392  1 snd-intel8x0
snd-pcm                81800  2 snd-pcm-oss,snd-intel8x0
snd-timer              20356  2 snd-seq,snd-pcm
snd-page-alloc          7400  2 snd-intel8x0,snd-pcm
gameport                3328  1 snd-intel8x0
snd-mpu401-uart         5856  1 snd-intel8x0
snd-rawmidi            19300  1 snd-mpu401-uart
snd-seq-device          6344  3 snd-seq-oss,snd-seq,snd-rawmidi
snd                    45988  11 snd-seq-oss,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-timer,snd-mpu401-uart,snd-rawmidi,snd-seq-device
soundcore               7008  1 snd
af_packet              16072  2
ds                     17572  2
yenta_socket           18624  0
pcmcia_core            59972  2 ds,yenta_socket
thermal                 9928  0
tc1100-wmi              5028  0
processor              13736  1 thermal
fan                     2756  0
button                  4624  0
battery                 7044  0
ac                      3204  0
b44                    18760  0
mii                     4224  1 b44
eth1394                17000  0
md5                     3584  1
ipv6                  230916  10
ide-cd                 37280  0
cdrom                  37724  1 ide-cd
ohci1394               30788  0
ieee1394              292056  2 eth1394,ohci1394
loop                   12520  0
nls_iso8859-1           3680  1
nls_cp850               4480  1
vfat                   11168  1
fat                    39776  1 vfat
intel-agp              19584  1
agpgart                27752  4 intel-agp
nvram                   6856  0
joydev                  8032  0
evdev                   7648  1
tsdev                   5824  0
usbmouse                4256  0
usbhid                 41088  0
ehci-hcd               26244  0
uhci-hcd               28752  0
usbcore               103172  6 usbmouse,usbhid,ehci-hcd,uhci-hcd
ext3                  120680  1
jbd                    49080  1 ext3

Looking at /var/log/messages, I don't see any errors: Here are the relevant lines:
Apr  7 15:59:02 localhost kernel: intel8x0_measure_ac97_clock: measured 49491 usecs
Apr  7 15:59:02 localhost kernel: intel8x0: clocking to 48000
Apr  7 15:59:02 localhost alsa:  succeeded
Apr  7 15:59:02 localhost alsa:  succeeded
Apr  7 15:59:03 localhost sound: Setting mixer settings succeeded
Apr  7 15:59:03 localhost xfs: xfs startup succeeded

DMESG also doesn't show any errors.

Any help will be greatly appreciated. I don't want to go back to 10.0 at this point.
0
haldrik
Asked:
haldrik
  • 2
1 Solution
 
gtkfreakCommented:
Log on as root and use the amixer command to set the volume levels
# amixer set Master 74% unmute
# amixer set PCM 74% unmute
# amixer set Headphone 74% unmute
# amixer set CD 74% unmute

You can go upto 100% in place of 74%. Also, once you have done this, you can login to your mixer and check the volume.
0
 
haldrikAuthor Commented:
Tried it...unfortunately, there's still no sound . Here's the results of amixer with no arguments after using your commands with 90%:
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 28 [90%] [on]
  Front Right: Playback 28 [90%] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 28 [90%] [on]
  Front Right: Playback 28 [90%] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 28 [90%] [on]
  Front Right: Playback 28 [90%] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-ex
clusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 24 [77%] [on] Capture [off]
  Front Right: Playback 24 [77%] [on] Capture [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-ex
clusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on] Capture [off]
  Front Right: Playback 23 [74%] [on] Capture [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-jo
ined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 24 [77%] [on]
  Front Left: Capture [on]
  Front Right: Capture [on]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Video',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
0
 
gtkfreakCommented:
If you are using the KDE desktop, then you can launch kmis and set the volumes there as well. Normally, after using amixer, the KDE volumes need to be set.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now