?
Solved

Mandrake 9.0 PPC on iMac G3

Posted on 2005-04-07
8
Medium Priority
?
465 Views
Last Modified: 2013-11-24
I tried to load Mandrake Linux onto an old iMac G3 (Summer 2001 Indigo).   I got Linux loaded, but the only way I can get in to Mandrake is to hold down the CMD-OPTION-O-F and get to an open firmware prompt.   I can't get the Linux bootloader to work.  
I think I messed up during the "partitoning" portion of the Mandrake Installation...because Mandrake keeps telling me that it can't find the "Apple BootStrap" partition.   I've tried to reinstall Linux several times...with no better results.   I finally decided that I would go back to Square #1...reinstall Mac OS 9...and walk through the whole process again.  
(Here is the real problem)...When I insert the Mac Reinstall CD (while holding down the "C") I successfully boot from the CD and get to the opening MAC reload screen.   Unfortunately the RELOAD button is "grayed out".    The only button on the screen that works is the QUIT button.   Somehow I really messed this thing up so that I can't reinstall Mac OS9.  
How do I reset the Mac so that I can relaod Mac OS 9....and then repartition the drive and start over with the Linux Mandrake load???    (I have no idea how difficult this is...so I assigned 125 points...if this probem is harder than that..let me know).
0
Comment
Question by:photog53
  • 5
7 Comments
 
LVL 15

Expert Comment

by:davidis99
ID: 13732624
When you boot from CD, do you have the option to open the disk utilities from the menus at top, before trying to do an OS install?  If so, go into the disk utility, delete the partition(s), create a new partition, and enable the option to write zeroes to the drive.
0
 

Author Comment

by:photog53
ID: 13732892
No...unfortunately not.   I get big gray box with three active buttons.  In the center it allows me to EJECT DISK  and  SWITCH DISK  and in the lower left hand corner iit allows me to QUIT.   The RESTORE button is still grayed out.   In the upeer left hand corner I have a box labled CONFIGURATION....and in it a highlighted line with the words...."iMac HD Disk 1.dmg  
In the center it says "Restore Image".   I don't see an option to open a disk utilitiy.  
0
 

Author Comment

by:photog53
ID: 13732916
Wait !!!!    I found another CD in the pack.   This one lets me see Apple folders and a Utilities Folder.....Give me a few minutes to play with this and see what trouble I can get into...
0
Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

 

Author Comment

by:photog53
ID: 13732929
I "initialized the Disk"...and now it is giving me the option to partition.    
0
 

Author Comment

by:photog53
ID: 13782576
I redid everything....the bootstrap now seems to work, but only the "m" option going to Mac OS works.   The "l" option for Linux takes through several boot screens...before flashing a coupe of times and taking me right back to the beginning of the boot choices.  
0
 

Author Comment

by:photog53
ID: 13793422
I'm going to close this question.    No one seems to have a good...and another 'Linux newbie"  who encountered the smae problems with Mandrake that I have....changed to Yellow Dog Linux (which worked).   Since this Mac G3 using Linux is an experimental box anyway...I will simply switch to yellow Dog.  
0
 

Accepted Solution

by:
PAQ_Man earned 0 total points
ID: 15644476
PAQed with points refunded (125)

PAQ_Man
Community Support Moderator
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
How to take pictures with depth using iOS 10
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question