javascript error on page of MS SQL Reporting Services - Datasource.aspx?createnew

Posted on 2005-04-07
Last Modified: 2012-05-05
Hi All,

 Still trying to learn SQL Server reporting services and having some trouble.

 I'm trying to create a new datasource (using the /reports virtual directory, not via visual studio)

 I created one before with no problems,

  Now on that page I get an javascript page and the familiar ! error sybol at the bottom left of IE

  The error is line 388 char 3 error: Object expected Code:0 Url

  Line 388 is pointless, becuase when I view source I get a file with 294 lines. (maybe it's including the contents of the external javascripts?)

  - Anyhow,

    After I installed RS, I had to move it to a differnent website (didn't need it on default) - that worked almost fine, except I got a few errors that seemed to be related to the lack of an SSL certificate - So I created one with cert server and installed it on IIS - I think its' around then that it stopped working, but hard to say, I've done a lot over the past 3 days.

  If this has ever happened to you, please post a reply, even if you don't have the answer so I can guage how common this is.


Question by:fruhj
    LVL 14

    Accepted Solution

    Bit of narrowing down...
    Do other reports on your site work ok?
    Is the issue just on creation of a datasource via Report Manager?

    Check this article for non-default IIS site setup:

    Moving Reporting Services' Virtual Directories
    LVL 12

    Author Comment

    Hey Simon,

      It seems to be just the datasource.aspx page. Reports are showing fine and the other screens I've accessed via the /reports virtual directory all seem fine as well (they render to IE fine with no javascript errors)

    I've got a test server here (without the error) I think I'll do an MD5 checksum on the folders and compare it to an MD5 of the problem server to verify that the files are the same - then at least we can rule out the aspx and js files as the problem.
    LVL 12

    Author Comment

    Hi Again Simon,

    I did the MD5 and all files are the same, minus 2 config files that were mentioned in the article.

    I noticed something else today that might help:

    I can't add a new folder - the ok button doesnt do anything - leads me to think it's not getting the javascript file or something.
    However that' the case testing from the new site I have setup (copied the folders per your article)

    On the original "default web site", I am able to add a folder.
    Both point to the same RS code - so it must be something different - maybe permissions setup, maybe config file, maybe the .net include files aren't in the new site I setup (I tried a test aspx page and it works, but it didn't use any client side javascript for validation - so maybe I'm missing that on my new site?)

    Ok Simon, thanks again, if you think of anything else, please let me know!

    - Jack
    LVL 12

    Author Comment

    Hey Simon, that was it!

    How F**ing Stupid of me!

    I thought I followed your article, and obviously I missed the last step - copying the asp_net client.

    (I never got the error message about not finding the js file from IE or I'm sure I'd figured this one out sooner)

    Anyhow Simon, once again thanks for all your help on this question and questions you've helped me out in the past with!

    - Jack
    LVL 12

    Author Comment

    Follow up message for someone reading this in the PAQ

    I had a problem with reporting services on a new site I had created.

    Many of the problems were related to client side buttons not working.

    It turned out to be a missing javascript file on the new site I created. uses a .js file for it's client side javascript code - used in things like validation, etc...

    I had created a new site, and aspx files were working, so I forgot all about the js file.

    I copied the folder: aspnet_client from another site off my machine (the default site to be exact) into the site I had used for Reporting services.

    This fixed the problem.

    Hopefully this paq can help someone else!
    LVL 14

    Expert Comment

    Glad I could be of help

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    Problem Statement In an SAP BI BO Integration project when a BO universe is built on a BEx query, there can be an issue of unit & formatted value objects not getting generated in a BO universe for some key figures. This results in an issue whereb…
    From implementing a password expiration date, to datatype conversions and file export options, these are some useful settings I've found in Jasper Server.
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now