[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

HOST IS DOWN - out of the blue

Posted on 2005-04-07
8
Medium Priority
?
219 Views
Last Modified: 2013-12-23
I was watching TV and my wife was surfing the internet when she said she couldn't get to any more web pages from the internet. I tried connecting to a site on the server and the host name wouldn't resolve. I tried localhost and it won't resolve. The only way I can reach a site on the server is with 127.0.0.1

I can't access anything on the server from any other computers within our network.

Could this be a DNS/BIND issue. Why would it stop working just like that out of the blue?

Can someone help me trouble shoot???
0
Comment
Question by:HangTenDesign
  • 4
  • 3
8 Comments
 

Author Comment

by:HangTenDesign
ID: 13732794
I tried nslookup on the server and it returns the correct information. However, when I try to ping that informaiton I get an "unknown host" return.

Is there some kind of routing problem??? What could this be??? help
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13732800
>I can't access anything on the server from any other computers within our network.
What kind of machine OS do you have?
Solaris, RedHat Linux or ....
What's the output of
uname -a
ifconfig -a   (as root)
netstat -rn

And also check /var/log/messages (or /var/adm/messages) for error messages.

Wesly
0
 
LVL 38

Accepted Solution

by:
wesly_chen earned 2000 total points
ID: 13732805
> I tried nslookup on the server and it returns the correct information
Check /etc/nsswitch.conf  for
hosts:   files dns     # <== make sure "dns" here
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:HangTenDesign
ID: 13732891
wesly_chen,

FREE BSD on MAC OS X

----> OK, so all I did was shut down DNS/BIND and then restart and it did the trick.

Why would a shutdown and restart fix it??? I have found UNIX to be incredibly stable and mostly cause and effect. What could cause it to do such a thing?
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13732920
> all I did was shut down DNS/BIND and then restart and it did the trick
Well, for MacOS X, you shouldn't need to run BIND (DNS server). I guess some sort of DNS temporary cache
database corrupted cause the problem.

I would recommend that turn off BIND if you don't need it.
Besides, turn off unnecessary services for security.
MacOS X, by default, will start a lot of services (similar to M$ Windows) which you probably won't use them all the time.

Anyway, glad to know your problem resolved so quickly.
 
0
 

Author Comment

by:HangTenDesign
ID: 13732949
Yes, thankyou.

BTW, I am running BIND cause I am running my own DNS server, web, mail, database, with over a dozen domains. I couldn't believe how incredibly powerful MacOS X was under the hood. I am not even using their Server software. It's all there!

Thanks again
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13732967
That's Unix's world. M$ charge every piece they can charge out of users.......
0
 
LVL 7

Expert Comment

by:bstrauss3
ID: 13909478
Check if your DNS server is caching negative replies, and whether you have listed the upstream (ISP) DNS server by name or IP address.

If the ISP has a problem for even a brief interval and you specify upstream by name, your DNS server may cache the fact that the ISP's DNS server is unavailable.  Once that happens, until the cache expires, every query for ns.isp.com gets 'not found'.

Restarting bind clears the cache.


-----Burton
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question