Unable to connect to the internet when using DHCP

I am running Windows XP Pro SP2 on my laptop with a Sony PCWA-C300S wireless card. I have a Linksys WRT54G v3 wireless router. I am connecting wirelessly. It is acting as the DHCP server, I have turned off WEP, I have turned off MAC filtering. I am getting an address via DHCP from the router. I can browse the other network computers and ping the gateway, I can ping myself. I cannot ping outside the network, or access the internet. I also have tried setting the DNS statically while receiving the IP via DHCP, and that didn't do any better.

When I use a static IP, I can browse the net just fine. When wired to the router, I am able to browse the net just fine.

I have tried WinsockxpFix. That didn't help.

Please help.
LVL 1
dbruyereAsked:
Who is Participating?
 
spazztik69Connect With a Mentor Commented:
put the machine into the broken setup that should work but dosen't then open a cmd prompt and do an ipconfig /all and paste/save the results so you can put them in here. it sounds like you're not getting a valid (or any) default gateway from the dhcp server.
0
 
dbruyereAuthor Commented:
Here you go. I am getting a valid gateway. Everything there is exactly correct as far as I can see.

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . . . : Sony 802.11g Wireless LAN Adapter
        Physical Address. . . . . . . . .  : 08-00-46-B1-FE-4E
        Dhcp Enabled. . . . . . . . . . . . : Yes
        Autoconfiguration Enabled . .  : Yes
        IP Address. . . . . . . . . . . . . . : 192.168.1.102
        Subnet Mask . . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . .: 192.168.1.1
        DHCP Server . . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . . : 68.94.156.1
                                                     206.13.30.12
        Lease Obtained. . . . . . . . . . . : Thursday, April 07, 2005 8:48:45 PM
        Lease Expires . . . . . . . . . . . . : Friday, April 08, 2005 8:48:45 PM
0
 
dbruyereAuthor Commented:
Very strange. I went and changed the Router's Ip from 192.168.1.1 to 192.168.2.1 and then did a release/renew on the wireless and everything is working now. I don't understand why the 1.1 would be a problem.

Anyway, Thanks spazztik69. You gave me the idea, so I am accepting your answer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.