• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 774
  • Last Modified:

apache 2.0 + Bugzilla 2.16

Hi,
I have installed bugzilla version 2.16 along with apache 2.0.43.
Following is the portion of my httpd.conf file.


DocumentRoot "/var/www/html"
<Directory />
    Options FollowSymLinks
    Options ExecCGI
    AllowOverride Limit
</Directory>
<Directory "/var/www/html/bugzilla">
    Options Indexes FollowSymLinks
    Options ExecCGI
    AllowOverride Limit
    Order allow,deny
    Allow from all
</Directory>
DirectoryIndex index.html
AddHandler cgi-script .cgi



When I try to browse to localhost/bugzilla it gives me 403 Forbidden. But if I change the DirectoryIndex to index.cgi it works fine. Should'nt the Options ExecCGI take care of this.


Regards
Walter.
0
wfaleiro
Asked:
wfaleiro
  • 2
  • 2
1 Solution
 
TomDavidsonCommented:
It's likely forbidden because it's decided not to give you a directory list of the bugzilla folder. Check apache's error_log for more details.
0
 
wfaleiroAuthor Commented:
[Thu Apr 07 17:16:51 2005] [error] [client 192.168.1.70] Directory index forbidden by rule: /var/www/html/
[Thu Apr 07 17:17:28 2005] [error] [client 192.168.1.70] (2)No such file or directory: exec of '/var/www/html/bugzilla/index.cgi' failed

This is the error. If directory list is forbidden how do i get the page to display when i change my index.html to index.cgi. I guess with ExecCGI option the bugzilla home page should have been displayed.

Thanks.
0
 
caterham_wwwCommented:
try to place

DirectoryIndex index.cgi

within <Directory "/var/www/html/bugzilla">....</Directory>-Container
0
 
wfaleiroAuthor Commented:
Hi Caterham
DirecotryIndex index.cgi works outside the container too. What I want to ask is Options ExecCGI should have enabled the execution of the scripts. But it does not.
0
 
caterham_wwwCommented:
You'll need DirectoryIndex index.cgi somewhere.

Options ExecCGI does *not* say "use index.cgi, if localhost/bugzilla/ was requested". It will just allow to execute files, but does not say use index.cgi. This is the error from 17:16:51. The 2nd, 17:17:28 is caused by something else.

If you are using DirectoryIndex index.html and have disabled MultiViews, you will will never see index.cgi for /bugzilla/
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now