[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Computers not found on netrwork

Posted on 2005-04-08
35
Medium Priority
?
343 Views
Last Modified: 2012-06-27
I am running Win XP (latest update). Firewall is on, but set to allow file sharing. (There is no differance when I turn the firewall off). I am using a direct hard wire connection between two computers both on XP.  The network connections between the two computers worked until I had to refomat one of the computers and reinstall everything. I set up the MShome network etc.,again but I do not see even my own computer in Microsoft network! My computer is set for file sharing etc., but I am really at a loss. Obviously I am doing something really simple wrong!!

Any help would be appreciated.

I
0
Comment
Question by:ronglen
  • 16
  • 11
  • 3
  • +2
32 Comments
 
LVL 7

Expert Comment

by:krakken
ID: 13739827
Try this on both computers.

Right click Network Places, select Properties.

On Properties find TCP/IP.  Doubleclick.

Inside TCP/IP set this address for one computer 192.168.1.10 and this one on the other 192.168.1.11
Then set both the same with this info.
Subnet mask: 255.255.255.0
Gateway (Do you have Interent? if so, then we'll need to change everything to match your ISP settings, but usually it'll be this) 192.168.1.1
DNS (again, only if you use internet, but if so, just set ISP DNS here)

Click ok, and save.  Then see if you can connect to each computer.
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 13740597
This behavior may occur if both the following conditions are true:
 NetBIOS over TCP/IP is not turned on (enabled) on one or more computers in the   MShome.
     
The Computer Browser service is not started or is turned off on one or more computers in the workgroup.

To resolve this issue, make sure that NetBIOS over TCP/IP is turned on and the Computer Browser service is running on each computer in the workgroup. To do this, follow these steps.
Step 1: Turn on NetBIOS over TCP/IP
1.     Click Start, click Control Panel, and then click Network and Internet Connections.
2.     Click Network Connections.
3.     Right-click Local Area Connection, and then click Properties.
4.     Click Internet Protocol (TCP/IP), and then click Properties.
5.     Click the General tab, and then click Advanced.
6.     Click the WINS tab.
7.     Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
8.     Click Close to close the Local Area Connection Properties dialog box.
9.     Close the Network Connections window.

Step 2: Start the Computer Browser service
1.     Click Start, right-click My Computer, and then click Manage.
2.     Double-click Services and Applications.
3.     Double-click Services.
4.     In the right pane, right-click Computer Browser, and then click Start.
5.     Close the Computer Management window.

The Computer Browser service maintains an updated list of computers on the network, and it supplies this list to computers that are designated as browsers. If this service is stopped, the list is neither updated nor maintained. If this service is turned off, any services that explicitly depend on it do not start.

Make sure all machines have ip's in the same subnet ie 192.168.0.1, and 192.168.0.2,
 And just make sure that they are pinging each others
then you might use this trick :

In the desktop add you’re the remaining address of the computers u can not see, lets assume that they are  pc1,pc2  .
in the PC1 lmhosts file as this will assist with resolution. Look for lmhosts.which is a sample file located at

C:\WINNT\system32\drivers\etc

Edit it with notepad, add the following entry for PC2

PCNAME2 <tab>       PC2_IPADDRESS

Save the hosts file as lmhosts (no extension - not .sam, not .txt)
Do this on the pc that you have  a problem with.


0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13741016
Since this is P2P situation, I suggest you read my page on P2P troubleshooting..  Go down the steps one by one until you get your computer network back on line..

http://65.24.134.81/KipSolutions/P2PNetworks/TroubleshootingP2P.htm

FE
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:ronglen
ID: 13741932
Hi Abu Deep,
I tried the first set of your suggetions, but still cannot see even my own computer in the MShome workgroup. When I click on "my network places" I can see all of the drives on my computer, but they do not seem to be in MShome workgroup. The workgroup is active since When I check "system information" it shows that this computer is indeed in the workgroup. I think and hope that when I can see my computer in the workgroup, I will be able to see the other computer too.  As I said, the connection worked before I reinstalled Windows.
Any ideas??
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13743257
Did you go through my page of troubleshooting this?
0
 
LVL 18

Expert Comment

by:crissand
ID: 13748216
The nic is broken, or its drivers are not installed or are defective.
0
 

Author Comment

by:ronglen
ID: 13795932
Hi Fatal Exception,
I did go through your very good troubleshooting protocal and so far everything looks fine - except that I am not networked. I also ran the reset TCP that you referenced and I now have conductivity between the computers.  I can ping my own but not the other computer and can only see one computer in the workgroup from either side. I had the cable checked at a local shop and it seems OK.  I reinstalled the drivers etc. and am really puzzled. Any other ideas??
0
 

Author Comment

by:ronglen
ID: 13796084
One more thing. I said that I had conductivity. I spoke in error. I still have limited or no conductivity on the network. If I had not checked the cable, I would think that that was the problem, but.......
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13798871
except that I am not networked.<<  ??  I think you mean you are not running a Domain Controller, correct?  Anytime you connect more than 1 PC, it is considered a network, even if it is just a P2P connection..

What happens when you try to connect via the Run Line with the remote PCs IP Address?

Start > Run > \\ipaddress (OK)  (Don't forget to put in the backward slashes)
0
 

Author Comment

by:ronglen
ID: 13799694
I tried it and no go.  I am seeing something strange. When I have both computers on and connected, everything looks normal on computer #2. On my computer, I see that there is "limited connectivity".  I ran "netsh diag gui" and the connection appeared normal - I don't know if this is related.

I can ping each computer individually but not the other and I cannot see the other computer on either one.  I msut be missing something simple but.......
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13799754
This is a tough one, without us sitting in front of your systems..  After trying to ping the networked computer, run an ARP -a command from your Command Shell (Start > Run > cmd) and see if your second computer's MAC address is showing up in the ARP Cache..  
0
 

Author Comment

by:ronglen
ID: 13799839
I tried that and ARP -a gives me no log even whtn I ping my own computer or an unknown DNS. Am I doing something wrong using ARP -a?
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13800708
Hmm..  If nothing exists in your ARP Cache - after a ping request is sent out, then the ARP Request is not making it out to your network, or the receiving computer is not responding.  Computers communicate via their MAC addresses, not the IP Addresses.  The ARP request is a broadcast that goes out when a computer does not know how to map an IP Address to the MAC Address of the remote computer.  Usually this is the result of a firewall that is blocking the request.  And the reason the Ping is not going through.

If this were me, I might try throwing another NIC into the machine (with the limited network message) to see if it is a hardware issue, but I have a box of extra NICs sitting in my storage.  LOL, eh?  You might try starting the computer with Safe Mode WITH Networking (not safe mode alone) and try the ping again.  (F8 at boot).  If it is successful, we could then narrow it down to a software problem, possibly something starting at boot that is blocking the requests..

FE
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13800865
BTW:  Here is the proper way to use ping to assess network problems:

Step-1: Ping Loopback IP address (127.0.0.1). Success shows that TCP/IP is properly installed.

Step-2: Ping local NIC's IP address. Success shows that NIC is working properly.

Step-3: Ping Default Gateway. Success shows that local physical layer connections are ok.

Step-4: Ping Remote IP address. Success shows that remote physical layer connections are ok.

FE
0
 

Author Comment

by:ronglen
ID: 13802395
Hi Fatal Exception,
I really appreciate your ongoing efforts!!!!
How do I ping the gateway?

I was able to ping the loopback and my computer both by name and by DNS. I cannot find the other computer.
When I try to repair the connection, I get the msg "unable to renew IP address"  

These two computers were connected OK before I had to format mine. Since then No GO.

Thanks
Ron

0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13802602
Yes >These two computers were connected OK before I had to format mine. Since then No GO<  Been there, done that, and it is frustrating.  :)

Are these computers connected to the internet at all?  If so , how are you connected?  (obviously not a router, since we are trying to TS this as a direct connection)  

BTW:  are you absolutely sure you are connected using a Crossover Cable?

The gateway is a Layer 4 device that allows access to another subnet / internet.  It is usually the Default Gateway, or the route of last resort (meaning that if a data packet, or frame, cannot find the destination address, it is sent out the default gateway.)  If you do an "ipconfig /all" at the Command Prompt, it will tell you what the Default Gateway is..

FE
0
 

Author Comment

by:ronglen
ID: 13803210
I am sure that the cable is a crossover. It worked before. Each computer is connected independantly to the net over a 56K dial-up. Only one computer can log on at a time.

I ran "ipconfig/all" which I never knew about, and got

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Owner>ipconfig/all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : ron
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
        Physical Address. . . . . . . . . : 00-07-E9-C2-02-F6

PPP adapter Surfbest:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
        Physical Address. . . . . . . . . : 00-53-45-00-00-00
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 66.6.190.99
        Subnet Mask . . . . . . . . . . . : 255.255.255.255
        Default Gateway . . . . . . . . . : 66.6.190.99
        DNS Servers . . . . . . . . . . . : 66.6.176.10
                                            66.6.191.10
        NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
        Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::5445:5245:444f%5
        Default Gateway . . . . . . . . . :
        NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter 6to4 Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : 6to4 Tunneling Pseudo-Interface
        Physical Address. . . . . . . . . : 42-06-BE-63
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 2002:4206:be63::4206:be63
        Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
                                            2002:836b:213c::836b:213c
        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1
        NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

        Physical Address. . . . . . . . . : 42-06-BE-63
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::5efe:66.6.190.99%2
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1
        NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Owner>

Does this help? It looks like IP routing is not on.......I do not understand all the information.

ron
0
 
LVL 18

Expert Comment

by:crissand
ID: 13805030
The nic, or the cable.
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13805121
Here is your NIC:

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
        Physical Address. . . . . . . . . : 00-07-E9-C2-02-F6

To use TCP/IP to transmit data, you need the Network Layer Address (IP Address) for routing the packets to the destination.  I see no Layer 3 address here.  (You have the Layer 2 address, that being the MAC or Physical Address).  Go into your TCP/IP Properties window, and setup static address in the same subnet as the other computer.  

Just curious, what address were you trying to ping in the comments above?  If the PPP adapter, you cannot ping this until you have an address for your NIC, and a route established between the two.  (Which, unless you want to use ICS to share the PPP connection, you don't need anyway..)

So, take a look at both computers NIC's properties.  Setup IP Addresses like so:

Private IP Address Static:  192.168.1.10 (computer 1)  192.168.1.11 (Computer 2)
Subnet Mask:  255.255.255.0  (both)
Don't worry about DNS since this is just a direct connection.

FE

0
 

Author Comment

by:ronglen
ID: 13808639
Hi FE,

I am getting confused. When i did the "ping" tests I pinged "ron" and 169.254.16.61  which is the address of my computer. Both were OK.

I do not know how th set the NIC/IP etc that you suggested. Is there someplace that can give me a step by step??

Ron
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13809325
Ah,...  that is the reason you cannot connect!  169.254.16.61  is what we call the APIPA address and it is automatically given to the NIC when a DHCP server cannot be fournd, no static IPs are assigned, and it 'sees' that it is connected to a network!!!

You have to assign static IPs to your NICs (on both machines).  Once you do that, you will be able to connect to both!

Depending on your desktop setup, you need to access the TCP/IP properties window.  The for-sure way is to open Control Panel > Click on Network Connections > right click the Lan Connection and select Properties.  Highlite TCP/IP and select Properties.  Click "Use the following IP Address, and put in the address I gave you above.  Do this on both machines.

Just make sure you are configuring the LAN Connection and not your Dialup.

FE
0
 

Author Comment

by:ronglen
ID: 13892025
Hi Fe,
Sorry for the long delay.

Do I choose "Microsoft tcp/IP" to modify?  When I go to "configure" I am not sure what value to change or add.  There is no option for "use the folowing IP address". There is a "locally administered address" item.

Sorry to be be dense, but this is new ground for me.

Thanks

Ron
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13897224
No problem.  You must be going to the wrong place.  Lets start again.

To configure a static address on a 2K/XP system:

Right click My Network Places and choose Properties
Right click Local Area Connection and choose Properties
Highlite TCP/IP and choose Properties
Choose "Use the following IP Address" and configure a static address.  Make sure you place the Default Gateway there, and then choose Advanced.  Go to the DNS tab and configure your DNS servers.

FE
0
 

Author Comment

by:ronglen
ID: 13897842
Hi FE,
I get to TCP/IP which says "Microsoft TCP version 6"
There is no "use the following IP address" anywhere. When I click on "configure, I can get to "advanced" which includes "locally administered address"
Is this what I have to change?

Is there any reason that you know of that this was not set up automatically when I set up the network?

Thanks

Ron
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13897929
No, that is not right...  If you are seeing V6, that is short for IPv6, which is the new 6 octet, 48 bit version that has been in development for the last few years.  This version combines your MAC address with an IP address, much like IPX does, and requires Ipsec.

You need to install v4 instead.  To do this, click:

Install > Protocol > IPv4

After this, you should see another TCP/IP Protocol where you can take the necessary steps outlined above.  You can also delete the V6 from the LAN Properties window...  :)

FE
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13897939
Hmm.. I wonder how you got V6 in there in the first place?  This does not install by default...  :)
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13897959
My mistake and I knew it when I typed it!   v6 is NOT a 48 bit, but a 128 bit address...  was thinking of a MAC address..  wanted to point that out to anyone else reading this thread!  and I got called out on it!  :)

BTW:  if anyone wants to read about v6, feel free to do so:

http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/intmgmt/14_xpip6.mspx
0
 

Author Comment

by:ronglen
ID: 13899429
Hi FE,
I am as confused as ever. I looked at the link above, ran print route and got:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Owner>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 07 e9 c2 02 f6 ...... Intel(R) PRO/100 VE Network Connection - Packet
Scheduler Miniport
0x40004 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     66.6.190.198    66.6.190.198       1
     66.6.176.178  255.255.255.255     66.6.190.198    66.6.190.198       1
     66.6.190.198  255.255.255.255        127.0.0.1       127.0.0.1       50
   66.255.255.255  255.255.255.255     66.6.190.198    66.6.190.198       50
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      169.254.0.0      255.255.0.0    169.254.16.61   169.254.16.61       20
    169.254.16.61  255.255.255.255        127.0.0.1       127.0.0.1       20
  169.254.255.255  255.255.255.255    169.254.16.61   169.254.16.61       20
        224.0.0.0        240.0.0.0    169.254.16.61   169.254.16.61       20
        224.0.0.0        240.0.0.0     66.6.190.198    66.6.190.198       1
  255.255.255.255  255.255.255.255     66.6.190.198    66.6.190.198       1
  255.255.255.255  255.255.255.255    169.254.16.61   169.254.16.61       1
Default Gateway:      66.6.190.198
===========================================================================
Persistent Routes:
  None

C:\Documents and Settings\Owner>

What now????

Ron
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 13900390
Lets go back to the original problem:   >>I do not see even my own computer in Microsoft network<<

I would bet you are running a mixture of IPv4 and IPv6 between your 2 machines, and that is the reason you cannot see the computer.   To resolve this, I would uninstall (delete) IPv6 and install IPv4 on that system.  (Or install IPv6 on the second machine).  Just so you know, the nice thing regarding IPv6 is that is does not use ARP requests to resolve the MAC address of the networked systems, since it is hardcoded into the IPv6 address.

Your route table reflects your PPP connection and the APIPA address.  I could go into detail about the routes and metrics, but that would not tell you how to resolve this.

If you are using only a PPP connection (dialup) to connect to the internet, and only wish to connect the 2 systems together for file sharing, I would install IPv4 on both systems, and create static addresses on each such as this:  (This is the address bound on the NIC itself, not the PPP Adapter - the modem)

Machine 1:

IP Address:  192.168.1.10
Mask:  255.255.255.0
Default Gateway:  The IP Address of the connected machine  192.168.1.11

Machine 2:

IP Address:  192.168.1.11
Mask:  255.255.255.0
Default Gateway:  The IP Address of the connected machine  192.168.1.10

These configurations will only work with IPv4, as the Addressing scheme is much different with IPv6, as can be seen in your TCP/IP configuration above, showing the IP Address of:   fe80::5efe:66.6.190.99%2 (which as you can see is an IPv6 Address, not a v4 address...)

When you throw IPv6 into the mix, it can get very confusing, even for those of us that are used to seeing it.  :)

FE
0
 
LVL 40

Accepted Solution

by:
Fatal_Exception earned 500 total points
ID: 13900408
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 14056407
:)
0
 
LVL 18

Expert Comment

by:crissand
ID: 14101479
I don't know. Can be the cable. :-)
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever set up your wireless router at home or in the office to find that you little pop-up bubble in the bottom right-hand corner of Windows read "IP Conflict - One of more computers on the network have been assigned the following IP address"…
Measuring Server's processing rate with a simple powershell command. The differences in processing rate also was recorded in different use-cases, when a server in free and busy states.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question