Folder Permissions problem

I asked this question in the Security area and am not getting much help.  Thought I would try reposting it here.

I have the following structure on a server \\Servername\sharename\folder.  Inside of folder I would like to create a structure and have NTFS enforce it so nobody can add edit or delete the file folders. That is to say they should not be able to add their own folders, and they should not be able to do anything to the folders I create under the share. However, They should be able to add edit and delete files.

As to permissions, I have right clicked the folder gone to security and then selected the advanced button.  From here I have the following options for security.

1) Traverse Folder / Execute File  Checked
2) List Folder / Read Data  Checked
3) Read Attributes Checked
4) Read Extended Attributes Checked
5) Create Files / Write Data Checked
6) Create Folders / Append Data UnChecked
7) Write Attributes Checked
8) Write Extended Attributes Checked
9)Delete Sub Folders and Files Unchecked
10) Delete Checked
11) Read Permissions Checked
12)  Change Permissions UnChecked
13) Take Ownership UnChecked
14) Full COntrol Unchecked

This is for the allow entry.  The deny entry is as follows.

Numbers 6, 9 12 and 14 are unchecked.

With these settings I get what I'm looking for on the folder security.  However, If a user edits a file they are not allowed to save it except to a new file name.

It does appear that these setting cause the modify permissions under the basic permissions to be unchecked.  Is there a way of doing this?

Thanks for the help in advance.
Guitarman316Asked:
Who is Participating?
 
luv2smileCommented:
Take a look at this PAQ...not exactly the same, but may help give you some ideas. NTFS permissions can be very complex.
0
 
2hypeConnect With a Mentor Commented:
All you would have to do is.

Go to the folder. Right Click it and select Properties
Go to the security tab.
Select Advanced.  Click Add.  Select the User you want to be able to add, modify, Delete the files.
A permissions box will the pop up.  Change the Apply  onto box to say "files only".
Give the user modify permissions or full control.

This will allow them to have full control or modify control on the files but not the folders or subfolders.  Therefore they will not be able to change any of the folders you setup
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.