FreeBSD 5.3-release and bind9

hello . this is an urgent

I have FreeBSD 5.3-RELEASE installed and  BIND 9.3.0 the thing is i never used bind9 and i can't really get it to work, i have a domain xxx.net and all i need is an example for a host like max.xxx.net. i have two nameservers NS1.XXX.NET and NS2.XXX.NET and 14 ips from a company i asked them to remove bind9 and install bind8 but the answer was that they have no one whois into this operating system "an advanced operating system intended for advanced users. " they replied. i played alot with bind9 but i know there is a mistake somewhere and i found that ndc was renamed to rndc which made it completely a mysterious to me. I just need help with a start and i'll do the rest. just an example to make x.x.x.x point to max.xxx.net


the real domain replaced by x's

Best Regards
adam
BBCGBAsked:
Who is Participating?
 
it_alchemistConnect With a Mentor Commented:

You can just install from ports.

First kill the existing bind daemon:

killall -TERM named

cd /usr/ports/net/bind84 (or /usr/ports/net/bind8 if you want bind 8.3.7)

make install clean

This will install bind 8.4.6 at the time of this writing.

If you want to completely replace the bind in the base system then you can do this instead:

make PREFIX=/usr PIDDIR=/var/run DESTETC=/etc/namedb DESTEXEC=/usr/libexec DESTRUN=/var/run DESTSBIN=/usr/sbin DESTHELP=/usr/share/misc install clean




   

0
 
David PiniellaCommented:
0
 
BBCGBAuthor Commented:
thats about suse not freebsd
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
BBCGBAuthor Commented:
or guide me through uninstalloing bind9 and installing bind8 because bind8 suits me very well.
0
 
BBCGBAuthor Commented:
i can't believe this. no one is offering a help on how to uninstall bind9 and install bind8 instead on FreeBSD 5.3-RELEASE
0
 
BBCGBAuthor Commented:
hello

i still get
box# named.reload
rndc: neither /etc/namedb/rndc.conf nor /etc/namedb/rndc.key was found

after replacing it with bind8 . named -v gives me this
box# named -v
named 8.3.7-REL Sat Apr  9 08:15:20 UTC 2005
        root@max.xxx.net:/usr/ports/dns/bind8/work/src/bin/named

anyideas how to make named.reload work as it was in bind8 because i tried to rename rndc but i still get this

box# named.reload
exec: /usr/sbin/rndc: not found

thanks
0
 
David PiniellaCommented:
bind is bind anywhere. bind on suse is the same as bind on freebsd
0
 
it_alchemistCommented:
named.reload is not a BIND command, but part of the FreeBSD system. It's a customised script which in your case is expecting to find BIND9. 6 months ago, before FreeBSD switched to BIND 9, it was a very basic call to:

/usr/sbin/ndc reload

so you can have the same functionality by just issuing an:

ndc reload





0
 
David PiniellaCommented:
" i can't believe this. no one is offering a help on how to uninstall bind9 and install bind8 instead on FreeBSD 5.3-RELEASE"

your original question did not specify that you wanted this; you asked for an example of a bind9 host configured. you posted a comment suggesting that if no one could show this (i did, above,) then show you how to uninstall bind 9 and install bind 8...exactly 10 minutes later, you're surprised no one has done this?

consider installing webmin and configureding your DNS that way.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.