• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 804
  • Last Modified:

PIX 501 - Can't open inbound ports?

Hello, I went to a customer today to open some ports on their PIX502 and map it to their server.  They have 1 IP (I've named it 1.2.3.4 for this post).  All works well outbound and the vpn's inbound work.  For some reason the ports I mapped (25,80,443,444,3389,4125) won't open.    There are some leftover things there from a previous IT company but all they need now is the vpn and the outside ports open.  I must be missing something obvious.  Thanks for your help!

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password dfgdfg encrypted
passwd dfsgdfg encrypted
hostname test
domain-name test
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list nonat permit ip 192.168.3.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list nonat permit ip 192.168.3.0 255.255.255.0 10.254.254.0 255.255.255.0

access-list acl_out permit icmp any any
access-list sitevpn permit ip 192.168.3.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 199 permit tcp any host 10.0.0.10 eq pcanywhere-data
access-list 199 permit tcp any host 10.0.0.10 eq 5632
access-list 199 permit icmp any any
access-list 199 permit tcp any host 10.0.0.11 eq 3389
access-list Outside_coming_in permit tcp any host 1.2.3.4 eq smtp
access-list Outside_coming_in permit tcp any host 1.2.3.4 eq www
access-list Outside_coming_in permit tcp any host 1.2.3.4 eq https
access-list Outside_coming_in permit tcp any host 1.2.3.4 eq 444
access-list Outside_coming_in permit tcp any host 1.2.3.4 eq 3389
access-list Outside_coming_in permit tcp any host 1.2.3.4 eq 4125
access-list split permit ip 192.168.3.0 255.255.255.0 10.254.254.0 255.255.255.0

pager lines 24
logging on
logging timestamp
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside 1.2.3.4 255.255.255.252
ip address inside 192.168.3.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.254.254.1-10.254.254.254
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 1.2.3.4 smtp 192.138.3.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 www 192.138.3.2 www netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 https 192.138.3.2 https netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 444 192.138.3.2 444 netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 3389 192.138.3.2 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 4125 192.138.3.2 4125 netmask 255.255.255.255 0 0
access-group Outside_coming_in in interface outside
route outside 0.0.0.0 0.0.0.0 1.2.3.3 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
ntp server 128.252.19.1 source outside prefer
http server enable
http 1.2.3.2 255.255.255.255 outside
http 0.0.0.0 0.0.0.0 outside
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss minimum 48
sysopt connection permit-ipsec
service resetinbound
service resetoutside
crypto ipsec transform-set trset esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 86400
crypto dynamic-map dynmap 30 set transform-set trset
crypto map trvpn 20 ipsec-isakmp
crypto map trvpn 20 match address sitevpn
crypto map trvpn 20 set peer 1.2.3.1
crypto map trvpn 20 set transform-set trset
crypto map trvpn 30 ipsec-isakmp dynamic dynmap
crypto map trvpn client configuration address initiate
crypto map trvpn client configuration address respond
crypto map trvpn interface outside
isakmp enable outside
isakmp key ******** address 1.2.3.1 netmask 255.255.255.255
isakmp identity address
isakmp keepalive 10 5
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup trdialvpn address-pool ippool
vpngroup trdialvpn dns-server 192.168.3.2
vpngroup trdialvpn wins-server 192.168.3.2
vpngroup trdialvpn default-domain trileaf.com
vpngroup trdialvpn split-tunnel split
vpngroup trdialvpn idle-time 3600
vpngroup trdialvpn password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 15
ssh timeout 30
console timeout 15
username cdsadmin password Aa.dR2pvx/woulES encrypted privilege 15
terminal width 80
0
JCDavis64
Asked:
JCDavis64
1 Solution
 
martapCommented:

try a :

clear xlate

to reset all translations.
0
 
lrmooreCommented:
This:
http 1.2.3.2 255.255.255.255 outside
http 0.0.0.0 0.0.0.0 outside

May interfere with this:
 static (inside,outside) tcp 1.2.3.4 https 192.138.3.2 https netmask 255.255.255.255 0 0

The PIX won't be able to listen/serve up GUI on port 443, and port forward it at the same time to an internal server.
0
 
alex_yalaCommented:
static (inside,outside) tcp 1.2.3.4 smtp 192.138.3.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 www 192.138.3.2 www netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 https 192.138.3.2 https netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 444 192.138.3.2 444 netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 3389 192.138.3.2 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp 1.2.3.4 4125 192.138.3.2 4125 netmask 255.255.255.255 0 0

I think it is obviously a typo mistake with 192.138.3.2  when your network is on 192.168.3.x
Is that a typo mistake when you paste the config to EE, or a typo mistake when you type the config to the PIX?

Good Luck.

Alex.
0
 
lrmooreCommented:
Alex, good catch!

>PIX Version 6.3(1)
There is also a bug in this version that sometimes prevents statics from 'sticking' until you reboot...
0
 
JCDavis64Author Commented:
Yep, that would do it alright!  I knew it had to be something stupid like that.  I scrutinized that config about a hundred times.  I suppose if I was typing each command I would have caught it but I typed it once in notepad then pasted the mistake.  All 125 points go to Alex Yala!  Thanks again!
0

Featured Post

Get Certified for a Job in Cybersecurity

Want an exciting career in an emerging field? Earn your MS in Cybersecurity and get certified in ethical hacking or computer forensic investigation. WGU’s MSCSIA degree program was designed to meet the most recent U.S. Department of Homeland Security (DHS) and NSA guidelines.  

Tackle projects and never again get stuck behind a technical roadblock.
Join Now