[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 374
  • Last Modified:

XP Windows Update not working

XP Home  SP1

As far as I know, never had any Msoft updates applied...

Problem:
When going to Windows Updates, click on either Express or Custom install...and the little green bar will march from left to
right and never stop...

There are NO error messages, the green progress bar just keeps moving...longest time before I shut it down was about 35 minutes...

Downloaded the iuctl cab files, extracte and installed the files...made no difference...

Tried Bigfix.com but it doesn't appear that they are offering windows update files anymore...

Went into administrator options and downloaded a few individual files, IE Explorer SP1, couple others thinking I might get something that will fix the issue...nada...

Not sure what else to try...

Suggestions???

STeve



0
stevem5000
Asked:
stevem5000
  • 6
  • 6
  • 3
  • +3
5 Solutions
 
stengeljCommented:
If it's failing on SP2, it could be because your WinXP product key was deemed 'invalid' by Microsoft.  More info:

"You receive a "The product key used to install Microsoft Windows may not be valid" error message when you try to install Windows XP Service Pack 2"-http://support.microsoft.com/default.aspx?scid=kb;EN-US;883254

Usually, you would see an error about it though...Does the event viewer show any errors?
0
 
Leandro IaconoCommented:
This could also be an ActiveX problem ....
http://www.experts-exchange.com/Operating_Systems/Q_21370484.html
0
 
stengeljCommented:
Found this while I was poking around...seemed to work for other similar cases.

Click Start > Run > Type cmd.exe

Type:

net stop cryptsvc [Enter]
ren %systemroot%\system32\catroot2 oldcatroot2 [Enter]
net start cryptsvc [Enter]

Then try your updates. The 'catroot2' folder will be recreated automatically (although you may have to reboot).

Source: http://www.bootdisk.com/xptop20.htm

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
r-kCommented:
Also, check the contents of:

 c:\windows\windows update.log

and see what is in:

 c:\windows\SoftwareDistribution
0
 
stevem5000Author Commented:
OK...we might be getting somewhere...

Went thru the suggestions above, still not working...


I went thru the catroot2 renaming, didn't help...it's not a product key issue...

However, when I checked the SoftwareDistribution folder, there are a number of folders with names like c9bikl9837jkfl0 etc...I went thru some of those folders and I found references to SP2...

I am begining to suspect an attempt to download SP2 failed...

Additional info...
this is a friends computer I am trying to get updated...runs on a dial up modem, and we are installing DSL...the DSL installation would not work correctly...so I brought the computer home where I have DSL...It has been running very slowly and got to the point where he cannot get on the internet using dialup...

I found 14 viruses, cleaned them, a small amount of spyware...nothing "big" like about:blank...cleaned that and also did a Trendmicro online scan, found one spyware, cleaned it...

I have the computer working on the internet very nicely with my dsl connection...running at "normal" speed and performs like nothing is wrong...

Except I can't do Windows update...

Thanks for the help...anything else???

Steve
0
 
r-kCommented:
Check the clock (including date) to be sure it is set correctly.
0
 
stevem5000Author Commented:
r-k...
The time was off by some 4  hours...wrong time zone and clock was off also...day was right...

I have heard of cases where the computers can't sync with Msoft servers because of time being off...but didn't work in this case...

Still no joy...

Steve
0
 
r-kCommented:
Is the machine currently at SP2? If not, you could just download the XP2 update separately as an exe file (200+ MB) and try installing that first, before trying the online updates.

Also, consider deleting the contents of the c:\windows\softwarediestribution\download folder (but don't delete the other sub-folders).
0
 
stevem5000Author Commented:
"there's somethin' happenin' here"..."what it is ain't exactly clear"...

Here is what I did...

Found info here  http://www.wilderssecurity.com/showthread.php?t=31559 on re-registering some dll's, which I did...no joy...

I deleted the download folder in c:\windows\softwarediestribution\...rebooted and THIS time, (although I didn;t notice it right away...maybe 10 minutes later or so)...the automatic updates icon was in the taskbar...there were about a dozen downloads listed ready to install...I tried it, didn't work...

I went back into Automatic updates and found a "custom install" and was able to install all the updates a few at a time...did it in 3 different installs...

Now, I still cannot connect and get my updates...I have made some progress, but it still works like I indicated in my original post...

There is something wrong deeper inside...I am going to try a XP restore, or a scannow, and if that doesn't work...I'm gonna do a complete rebuild...

Many thanx for the help...

I'll wait a little while and see if anyone has any more ideas, but if nothing else works I will start the rebuild later tonite...

Steve

0
 
stevem5000Author Commented:
r-k...I ment to mention that it is NOT on SP2...and I don;t know what updates it has and SP2 usually requires some updates to  be applied before you can install SP2...

But I will try the SP2 download before I rebuild...

Thanx
Steve
0
 
r-kCommented:
You might try the simpler step of running the SysTem File Checker first:

      (a) Place Windows/XP CD in CD drive
      (b) Type "sfc /scannow" at the command prompt.

see http://support.microsoft.com/default.aspx?scid=kb;en-us;310747

0
 
r-kCommented:
Re. SP2, I am pretty sure you don't need any other updates before SP2 can be installed.
0
 
theruckCommented:
last time i had problems with windows update it was solved by setting the right time and ate (you said you just tried it) and running:
cmd
proxycfg -u

0
 
Mohammed HamadaSenior IT ConsultantCommented:
Here's not a big thing, but just try it out

Download the below file.
http://members.aol.com/toadbee/hoster.zip
Before running you should close All your IEs.
After you extract it, run the hoster and then click on Restore Original Hosts, then click Make hosts read only.
Then reboot.

Also it could be a registry key issue.
Try those links
http://www.ccleaner.com
http://boozet.xepher.net/beclean/download.htm
http://www.pcworld.com/downloads/file_description/0,fid,22384,00.asp

Hope this help
0
 
stevem5000Author Commented:
Well...this thing has gone from "bad" to "ugly"...

I was able to download and, it appears, to successfully install SP2...it did NOT come from Windows Updates...but I downloaded the whole 266 Mb and ran the install locally...everything appears normal...

Except:
IE won't work...can't ping...will get IP from my server, static DNS doesn't help...

There is something "wrong" and it isn't obvious...
Since I have already put in about 3 hours on this and there is no end in sight...I'm going to wipe the HD and re-install everything from scratch...at least then I'll know what I have to work with...

Many thanx for all your help and ideas...all of them were good and I'll split the points out to everyone, hope this is ok...

Steve
0
 
r-kCommented:
Sorry to hear about the continuing problems. If you had the time and wanted to try one last thing, do give the system file checker (sfc /scannow) a try as mentioned above. Good luck.
0
 
stengeljCommented:
Bummer...save SP2 on a disk before you wipe it so that you don't have to redownload it!
0
 
stevem5000Author Commented:
Guys..thanx...

Here it is, late on a Sunday evening...Don't you have anything better to do than hang around EE and help us dummy's out???..:)

Didn;t try SFC and didn't think about saving SP2...

Oh well....

Thanx again
Steve
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 6
  • 6
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now