[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 753
  • Last Modified:

Does anyone have the proper USR Sportster V.92 Config wih Cisco Router for OOB on an AUX Port?

I have connected Sportster modems to Cisco routers in the past and had good success.  I saw detailed config suggestions from lrmoore and others for the old 33.6 models as answers to previous questions.  I have change DIP switch settings and tried some AT commands on the modem.  I have also tried customizing the Stopbits and other modem specific features on the AUX port.  I am trying to dial in from Hyperterminal under Windows XP.  When I first set this up I could connect to the modem but never got a Login to the Router.  After making more changes I have had difficults even get past the handshake and get a connection.  
0
liquidrules
Asked:
liquidrules
  • 3
  • 2
1 Solution
 
-Leo-Commented:
Please see part of my working config (Cisco 2520 router and USR Sportster 56K modem)


interface Async4
 description dialup
 ip unnumbered Ethernet0
 encapsulation ppp
 async mode interactive
 peer default ip address pool default
 ppp authentication pap ras
!
line aux 0
 modem InOut
 modem autoconfigure discovery
 transport preferred none
 transport input all
 autoselect during-login
 autoselect ppp
 speed 38400
0
 
-Leo-Commented:
Also, you should set your modem for autoanswer (via reverse-telnet to the modem)

Read here reagrding reverse telnetting: http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a00800871ec.html
0
 
liquidrulesAuthor Commented:
Your config was very helpful.  But, I am still having a problem even though it is much more isolated.  Whenever I reboot the router the speed setting changes from 38400 (even though this is specified in the Startup) to 115200.  If I try dialing in I get garble.  If I go in via telnet or the console port and change line aux 0 to speed 38400 then I am able to connect every time and am able to read the screen.  If there are way to force the router to keep the speed 38400 after it boots up?  Any other suggestions?
0
 
-Leo-Commented:
Check your modem configuration - "modem autoconfigure discovery" tooks modem settings and thats probably why you having 115200 after every reboot.

Reverse telnet to your modem and see its configuration with ATI4 command.

Look here for AT commands: http://www.helpdesk.umd.edu/topics/communication/dialup/hardware/2153/

If you having problems with reverse telnet - connect your modem to the PC's com port and start HyperTerminal.
0
 
liquidrulesAuthor Commented:
Thanks for the update.  I have limited experience with these settings but do not see anything related to 115200.  I have included a dump of the ATI4 command below and a dump of the show line aux 0 after reboot.  However, I did notice that even though I specify 38400 in the startup-config, when the router re-boots both with AND without the modem attached the speed on the aux port is changed to 115200.
             
ATI4
U.S. Robotics 56K FAX EXT Settings...

   B0  E1  F1  M1  Q0  V1  X4  Y0
   BAUD=9600  PARITY=N  WORDLEN=8
   DIAL=TONE    ON HOOK   CID=0

   &A0  &B1  &C1  &D0  &G0  &H0  &I0  &K0
   &M4  &N6  &P1  &R2  &S0  &T5  &U6  &Y1

   S00=001  S01=000  S02=043  S03=013  S04=010  S05=008  S06=004
   S07=060  S08=002  S09=006  S10=014  S11=070  S12=050  S13=000
   S15=000  S16=000  S18=000  S19=000  S21=010  S22=017  S23=019
   S25=005  S27=000  S28=008  S29=020  S30=000  S31=128  S32=002
   S33=000  S34=000  S35=000  S36=014  S38=000  S39=000  S40=001
   S41=000  S42=010

   LAST DIALED #:

OK

show line aux 0

     5 AUX 115200/115200- inout     -    -    -      0       0     0/0       -                                                                              

Line 5, Location: "", Type: ""                             
Length: 24 lines, Width: 80 columns                                  
Baud rate (TX/RX) is 115200/115200, no parity, 2 stopbits, 8 databits                                                                    
Status: No Exit Banner, Modem Detected, CTS Raised                                                  
Capabilities: Modem Callout, Modem RI is CD, Modem Discovery                                                            
Modem state: Idle                
Modem hardware state: CTS* noDSR  DTR RTS, Modem Configured
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                ^^x    none   -     -       none
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
               00:10:00        never                        none     not set
                            Idle Session Disconnect Warning
                              never
                            Login-sequence User Response
                             00:00:30
                            Autoselect Initial Wait
                              not set
Modem type is default.
Session limit is not set.
Time since activation: never
Editing is enabled.
History is enabled, history size is 20.
DNS resolution in show commands is enabled
Full user help is disabled
Allowed input transports are pad telnet rlogin udptn.
Allowed output transports are pad telnet rlogin.
Preferred transport is none.
No output characters are padded
No special data dispatching characters
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now