• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 307
  • Last Modified:

Printout Method Best Mode Printing

When i use the following statements to print out a report directly

Report.PrintOut False, 1, False

The print out comes, but the printer prints in best quality mode, instead of the econo mode, which is set in the printer properties through control panel.

I have tried working of this module with different printers and different computers, everywhere it prints only in best mode, instead of econo mode.

Can anyone suggest why this could be happening.


0
s_monani
Asked:
s_monani
  • 4
  • 3
2 Solutions
 
mlmccCommented:
When you open the report in Crystal, how are the printer properties set?  You may need to set the econo mode through the FILE --> PRINTER SETUP in Crystal.

mlmcc
0
 
s_monaniAuthor Commented:
The report is part of an appl. developed in VB and is used as an RDC.

I checked the options in the report designer, where it shows the econo settings done, still the print out comes in the best mode.

Further i also tried using NO PRINTER option. But enabling this options sends no job to the printer !

0
 
mlmccCommented:
The NO PRINTER option is just that, there can be no printouts.

Not sure about the other problem.   Are you printing directly from the application or does the printer dialog come up?

What printer?

mlmcc
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
s_monaniAuthor Commented:

Direct print out, No Dialog box pops up, as the statement is given.

Tried on two different printers HP 1010 and HP 1315 printers.

HP 1010 is remotly connected and HP 1315 is locally connected.

ke.
0
 
mlmccCommented:
One of the FALSEs controls whether the dialog box pops up.  Change them to TRUE and see if you can change it when the report is printed.  Not sure if this is something you can control through code or not.

mlmcc
0
 
s_monaniAuthor Commented:
Doing that will take away the desired functionlity from the system

Otherwise i have checked, the document gets printed properly when it is printed from the Crystal Viewer Control.

ke.

0
 
mlmccCommented:
Was the report originally built with the printer set to default to econo mode?  If not

Set the printer in the mode you want it through PRINTERS
Open the report
Verify printer settings are as desired.  If not set them
Save the report

mlmcc
0
 
vidruCommented:
If you'll be printing to the default printer, you could try this:

Printer.PrintQuality = vbPRPQLow  'or vbPRPQDraft
Report.SelectPrinter Printer.DriverName, Printer.DeviceName, Printer.Port

-dave
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now