• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 809
  • Last Modified:

How to enable jumbo frames

I always thought it was just upping the MTU on the interface, but apparently that doesn't work?

osaka root # ifconfig eth1 mtu 9000
SIOCSIFMTU: Invalid argument

Card is a Netgear GA311 (uses Realtek 8169).. i'm using the NAPI Tx/Rx polling option on 2.6.11 kernel.
0
Chireru
Asked:
Chireru
1 Solution
 
MKraussCommented:
thasts maybe a bug within the driver, there are a couple issues with 8169 on 2.6.11,
see: http://kerneltrap.org/mailarchive/1/search/author/Francois%20Romieu .
If you have a chance then try 2.6.12-rc2 .
0
 
prof666Commented:
Asked the same question myself:

http://www.experts-exchange.com/Networking/Linux_Networking/Q_21178421.html

let me know if you get an answer (as I also need to get this sorted). Looks as if the current drivers won't allows MTU above 1500 (any value about 1500 returns an error). I'm currently on Kernel 2.6.8 (SuSE 9.2).
0
 
ChireruAuthor Commented:
My thoughts are that two things could be wrong with my setup:
1) I'm running gentoo's sources (they differ from the vanilla)
2) I enabled the NAPI Tx/Rx polling option

So I've disabled the option, and grabbed the latest vanilla kernel to try with, but have had no time to try it.

By the looks of a few of the messages linked by MKrauss, there may be a problem with the driver, but there is no-one there specifically stating that.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
ChireruAuthor Commented:
After upgrading to the newest kernel, and disabling NAPI, I can raise the MTU to 7200

osaka root # ifconfig eth1 mtu 7200
osaka root # ifconfig eth1 mtu 7201
SIOCSIFMTU: Invalid argument
osaka root # ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:0F:B5:44:46:71
          inet addr:10.10.222.2  Bcast:10.10.222.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:b5ff:fe44:4671/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:7200  Metric:1
          RX packets:1674 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1861 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:223898 (218.6 Kb)  TX bytes:1193570 (1.1 Mb)
          Interrupt:5 Base address:0xe000


Not sure if I could do this with the old kernel or with the NAPI option though.  Anyone have a clue why it won't go higher?
0
 
prof666Commented:
How to disable NAPI, so I can test it on my system to see if this is limited to the newer kernel?
0
 
ChireruAuthor Commented:
>  How to disable NAPI, so I can test it on my system to see if this is limited to the newer kernel?

It's an option in the kernel, under the r8169 driver
0
 
ChireruAuthor Commented:
So... no ideas on how I can get 9k jumbo frames working?
0
 
NetminderCommented:
Closed, 250 points refunded.
Netminder
Site Admin
0
 
DanJCommented:
Netgear GA311 largest MTU is 7000
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now