IPSEC service sets automatically to disabled

Hi all,

I had the IPSEC services disabled on a group of windows 2003 servers with  Citrix Metaframe XP FR3. I upgraded Citrix to Presentation Server 3, and it needs IPSEC services to start the main services, IMA. So I set the service to automatic, and I do the upgrade. The problem that I have is that sometimes (I can't find a pattern for it) I receive the following error:

Source: Service Control Manager
Category: None
EventID: 7040
User: NT AUTHORITY\SYSTEM
Description: The start type of the IPSEC Services service was changed from auto start to disabled.

So as you can see, the system is disabling the service, and so the IMA service Stops, and so, none of the users can access the server.

If I set the IPSEC service to automatic, and I start the services, or I reboot the server, everything starts working again, until the system account decides its time to disable the service again.

Any idea about this?
dmadiedoAsked:
Who is Participating?
 
NJComputerNetworksCommented:
You might want to create a Group Policy for these Citrix servers...make the GPO set the IPSEC to Automatic ...



Computer Config - Windows settings - System Services- IPSEC




0
 
theruckCommented:
is not the citrix software able to start the service itself if you set the IPSEC service to Manual?
0
 
NJComputerNetworksCommented:
A note that I found regarding Citric and Windows 2003 SP1 (Warning not to apply the SP 1):  http://techrepublic.com.com/5208-6230-0.html?forumID=3&threadID=171505&start=0

0
 
dmadiedoAuthor Commented:
Thanks NJComp... for your help.

One of my coworkers did what you recommended, setting the service as disabled. This was the cause of all my troubles. I only noticed it until I entered to follow your directions.

0
 
NJComputerNetworksCommented:
Glad it helped you.  GPO's are great for central management.  Talk to you later...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.