Slow performance with SCSI SX150176LC 7200 rpm drive

Hello,
I have a Dell Dimension 2400 with a western digital 40 gig. hard drive# 400BB,7200 rpm. --- and I changed it with a Seagate 50 gig. SCSI  SX150176LC 7200 rpm. With Adaptec AHA-2940U/2940UW/2940D PCI SCSI Controller.  Both drives have Cluster size 4 KB. And I ran a performance test from passmark software  version 5.0 on both drives. The Seagate runs much slower. This is my first SCSI drive. The disk sequential write, read and the disk mark is very slow! It should be just as fast or faster then the western digital. Any ideas? Dave
davekuharAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sciwriterCommented:
<< The Seagate runs much slower >>

WD will always run faster than a Seagate, even with SCSI.  The biggest problem with Seagate, which has radically decreased their market share in recent years, is that some time ago, they instituted a "forced" power down of the drive, to conserve .. what I don't know, because on many systems, they will simply time out after sitting idle for several minutes.  It is difficult to see why they did this, and equally difficult to undo it -- it is not related to windows power management settings, it is something built into the controller logic on the drive.  Perhaps seagate has a utility to undo it.  I have never bothered to look, because we no longer recommend these drives to any corporate clients.  In addition, the warranty on seagate seems to depend on where you bought it, so a supposed 3 year warranty can drop to 90 days under common circumstances.  

The most reliable drives for SCSI and IDE use are Fujitsu (only now SCSI, they dropped the IDE line), and IBM_Hitachi (still made by IBM plants, marketed by Hitachi with less of a warranty than IBM gave).  Others have had great luck with WD -- we got a series of them several years ago, where the seek heads died after 6 months to 1 year on 100% of the drives we ordered, over a 3 year period.  So you know my prejudice for long-term reliable drives, from many years experience.

More to your situation, stick with the WD if it is working fine.  Use another drive as a backup, and perhaps not go with SCSI unless you want to do a SCSI RAID array with that controller.
0
davekuharAuthor Commented:
mmmm, I see, well the Seagate 50 gig. SCSI  ST150176LC 7200 rpm. has a average read time of 7.6ms. --And the western digital 40 gig. hard drive# 400BB,7200 rpm. shows-Read- Write 8.9 ms (typical) 18 ms (maximum) 10.9 ms (typical) 20 ms (maximum) So I would think the Seagate would be faster. the performance test for       seagate shows----write 9.2MBytes/Sec.,, read 14.6MBytes/Sec.,, and disk mark 89.4.  western digital ---write 26.8MBytes/Sec.,,read 39MBytes/Sec.,, and disk mark 180.2. That's a big difference! I would think that it should be closer. I think something is not set up right! Settings??
0
sciwriterCommented:
<< So I would think the Seagate would be faster >>

Yep, that's what the specs would suggest.  I've concluded it is basically a Seagate scam.  You can try the SCSI controller, to boost the data throughput, that will help, but you wil border on unreliable writes and inconsistent reads.  The fact that the WD is doing 2x 3x what the seagate does is exactly what we found.
0
mysticaldanCommented:
Have u tried entering the SCSI card BIOS by hitting CTRL-A at bootup time and configured it to take advantage of extra features?? My Seagte gives me more than 2 times better rates and its just a 16 Gb hard disk 7200 RPM. You need to make sure the SCSI card is setup properly. Check if there is any utility also available from the adaptec website http://www.adaptec.com/worldwide/support/drivers_by_product.jsp?sess=no&language=English+US&cat=/Product/AHA-2940


Dan
0
davekuharAuthor Commented:
UPDATE-----
To sciwriter,,, I'm not going to give up that easy! I might be learning the hard way. I can't deal with unreliable writes and inconsistent reads!

To mysticaldan,,, Im using windows XP Pro. I don't see anything on that site for XP. And I don't know how to configured it to take advantage of extra features. This is my 1st SCSI. I don't want to lose or blow anything.
0
sciwriterCommented:
The way to get into the controller is to just press Control-A as you are booting, assuming a standard adaptec-type SCSI controller -- then you can do all sorts of performance enhancements -- but make sure you TEST them before you asssume they are good.  SCSI2 allows writes faster than the drives will handle it, keep that in mind....

I did not suggest you "give up"  -- I just explained, that in our experience, seagate did not live up to its claims -- a statement of realism, more than anything else.  It is easy enough to get into the Adaptec controller, and configure it, but it is another matter to get the drives to where they will perform to rated specs.

WE tried this and gave up.  Have since recommended IDE RAID controllers with fast, reliable IDE drives and dump the SCSI, and so far, everyone has been tickled pink.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mysticaldanCommented:
After the memory check when ur system boots u will have a screen saying Hit CTRL-A to enter SCSI setup. Just enter the setup and enable enhanced mode and other features related to boosting performnace. Dont change any other setting related to SCSI termination etc.

Write down the original settings when u enter the BIOS and u can always change them back. Unless u do a format of the drive from the menu which i know u wont u do not really risk anything by changing settings.

Do not change any settings related to the Bootup time or sequence and u shud be able to enable the setting. It will be generally just one setting to enable Enhanced mode and thats all thats needed to make ur drive go faster.

Dan
0
davekuharAuthor Commented:
Hello,
During bootup I went into F2 just to look aroound and found that the ---Host adapter SCSI termination is on---automatic.  Again, during bootup I went into CTRL-A and the only thing i can find to boost performace was in---advanced configuration options /--support for ultra SCSI speed, which wasn't enabled. I enabled it and there was no difference in the performace test. I don't see anything anywhere to enable it to enhanced mode. Now what?
0
mysticaldanCommented:
Well Ultra SCSI needs to be enabled to take advantage. ANother thing you can try is to load the new drivers for ur card. You need to know the model though. Use Everest http://www.lavalys.com/products/overview.php?pid=1&lang=en&pageid=1
and run it to see who is the manufacturer of ur card and then load the exact drivers rather than the generic ones that Windows loads. Leave SCSI termination to AUTO. What is the SCSI disk formatted as? In case its as an NTFS disk i suggest u try formatting it as a FAT32 disk and see the difference. I have been able to get a nice boost just by doing that.

Dan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.