Created my first crystal report with wizard want an adjustment with groupings.

I've created my first Crystal Report - with a wizard called Budget Reports.
I did have a particular field called Alternate that I went ahead and grouped the entire report by.
I only have two records for Alternate - one is Base Bid and the 2nd is Future so its not a long report.
Thus I have two pages - one for Base Bid Budget and the 2nd for Future Budget.
What I want to do is to list both of these on the same page!  But I don't see any options to declare this header group to not start with a next page.
Please help - my first attempt at Crystal Reports.
I appreciated it a lot!.
LVL 1
stephenlecomptejrAsked:
Who is Participating?
 
hulitkCommented:
You can check under the Report menu > Change group expert.  Under the options button check to see if the "keep groups together" box is checked, if it is uncheck it.  


 
0
 
mlmccCommented:
There are other possibilities
Open the report
Click FORMAT --> FORMAT SECTION
Select each section in turn
   Check to ensure you don't have NEW PAGE BEFORE or AFTER clicked.
   Check to ensure the KEEP TOGETHER is not checked.

mlmcc
0
 
frodomanCommented:
Another thing to check is for empty space in the design - if you have a lot of white space in a section above your fields, Crystal will keep that white space and the total size of the section may be taking up too much space on the page.  Try squeezing things together on the design layout if none of the above suggestions helps.

frodoman
0
 
stephenlecomptejrAuthor Commented:
I've tried all of your suggestions and checked all the settings accordingly and none of which has New Page before or New Page after checked off.  I've tried checking each individual setting for New Page After/Before and also the white page and still not working...
Sometimes a combination of settings for others may cause conflict so I've listed them below.  Is there an original glitch that a service pack may need to be run to fix this?

This is what I have accordingly below.
Report Header (Keep together)(Suppress No Drill-Down)(Free-Form Placement)
Page Header
  Page Header a (Free-Form Placement)
  Page Header b (Free-Form Placement)
Group Header#1: sp_GetBudget
  Group Header#1a (Free-Form Placement)(Keep together)
  Group Header#1b (Free-Form Placement)(Keep together)
Details (Free-Form Placement)(Keep together)
Group Footer#1: sp_GetBudgetFooter
  Group Footer#1a: sp_GetBudgetFooter (Free-Form Placement)(Keep together)
  Group Footer#1b: sp_GetBudgetFooter (Free-Form Placement)(Keep together)
Page Footer (Free-Form Placement)
Report Footer (Keep together)(Suppress No Drill-Down)(Free-Form Placement)
Any of these settings may cause a conflict with the end result?
0
 
mlmccCommented:
Glad i could help

mlmcc
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.