?
Solved

XP Pro to XP Home network crossover

Posted on 2005-04-10
15
Medium Priority
?
329 Views
Last Modified: 2010-04-10
I have purchased a new computer, it has XP Home, FAT32 filesystem.  I want to network this new computer with my main computer (server) which runs WinXP Pro.  The ICF works as I am typeing this message on the new computer (client).  The problem is the file shareing.  I get the message:

“\\<computer name> is not accessible. You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.

The XP Pro is on NTFS file system, where the client XP Home is Fat32.  The computers are connected via crossover cable, (I Know I will be buying a router in the very near future), for now I need to get the file shareing to work with the existing crossover cable.

The ICF has been disabled on both computers, they both are in workgroup MSHOME, Simple fileshareing disabled on server.  On server the folder to share has been enabled for shareing and permissions given for username blakelock, the client has been set up with a blakelock acount and same password to match the acount on the server.

I dont understand how this can be hapening.  I need a solution for this.
0
Comment
Question by:jetsonsblue
  • 6
  • 5
  • 3
  • +1
15 Comments
 
LVL 3

Expert Comment

by:woof-dog
ID: 13750379
Make sure no other firewqall is running.

Are you trying to mount (map) the C: drive?  If so don't forget you use \\I.P address\c$ or $c (can't remember), or instead of c$ or $c put in whatever you are using as a share name.

Ok if you already doing that try sharing a folder not a drive.  Example setup a sharing and a folder on computer A say folder 'test' then mount it from Computer B, example \\I.P address\test
0
 

Author Comment

by:jetsonsblue
ID: 13750503
Not wanting to share entire drive, I have set several folders includeing My Documents for shareing.  These shares apear in network places, however when I try to access them, I have the error.

What do you mean by trying to mount it?
0
 
LVL 88

Expert Comment

by:rindi
ID: 13750733
XP with SP2 has an automatically enabled firewall. Either disable this or configure it so that your networking functions are open (exceptions tab of the firewall, file an print sharing as exception, tcp ports 139, 445 and udp ports 137, 138 must be allowed). You will find the windows firewall under control panel. If you have a further firewall installed, you must first decide on which one you want to use. Some antivirus products also have some firewall functions, I believe mcaffee has such a product, symantec has different such products (internet security) etc. Then disable the firewall you aren't going to use and add the above settings to the one you are going to use.
You will also have to to add the user "blakelock" to those which are allowed access to your shares (check the "shares" properties).
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 18
ID: 13751662
When putting peer to peer sharing in place with XP Pro and XP Home, I have found out that the administrative share c$ does not always work.  You have to have all the basics in place like the same subnet and same workgroup first as well as file and print sharing turned on.  If you have SP2, the firewall must also have file and print sharing enabled.  What I have done to get around this is to share the drive with a different drive letter.  So, since c$ didn't work, I shared it a C or CDrive.  It has worked every time.
0
 

Author Comment

by:jetsonsblue
ID: 13752807
How do I go abouts changeing the share name from c$ to C
0
 
LVL 88

Expert Comment

by:rindi
ID: 13752888
Just right click the directory you want shared, select "sharing and security", then the "sharing" tab. Now select "share this folder", enter a share name, don't make the name too long and don't use special characters or spaces. If it is the complete drive you want to share, you'll have a sharename already (Drive$), then just click the button "new share"...
0
 

Author Comment

by:jetsonsblue
ID: 13753037
Ive gone into the firewall config, and turned it off, I then went to the exceptions tab and unchecked everything.  For the folder in which I want to share, on shareing and security, I have added for the permisions, blakelock.  There is no other firewalls, installed.

I tryed to find where I can rename the $c but cannot seem to find it.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13753256
You don't need to rename it, just create a new share. If I were you I wouldn't share at drive level, I believe it is better to share at directory level, it is safer and you can't wreck as much (If it is a system drive, it would be possible to delete important system files).

Also, in the firewall config you should only uncheck those exceptions you don't want. If you want your PC to be able to share folders and printer, the file and printer sharing exception must be checked.
0
 

Author Comment

by:jetsonsblue
ID: 13758950
the reason for wanting to rewname the c$ share was reguarding samccarthy's post.

I just rechecked the file and prionter shareing, but the problem still exists.  So now firewall is turned off and in exceptions file and printer shareing is checked.

I have now set 3 folderas foer share, and in shareing and security, ive addewd the user blakelock and given full access.  The problemn still exists.

Just to clerify

Comp A - WinXP PRO Sp1 - ntfs
Comp B - WinXP Home Sp2 - fat32

Same workgroup, ipx protocol,  
0
 
LVL 88

Accepted Solution

by:
rindi earned 500 total points
ID: 13759439
Use tcp/ip, not ipx protocol. IPX was a protocol used for early netware systems, and isn't used anymore today. Routers and gateway devices probably don't support this protocol, and if they do, you have to configure this option in the device configuration tool.
0
 
LVL 18
ID: 13760933
You don't need to rename it, just create a new share and call it what you want.  Sorry if I wasn't clearer there.  As I said, it fixed all of my problems.  Also, you just need to use TCP/IP, not IPX.
0
 

Author Comment

by:jetsonsblue
ID: 13763141
ok it was a two part roblem, first I changed back to tpc/ip as sugested, and second, I had to add authenticated users and administrators group along with blackelock to the share permisions for each folder, and this finaly solved the problem.

Since TCP/IP was paert of my problem, and rindi mentioned it first, i think it is only fair to acept rindi's answer, Let me know if we can agree on this, and I will acept the answer/answers when I hear back.
0
 

Author Comment

by:jetsonsblue
ID: 13763207
I forgot to mention that before the problem was solved i  did create a new share on C drive named C , rebooted, and it did not work.  The actual solution was above, let me know if you think I should split points or assign only to rindi.
0
 
LVL 18
ID: 13768782
Whatever got you to the answer.  If the thread pulled out the problem by questions and answers, then split the points.  If you feel rindi alone answered you post, then give it to him.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13779002
thanx.
0

Featured Post

What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question