• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 289
  • Last Modified:

Formsess and PHP5

What changes need to be made to formsess 2.0 to use with PHP5?
0
gwkg
Asked:
gwkg
1 Solution
 
matt_mcswainCommented:
php5 is pretty backwards compatible w/ php4. For example, the default name of object constructor's changed for the class name to __construct, but the old way will work if __construct is not present.

They did break compatibility in a few places, such as objects are passed by reference automatically in php5 while they were passed by value in php4, and they altered a function here and there. I don't know much about formsess, but I would just try it out and you'll most likely be ok.
0
 
gwkgAuthor Commented:
I was just lookin for an excuse why I couldnt get the plugin to work.  I cut my losses and went for SmartyValidate and wasted a day tryin to get that to do what I wanted before I gave up on that too.  The worst part is that I had javascript/client side validation and php/server side validation working fine before I went and tried to rewrite it "the right way".  This is only my 2nd php site and Ive only been learning from what I read so I always think there is a better way to do what I did.  Usually Im right.

This morning, I came to the realization that I should more time learning a little more about objects and classes and less time fooling around with SmartyPlugins.

Ill give ya all the points and close the question for taking the time to help me =)

Thanks!
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now