[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 277
  • Last Modified:

Installing DBI-1.48 to perl 5.00503

My Unix server which share applications with others have PERL 5.00503 installed. When im try to install DBI::DBD, it give me this msg: "Perl 5.006 required--this is only version 5.00503, stopped at Makefile.PL line 10. BEGIN failed--compilation aborted at Makefile.PL line 12."

When i go to perl.com, the current distribution is 5.8.6. My question is... in what way i can istall this DBI::DBD::mysql to my current server...

1. anybody have previous release of DBI?
2. OR any body have perl 5.006?
3. OR any other way to make this installation succeedd.. (i dont want to upgrade to PERL 5.8 simply bcause there are possibility that the other app will not work... during/after installation (?)

TQ
0
spreq
Asked:
spreq
1 Solution
 
kanduraCommented:
You should be able to install older versions like this:

    cpan install TIMB/DBI-1.42.tar.gz

where 1.42 is the version number you'd like to install. 1.48 is the latest version of DBI.

Perl 5.006 is commonly called 5.6.0 or higher. Upgrading perl is indeed something you'd better do with care. It is quite possible though to install a private version of perl somewhere else, while leaving the system perl intact.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now