[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

PIX 501 CONFIG

Posted on 2005-04-11
12
Medium Priority
?
371 Views
Last Modified: 2013-11-16
Hi There

Let me give you a breakdown of what I would like to do...

I have 2x external IP's "196.34.84.1" & "196.34.84.13" which are in use.  I do have more but we do not use them as yet.

My knowledge on PIX is very limited, so here it is...

The pix is set for the following,  "196.34.84.1" brings in our MAIL, HTTP, FTP.
The other ip "196.34.84.13" is for our VPN clients.

I have 3x servers, "192.168.0.1" up to 192.168.0.10"

I am moving our exchange server from 192.168.0.1 to 192.168.0.4.  The problem is that the pix will only deliver mail to and HTTP to "192.168.0.1"

With having exchange on "192.168.0.4" it will not then receive mail.

I need to change the IP on the pix from 192.168.0.1 to 192.168.0.4.

Please supply the exact command line in order to do that.  Will or can anything else be affected?

I am not sure how this works but, if we change that IP to the new one how will the effect the WEB?
0
Comment
Question by:hitechauto
  • 5
  • 3
  • 2
  • +1
12 Comments
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 13751231
If you could give me a dump of the current Pix config, I can let you know what to change.

Is the HTTP proxy (I assume you are using one) also moving from 192.168.0.1 to 192.168.0.4?  If so, the HTTP forwarding will also need to be updated.  If this is not the case, only the smtp will need to be changed.  Either way, you provide the current config, and I can provide the required changes.
0
 
LVL 2

Expert Comment

by:VMarcus
ID: 13751343
In you PIX is a rule, a static address translation. This line converts one outside ip-address to an inside one, this is the rule you have to delete and insert again. It should look something linke this:

Old one:
(no) static (outside,inside) outside-ip 192.168.0.1 netmask 255.255.255.255

to be removed with the command no ....

New one:
static (outside,inside) outside-ip 192.168.0.4 netmask 255.255.255.255

regards,
Vincent
0
 

Author Comment

by:hitechauto
ID: 13751366
ATT: "purplepomegrainte"

I don't mind sending you my config but how safe is it for you to have, reason for this i dont know much about pix and one of your guys said before when i posted the config that i shoud grey out certain areas.  I am just a little concerned.  I'll take your word for it.... LET ME KNOW
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 2

Expert Comment

by:VMarcus
ID: 13751404
Hi,

The only thing I "need" is the lines stating static ....
The rest should not be necessary

Regards,
Vince
0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 13751408
Does your pix handle VPN, etc.?  If so, then the keys are in the config file it is this that should be left out.  If you are using forwarding to a server to handle the VPN this shouldn't be a problem.  So long as only network details are visible in the config it is pretty safe

The only bits I need to see of the config file are those referencing smtp and perhaps the access groups if that is set.  If you can extract those bits, or alternatively simply provide the whole config excluding anything that references IPSEC, VPN, etc. I can advise.  It may be that Vincent's answer above is sufficient, in which case no need to continue.
0
 
LVL 2

Expert Comment

by:VMarcus
ID: 13751412
You don't need to post access-lists as that will not change. the only thing changing here, is your servers internal IP address. This is mapped by the static lines.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13751691
Vincent gave you the right idea..

pixfirewall#config t
pixfirewall(config)#no static (inside,outside) 196.34.84.1 192.168.0.1 netmask 255.255.255.255
pixfirewall(config)#clear xlate
pixfirewall(config)#static (inside,outside) 196.34.84.1 192.168.0.4 netmask 255.255.255.255
pixfirewall(config)#exit
pixfirewall#wri mem
0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 13751737
Ok, I'll bow out of this one.  I do not like offering one line fixes for devices such as the Pix (unless asked a very specific question!) as it is very easy for a simple change to affect more than one service.  e.g. the above fix from Vince will also change the HTTP forwarding, as you are just mapping an outside address to an inside one.  I normally configure the Pix to forward traffic on a service basis, e.g. just SMTP traffic is forwarded from the outside address to the inside one.
0
 
LVL 2

Expert Comment

by:VMarcus
ID: 13751834
The only thing I was trying to explain, was that the problem is with the static translations. If you prefer to do those translations at service level rather then at device level, fine with me, but the problem still is with the static lines.
0
 

Author Comment

by:hitechauto
ID: 13751953
OK, HERE IS THE CONFIG.

AT THE MOMENT HTTP & SMTP COME THROUGH ON ONE OUTSIDE IP "196.34.84.1" CAN THIS BE SPLIT ONTO TWO DIFF. IP'S OR BEST TO KEEP IT AS IT IS.  I AM RUNNING ISA 2000, THE ONLY WAY WE GET ACCESS TO THE NET VIA ISA IS IF I HAVE MY DNS FORWARDS IN.  WE DO NOT CONNECT TO AN UPSTREAM SERVER.



Written by enable_15 at 01:25:05.065 UTC Fri Mar 18 2005
PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ecmfTkDl9JCBuhWs encrypted
passwd nC1TgPA/j9j.bzQi encrypted
hostname Hi-Tech
no fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1273
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list OUT_IN permit tcp any host 196.34.84.1 eq smtp
access-list OUT_IN permit tcp any host 196.34.84.1 eq pop3
access-list OUT_IN permit icmp any any echo-reply
access-list OUT_IN permit icmp any any time-exceeded
access-list OUT_IN permit icmp any any timestamp-reply
access-list OUT_IN permit tcp any host 196.34.84.1 eq www
access-list OUT_IN permit tcp any host 196.34.84.1 eq ftp
access-list OUT_IN permit tcp any host 196.34.84.4 eq ftp
access-list OUT_IN permit tcp any any eq 81
access-list IN_OUT permit ip host 192.168.0.1 any
access-list IN_OUT permit ip host 192.168.0.2 any
access-list IN_OUT permit udp any any eq isakmp
access-list IN_OUT permit esp any any
access-list IN_OUT permit tcp any any eq 81
access-list 80 permit ip host 196.34.84.13 host 192.168.0.100
access-list 101 permit ip 192.168.0.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list 101 permit ip 172.16.1.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 196.34.84.13 255.255.255.240
ip address inside 192.168.0.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 196.2.27.72
ip local pool test 172.16.1.1-172.16.1.2
pdm location 192.168.0.1 255.255.255.255 inside
pdm location 192.168.0.2 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 196.34.84.4-196.34.84.12 netmask 255.255.255.240
global (outside) 1 196.34.84.3 netmask 255.255.255.240
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 196.34.84.1 smtp 192.168.0.1 smtp netmask 255.255.25
5.255 0 0
static (inside,outside) 196.34.84.1 192.168.0.1 netmask 255.255.255.255 0 0
access-group OUT_IN in interface outside
route outside 0.0.0.0 0.0.0.0 196.34.84.14 1
timeout xlate 1:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.0.254 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:7af76d9c95e225e2ba4c79a147a11bdb
Hi-Tech#
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13752027
We can start by removing both statics, since they both forward to the same internal

no static (inside,outside) tcp 196.34.84.1 smtp 192.168.0.1 smtp netmask 255.255.255.255 0 0
no static (inside,outside) 196.34.84.1 192.168.0.1 netmask 255.255.255.255 0 0

clear xlate <== important step

Now, you can add new statics, using just the service ports you need:
  static (inside,outside) tcp 196.34.84.1 smtp 192.168.0.4 smtp netmask 255.255.255.255  <== EMAIL
  static (inside,outside) tcp 196.34.84.1 http 192.168.0.1 http netmask 255.255.255.255     <== www to different server
  static (inside,outside) tcp 196.34.84.1 pop3 192.168.0.4 pop3 netmask 255.255.255.255
  static (inside,outside) tcp 196.34.84.1 ftp 192.168.0.4 ftp netmask 255.255.255.255
  static (inside,outside) tcp 196.34.84.1 ftp-data 192.168.0.4 ftp-data netmask 255.255.255.255

<=done=>


0
 
LVL 2

Accepted Solution

by:
VMarcus earned 2000 total points
ID: 13752028
static (inside,outside) tcp 196.34.84.1 smtp 192.168.0.1 smtp netmask 255.255.255.255 0 0
static (inside,outside) 196.34.84.1 192.168.0.1 netmask 255.255.255.255 0 0

The first rule is obselete, because the second rule does the same as the first one except only for smtp. You should change the 2nd rule to:
- no static (inside,outside) 196.34.84.1 192.168.0.1 netmask 255.255.255.255 0 0
- no static (inside,outside) tcp 196.34.84.1 smtp 192.168.0.1 smtp netmask 255.255.255.255 0 0
- clear xlate
- static (inside,outside) 196.34.84.1 192.168.0.4 netmask 255.255.255.255 0 0

Be adviced:
Server 192.168.0.1 is no longer reachable from outside, nor for mail, nor for www, but the device itself can get on the internet.

However, if device 192.168.0.1 should still serve www requests, use the following:
- no static (inside,outside) 196.34.84.1 192.168.0.1 netmask 255.255.255.255 0 0
- no static (inside,outside) tcp 196.34.84.1 smtp 192.168.0.1 smtp netmask 255.255.255.255 0 0
- clear xlate
- static (inside,outside) tcp 196.34.84.1 www 192.168.0.1 www netmask 255.255.255.255 0 0
- static (inside,outside) tcp 196.34.84.1 smtp 192.168.0.4 smtp netmask 255.255.255.255 0 0
- wr m
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Make the most of your online learning experience.
This program is used to assist in finding and resolving common problems with wireless connections.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question