Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

webconfig runtime error

Posted on 2005-04-11
15
Medium Priority
?
307 Views
Last Modified: 2011-10-03
It seems like i get this runtime error everytime time i create a new web page on the server.  I set the mode to Off and i still get the same runtime error:

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 

I dont understand because i have this set to Off <customErrors mode="RemoteOnly" and i cant get the real error to show up.
0
Comment
Question by:tentavarious
  • 6
  • 4
  • 3
  • +1
15 Comments
 

Expert Comment

by:discofunk
ID: 13752588
You will have to give the user ASPNET access to the folder your web site is located in.
0
 

Author Comment

by:tentavarious
ID: 13752677
That has to be done through the IIS correct?
0
 

Expert Comment

by:discofunk
ID: 13753331
You can do by right clicking at your folder that contains the solutions, select Properties -> Security -> Add. Then  type in "ASPNET" in the box, -> OK.

Done.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:tentavarious
ID: 13753372
I dont have that security option on my server folders.
0
 

Expert Comment

by:discofunk
ID: 13753616
What OS are you running you web site on?
Do you have direct access to the web server? If you don't have access to it, this must be done by someone that has.

Tell me everything you know about your server configuration.

Hang in there :-)
0
 

Author Comment

by:tentavarious
ID: 13753802
Alls i basically know is it runs windows 2000 i dont touch or server too often.  I seem to get the webconfig error when i try to add a new folder containing the new web page under the inetpub\wwwroot directory.
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 13755162
Did you modify the right web.config file?  That would be my first guess from what you described.

Bob
0
 

Author Comment

by:tentavarious
ID: 13755215
Yep, i am looking at it now and the web config custom errors is set to Off.  But i still get the same runtime error when i try to load the web page. I cant get the real error to show up.  I had a similar problem b4 when i started a new folder on the server, i cant remember how i fixed it.

still getting this error
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 13755233
Is this the web.config file for the main site or a sub site?

Bob
0
 

Author Comment

by:tentavarious
ID: 13755262
The main site
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 13755297
Whenever I create a web site in ASP.NET, it gets created under a folder in C:\InetPub\wwwroot, and changing the CUSTOM ERROR MESSAGES section has always worked, so I don't understand what you did when you "created a new folder" on the web site.

Bob
0
 

Author Comment

by:tentavarious
ID: 13755523
Here is how my folder is set up c:\inetpub\wwwroot\maintenance\maintprod\all my webpages are here.  I set up the maintenance\maintprod folders to contain my newly created web pages.  Runs fine on my machine then i copy all the files to the server to the same location, and i get that web config error.
0
 
LVL 22

Accepted Solution

by:
prairiedog earned 500 total points
ID: 13757493
You cannot just create a folder on another server and copy files to the folder to run an application. You have to make the folder an application folder. If you have access to your IIS server, then follow the following steps:

Go to: Control Panel -> Administrative Tools -> Internet Information Services
Then click "Web Sites" node, then expand "Default web Site" node. Right click the folder you created then choose "Properties". Under "Directroy" tab and in the "Application Settings" section, if the "Application Name" field is greyed out, then click "Create" button next to it, then click "ok" to exit.

If you don't have access to your IIS Server, then ask your system administrator to do it for you.
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 13761625
Thank you Jeffrey for that explanation.  It's exactly what is needed.

Bob
0
 
LVL 22

Expert Comment

by:prairiedog
ID: 13761838
You're welcome, Bob. I am glad that I can help.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A basic question.. “What is the Garbage Collector?” The usual answer given back: “Garbage collector is a background thread run by the CLR for freeing up the memory space used by the objects which are no longer used by the program.” I wondered …
In my previous two articles we discussed Binary Serialization (http://www.experts-exchange.com/A_4362.html) and XML Serialization (http://www.experts-exchange.com/A_4425.html). In this article we will try to know more about SOAP (Simple Object Acces…
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses
Course of the Month21 days, 6 hours left to enroll

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question