[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 282
  • Last Modified:

problem with outlook when using server's dns

Dear Expert,
I am using  windows server 2003 in a wireless network system with dhcp. the users runing windows xp.when they are logon in the domain it takes a long time more than 5mn OUTLOOK working normally.when I put the dns of the server they logon quickly but OUTLOOK doesn't work. they can send but not received. I need your help quickly. thanks
0
petitefille
Asked:
petitefille
  • 3
  • 3
  • 3
  • +1
1 Solution
 
map000Commented:
what connection to the mail server are you using? pop3, smtp or exchange connector?
I suppose it's pop3, smtp; in this case, try to ping the pop3 server address; also check if the dns server contains the correct mappings (name to ip)
0
 
NJComputerNetworksCommented:
You internal client should be pointed to your local Windows 2003 server for DNS resolution only (Do not point them directly to the ISP DNS servers....this will cause slow logons)

Then you must configure your Windows 2003 server to forward Internet DNS requests to your ISP DNS servers.

1) Logon to the DNS server
2) Open the DNS Admin Console
3) Right click your server name and choose PROPERTIES from the drop down box
4) Click the FORWARDERS tab and enter the ISP DNS servers here...

This will allow your DNS server to forward requests to the ISP on behalf of your clients...

This should solve your problems....with slow logon and Outlook


-later
0
 
petitefilleAuthor Commented:
my isp doesn't give me a real dns when i run ipconfig/all  the dns 192.168.0.1 is the same with my gateway
what do you think can I put it  anyway in the FORWARDERS tab.

Thanks
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
NJComputerNetworksCommented:
No, that won't work.  192.168.0.1 is an internal IP address.  Its pretty rare no a days for an ISP NOT to provide DNS server addresses.  I would check with the ISP to verify that they do not provide DNS servers for you...

do this:

1) Set all of your clients to use ONLY the Windows 2000/2003 DNS server(s)  (This is how DNS must be setup for Active Directory domain functionality  to work properly...AD needs internal DNS to work.  This is why logon work much faster when the clients use your internal DNS servers...)

2) configure forwarders on your DNS server as I descibed in my previous post.  (once you have learned what the ISP DNS servers are)

or

If you do not have ISP DNS servers available, program the IP address instead of server names in your Outlook profile.


One thing you may be able to do is to go into your GATEWAY and view the IP settings.  You probably have a non-public IP address for your company.  Meaning that you get a DHCP address from your ISP.  With the DHCP address, you probably get additional IP settings like DNS.  On most routers, you will be able to display the current IP settings (DHCP address) that your ISP gave you.  On this property page, you can see the DNS servers IP's given to you by your ISP.  You can then use these in your forwarders tab.

-let me know what type of GATEWAY you have (Lynsys model number, Cisco model number, etc) and I can direct you to the properties page.

0
 
petitefilleAuthor Commented:
My gateway is a D-Link  DI-624 Air Plus XtremeG 2.4ghz

Regards
0
 
NJComputerNetworksCommented:
Ok...login to your router:

Probably like this:

Open up Internet Explorer and then type in this url:

http://192.168.0.1 <enter>

- Enter your users name and password  (admin is the defualt userver name and less password blank if you didn't create one)

- Click OK to logon

- Step 3 Click the Status tab and then click Device Info to the left.

You should be able to see your WAN settings here...
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
petitefille,

Click on this link:  http://192.168.0.1/h_dhcp.html User Name: admin  Password: blank (unless you've created one)

IS DHCP Enabled on your Router?  If so, using 192.168.0.1 for your DNS server on your client machines is the correct entry (it's not the safest way to configure your network, but this is how you have it set up).

Then, click on this link:  http://192.168.0.1/adv_virtual.html and click the Enable dot and enter the following:
Name:  Servername SMTP
PrivateIP: (add your Server's local IP address found with ipconfig /all)
Protocol Type: TCP
Private Port: 25
Public Port: 25
Always Available

Then click Apply.

Because you are using wireless routing, all of your client machines are going to the ROUTER before going to your server... the router IS responsible for your DNS then, and if you then use your server's local IP address when configuring OUTLOOK everything should work just fine.

Good Luck!

Jeff @
TechSoEasy

0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
P. S. either reboot your XP machines or run C:\>IPCONFIG /FLUSHDNS on them in order to properly connect to your reconfigured DNS.

Jeff
0
 
petitefilleAuthor Commented:
Dear All,

Thanks a lot for your help, everything is ok now. they log on  quickly and outlook is working properly.
so you make a good job.
thanks so much.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Terrific... please close this question... for info on that:  http://www.experts-exchange.com/help.jsp#hs5
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now