Access is Denied. The source file may be in use. copying a file over itself

In Windows 2000 I'm getting the error "Cannot copy mftp32: Access is Denied. The source file may be in use." when copying a file over the exact same file in another folder. The file is on a server drive and I'm trying to do the action from a workstation. The file name is mftp32.ocx (ActiveX) If I try the same copy within a Terminal service session it works. I have admin rights to folder and file. As much as I can tell nothing has the file open. I have an upgrade that is failing because the file is open exclusively. I believe if I can correct the issue that is causing the error above the upgrade will also work. - Thanks for your help.
KJTannerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

theruckCommented:
maybe the antivirus has the file open in the time of copyiing and missunderstoods it because you have 2 files of the same name opened. try to disable the AV first
0
KJTannerAuthor Commented:
I disabled the anti virus program and booted the PC - I still get the error when doing a copy.
0
theruckCommented:
can you rename the destination file?
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

KJTannerAuthor Commented:
The names are the same, just in different folders.  
You're getting closer though. I gave the file a different extension and copies work. Unfortunately I need the file name to stay the same for the upgrade.  - OCX - ActiveX
0
theruckCommented:
rename or delete the old file... then copy the new file into that direction it is the same like copying over
0
KJTannerAuthor Commented:
The upgrade has to copy over the file mftp32.ocx. The upgrade is automated so I don't have the option of remaning the file and copying it. The issue seems to be the type of file that it is. I deleted the original files and renamed the files I was just testing with back to the original name and now the copy is failing again. - Thanks for your thoughts but we're not there quite yet.
0
theruckCommented:
you could do a script which would delete the file then run the upgrade...
maybe the setup itself opens the file
is the folder mapped as a local drive?
0
KJTannerAuthor Commented:
The software maps a drive.
I tried deleting the file before the upgrade but it still have the issue.  It's strange that one cannot copy a file with the extension of ocx.
0
theruckCommented:
can you copy the file "by hand"? or is only the upgrade procedure failing?
so if there is no file in teh destination folder the error message cannot be because of the shared folder so you have to investigate the computer you are installing the upgrade from
0
theruckCommented:
maybe it is time to be more specific and describe the upgrade procedure and all the things which are important.
0
sweatbeastCommented:
How is the file copy happening? Is this something like InstallShield, Winstall, Windows Explorer etc?
0
alopezfdzCommented:
the file appears to be Mabry Internet FTP Control. maybe your app opens a control that use that ocx or you have other app that use that file. do you have an ftp server or client in that pc? if yes try to stop the service and then replace it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nirmal SharmaSolution ArchitectCommented:
I agree. The file is being used by the software. Stop the service of this software and then try to copy.
0
KJTannerAuthor Commented:
I've moved the files that I've been manually copying to another server on which the copy now works. The main difference between the servers is FTP/IIS. The server without IIS does the copy without an error. Thank you all for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.