Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1349
  • Last Modified:

Could not Establish Link -- Check if the cable is plugged in.

Hi,

After a recent cisco switch upgrade, the switch lost connection with this sun server. We have to do init 6 to make it visible to the network. And today this server suddenly breaks off connection. We did init 6 again. These are the info in messages file. Can anyone tell me what is going on. Thanks  

Apr 11 13:21:19 aai-sun ge: [ID 451854 kern.notice] SUNW,pci-gem0: Using Gigabit SERDES Interface
Apr 11 13:21:19 aai-sun ge: [ID 451854 kern.notice] SUNW,pci-gem0: Forced 1000 Mbps Full-Duplex Link Up
Apr 11 13:33:39 aai-sun ge: [ID 451854 kern.notice] SUNW,pci-gem0: Could not Establish Link -- Check if the cable is plugged in.
0
ebi168
Asked:
ebi168
1 Solution
 
kusuma_hsCommented:
This looks like u have problem with the network connection itself. pl. change the n/w port that is working and then check.

Rgds,
Kusuma
0
 
ebi168Author Commented:
If it is the connection problem, how come init 6 will solve the problem.
0
 
NukfrorCommented:
One thought is the cable involved.

What kinda of ethernet cable are you using ?  CAT5 or CAT5E

You should NEVER use homemade cables for GigE interfaces.  Sometimes even factory made CAT5 isn't good enough.  You should use CAT5E when you see problems this.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
ebi168Author Commented:
I have find out the problem is caused by setting /usr/sbin/ndd -set /dev/ge adv_1000autoneg_cap to 0; it should be 1. Thanks for your effort in help.
0
 
pshattuckCommented:
If rebooting resolves the problem then you must hvae your network interface set to auto-negotiate and the router is set to something else.

Coordinate with your netowrk department and see what speed the port that the server is connected to is running at

then create a <interface>.conf file in the /platform/<architecture (most likely will be the directory sun4u)>/kernel/drv directory

Example:

If the interface is qfe0 on the server and the network port is running 100/full then you would create a file called qe.conf in the directory mentioned above and type in this

adv_1000fdx_cap=0;
adv_1000hdx_cap=0;
adv_100fdx_cap=1;
adv_100hdx-0;
adv_10fdx_cap=0;
adv_10hdx_cap=0;
adv_autoneg_cap=0;


the 0 turn off the interface to run at those speeds and the 1 to make the interface run at that speed

hence 1= on .... 0 = off

After you save this file, confirm that it is the speed you wish to be running at. Then reboot the server. If you have connected at reboot then you are at the correct speed. If it is still dropping on you .. then troubleshoot the port on the NIC andf make sure it is not flaking out

Hope that helps

the one turns on the port
0
 
CetusMODCommented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now