• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 546
  • Last Modified:

install postgresgres rpm

Any help with postgres rpm install

[root@mesrv01 postgres]# rpm -i postgresql-8.0.1-2PGDG.x86_64.rpm
warning: postgresql-8.0.1-2PGDG.x86_64.rpm: V3 DSA signature: NOKEY, key ID ddcd9f9a
error: Failed dependencies:
        libc.so.6()(64bit) is needed by postgresql-8.0.1-2PGDG
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by postgresql-8.0.1-2PGDG
        libc.so.6(GLIBC_2.3)(64bit) is needed by postgresql-8.0.1-2PGDG
        libcom_err.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libcrypt.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
        libcrypto.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libdl.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libm.so.6()(64bit) is needed by postgresql-8.0.1-2PGDG
        libncurses.so.5()(64bit) is needed by postgresql-8.0.1-2PGDG
        libnsl.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
        libpam.so.0()(64bit) is needed by postgresql-8.0.1-2PGDG
        libpq.so.3()(64bit) is needed by postgresql-8.0.1-2PGDG
        libreadline.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libresolv.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libssl.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libz.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
[root@mesrv01 postgres]# locate libc.so.6
/lib/i686/libc.so.6
/lib/tls/libc.so.6
/lib/libc.so.6
[root@mesrv01 postgres]# set | grep LD
OLDPWD=/pulse/download
[root@mesrv01 postgres]# export LD_LIBRARY_PATH=/lib:/usr/lib
[root@mesrv01 postgres]# rpm -i postgresql-8.0.1-2PGDG.x86_64.rpm
warning: postgresql-8.0.1-2PGDG.x86_64.rpm: V3 DSA signature: NOKEY, key ID ddcd9f9a
error: Failed dependencies:
        libc.so.6()(64bit) is needed by postgresql-8.0.1-2PGDG
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by postgresql-8.0.1-2PGDG
        libc.so.6(GLIBC_2.3)(64bit) is needed by postgresql-8.0.1-2PGDG
        libcom_err.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libcrypt.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
        libcrypto.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libdl.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libm.so.6()(64bit) is needed by postgresql-8.0.1-2PGDG
        libncurses.so.5()(64bit) is needed by postgresql-8.0.1-2PGDG
        libnsl.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
        libpam.so.0()(64bit) is needed by postgresql-8.0.1-2PGDG
        libpq.so.3()(64bit) is needed by postgresql-8.0.1-2PGDG
        libreadline.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libresolv.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libssl.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libz.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
[root@mesrv01 postgres]# cd /
[root@mesrv01 /]# ls
bin   dev  home    lib         misc  opt   pulse  sbin  usr
boot  etc  initrd  lost+found  mnt   proc  root   tmp   var
[root@mesrv01 /]#
0
cogit
Asked:
cogit
1 Solution
 
marxyCommented:
Seems like libc installed is not 64-bit
Run this

rpm -qf /lib/libc.so.6

0
 
cogitAuthor Commented:
wrong ver
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now