• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 507
  • Last Modified:

external hard drive added now gives error message - the parameter is incorrect

I changed a 40g external hard drive to a 120g. It appeared to take all the files I copied from the old one (using Windows Explorer). When I booted up today the drive appears to be there but when I try to access it I get the error message: I:\ the parameter is incorrect.
Any suggestions? Thanks John
0
maxmeg
Asked:
maxmeg
  • 5
  • 3
  • 2
  • +1
1 Solution
 
nobusCommented:
look into the disc management, right click on the white space, and select the appropriate command :
assign a letter, import, etc...
0
 
CallandorCommented:
Make sure the drive is correctly detected in the BIOS first.  If your CMOS battery is weak or dying, your drives may not be recognized.
0
 
eccs19Commented:
Can you please clairify something for me?  You say you changed from a 40 Gig to  a 120 Gig and copied the files over using the Windows Explorer.  Did you try to copy over the OS, remove the old 40 Gig, then try to boot from the 120 Gig?  If so, you won't get that to work.  You will need to use something like Norton Ghost to make an image of the 40 Gig, then restore the image to the new drive.  Just copying the OS won't work.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
eccs19Commented:
Sorry, I missed the external part.  My suggestion is probably completely irrelavant. (I've had a headache for 3 days, and just can't get rid of the darn thing.)
0
 
CallandorCommented:
Well, that makes two - I thought it was an internal drive also, so ignore my BIOS detection comment.  This must be a USB drive, so check the USB ports to see if they are working correctly by trying another USB device.  If they are, you may need to remove the USB drivers in device manager and let them reinstall.
0
 
eccs19Commented:
Callandor, I think we both need a LONG vacation! <g>
0
 
maxmegAuthor Commented:
Sorry about the headaches and mis-readings! The problem seems to be in the fact that Computer Management shows a disk but it has no system and no size. My main C: drive is still on FAT 32. Regards John
0
 
eccs19Commented:
Seems strange that the computer management shows no system and no size.  Were the files originally copied over to this drive on this computer or a different computer?  If it was all done on this one, then I would think that nobus's recommendation should be the correct one.  Seems strange.  Please clairify.
0
 
maxmegAuthor Commented:
I connected the new 120g drive by a separate usb socket - alongside the 40g usb socket. Then I went into Windows Explorer and selected all of the 40g I: drive - then dragged all to the new 120g H: drive.

It seemed simple - but maybe it is me that is simple!!
John
0
 
eccs19Commented:
After you removed the 40 Gig, did you have the 120 working at all, or did it just not work after the removal of the 40 Gig?  Did you try the 120 gig in a different computer to see if it is seen / working?
0
 
nobusCommented:
>>   The problem seems to be in the fact that Computer Management shows a disk but it has no system and no size   << what were the options it gave you when you right clicked the white space?
0
 
maxmegAuthor Commented:
It seems the drive holder for the new drive was faulty and has been replaced. Everything seems to be working now - thanks you.
John
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 5
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now