[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1705
  • Last Modified:

Event ID 1657, 1466, 1409 and 1373

Hi

The following events are appearing in the Event Viewer every 1/2 hour or so.

Event ID 1657             Source NTDS Inter-site

The Inter-Site Messaging Service requested an ADSI Get Object function for namespace object IIS://LocalHost/SMTPSVC/1/Domain.  The operation failed with the following message:
 
 Library not registered.
 
 Please check that the service providing that portion of the namespace is installed and running.  For example, if the namespace is 'IIS:', please verify that the IIS service is running.  It is possible that the DLL component providing that portion of the ADSI namespace is missing or corrupt. If the problem persists, you may want to reinstall the Windows component containing that service.

Event ID 1466             Source NTDS Inter-site

The Inter-Site Messaging Service SMTP Transport plug-in failed to add the following SMTP routing domain: e67b0fd1-8f15-4694-99fa-76f52544c2c9._msdcs.*domain name*.  This domain is needed by the SMTP service in order to accept incoming mail using this name.  Other replication partners will receive errors when sending mail to this name until the problem is corrected.
 Please verify that the SMTP service is installed and functioning correctly; also verify that ADSI is installed and working on this system.
 As a workaround, you may try to add the domain manually using the SMTP Service Manager.
 The error message is as follows:
 Library not registered.


Event ID 1409             Source NTDS Inter-site

The Inter-Site Messaging Service SMTP Transport plug-in could not send a message because no mail transport is installed.  Please install a mail transport, such as the SMTP Service.  The operation will be retried.

Event ID 1373             Source NTDS Inter-site

The query for messages for service NTDS Replication via transport CN=SMTP,CN=Inter-Site Transports,CN=Sites,CN=Configuration,DC=*name*,DC=*name*,DC=com failed with the following status:
 
 Library not registered.

Items with * have been amended to protect the company ;)

I have 2 DCs and this Server is the Global Catalog.  I cannot get into Active Directory Users & Computers or AD Sites and Services or AD Domains and Trusts.

If I go into these I get a "Naming information cannot be located because:  Library not registered"

I have looked at newsgroups posts, Event ID, who suggested to reinstall IIS, which I did but no success.

The SMTP and IIS services seem to be working/running okay.

Any suggestions?
0
Nzarth
Asked:
Nzarth
1 Solution
 
NzarthAuthor Commented:
Hi and thanks for posting.

I have already looked at Event ID, but just in case I went through the fixes again.

1st Link

The IIS Admin service is running.  I stopped the SMTP service and this made no difference (plus was working fine before).  There is no 2nd NIC on the server and the return error code is different to that link.  Error code I get is 1d 80 02 80.

2nd Link

Same as above, plus I cannot gain access to AD Sites and Services without getting the "Naming information cannot be located because:  Library not registered"  error.

3rd Link

Server is not running Exchange 2000 on it, and I did reinstall IIS, but this made no difference.  The server has a straight Windows 2000 Server install and wasnt upgraded from NT 4.

4th Link

Has no available info :(
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Is Your DNS functioning correctly..
0
How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
It seems to be a problem with your Domain/DNS configuration, Please check and verify.
0
 
NzarthAuthor Commented:
Not sure if there is a problem with my domain/DNS config.  Even if there was, why would that stop me from even opening the AD Users and Computers (error "Naming information cannot be located because:  Library not registered"  error?
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Please could you explain your network setup clearly?
Also what has changed?
0
 
NzarthAuthor Commented:
Found the fix :D

I had to add the following registry keys:
 
[HKEY_CLASSES_ROOT\TypeLib\{97­d25db0-0363-11cf-abc4-
02608c9e7553}]
[HKEY_CLASSES_ROOT\TypeLib\{97­d25db0-0363-11cf-abc4-
02608c9e7553}\1.0]
@="Active DS Type Library"
[HKEY_CLASSES_ROOT\TypeLib\{97­d25db0-0363-11cf-abc4-
02608c9e7553}\1.0\0]
[HKEY_CLASSES_ROOT\TypeLib\{97­d25db0-0363-11cf-abc4-
02608c9e7553}\1.0\0\win32]
@="C:\\WINDOWS\\System32\\acti­veds.tlb"
[HKEY_CLASSES_ROOT\TypeLib\{97­d25db0-0363-11cf-abc4-
02608c9e7553}\1.0\FLAGS]
@="0"
[HKEY_CLASSES_ROOT\TypeLib\{97­d25db0-0363-11cf-abc4-
02608c9e7553}\1.0\HELPDIR]
@="C:\\WINDOWS\\system32"

And it worked a treat.  Thanks for your input 1stITMAN, but I had a feeling that it was a registry entry due to the Library not registered error.

Cheers
0
 
Wayne BarronCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
[PAQ - Refund]

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Carrzkiss
EE Cleanup Volunteer
0
 
CetusMODCommented:
PAQed with points refunded (250)

CetusMOD
Community Support Moderator
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now