Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 172
  • Last Modified:

Need help with Linux Enterprise - setting up web service

I have a Linux running red hat enterprise.  Right now, the way it is configured, I can get out to the internet with this server, but I cannot get remote access to the server through remote desktop or vnc.  It is not responding.

The server does not sit behind a firewall, and should be accessible by IP address, but it is not right now.

This problem will be a multi-part question worth over 2000 points in the end, so anyone to help can REALLY help me.

The first step is to get the server accessible from the outside remotely, so I can do more setup from a remote area.  Can someone help me get this server online so that it can be accessed remotely?

when I ping the server with IP, I do get a reply.  I just can't access the site through IP or even remote desktop or vnc to it.

I can also putty into the server.

More info:

#ps -ef | grep httpd
root      2528     1  0 Mar09 ?        00:00:01 /usr/sbin/httpd
apache   27200  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
apache   27201  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
apache   27202  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
apache   27203  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
apache   27204  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
apache   27205  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
apache   27206  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
apache   27207  2528  0 Apr10 ?        00:00:00 /usr/sbin/httpd
root      1517  1484  0 09:35 pts/1    00:00:00 grep httpd


When I was on the server locally, and typed in the IP address, it gave me my webpage.

But when I try to access it remotely through a web browser, I get an error page "Can't find server".

I cannot telnet into port 80 of the machine.

C:\Documents and Settings\dita>telnet 80 (myipaddress)
Connecting To 80...Could not open connection to the host, on port (myipaddress): Connect failed
0
foreverdita
Asked:
foreverdita
1 Solution
 
veedarCommented:
Smells like a firewall issue click...

Applications -> System Settings ->  Security Level

Check there. Are the services enabled?

 try...

  chkconfig --list

see anything suspicious?

Run...
/etc/init.d/iptables status

Does it say stopped.

Run a port scan against your server.

Check your log files.


0
 
foreverditaAuthor Commented:
it was the iptables.  Thank you!
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now