Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 224
  • Last Modified:

IIS problems? RRAS related?

I'm having a bit of a problem, which may be related to RRAS....

I have IIS installed, default webpage is there.  (i've tried other web pages, it all does the same thing)

The picture on the default webpage has a picture icon, the picture doesn't load... just the text.  Is there anything I can do to fix this?

If I have another page (other than the default loaded)  the only thing that opens is the HTML, without any pictures \ flash files or anything.  I don't have any filters in RRAS, and I have port 80 open.

Thanks.
0
Nitro187
Asked:
Nitro187
  • 4
  • 4
1 Solution
 
2hypeCommented:
Doesn't sound like a RRAS Issue.  The only port that needs to be open is port 80.
If you disable RRAS does your webpage load fine?
When you view the webpage on your local machine does it look fine?
0
 
Nitro187Author Commented:
I think I may have figured out the problem.  The server has two IP addresses, and the web server is binding itself to the main IP address.  Do you know how I can switch the primary IP address to the other one?  I don't see anywhere I can set 'priority'.
0
 
2hypeCommented:
Go to IIS.  Right click on your webage (Default Webpage) and select properties.
There is a tab called Websites.
In the IPAddress choose the IP Address of the Card You want. Or you can choose (All Unassigned) and it should work with both.

Then Forward Port 80 to the IPAddress you have set the website to run on
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Nitro187Author Commented:
Already did that,  it doesn't work unless I disable the local area network card. :(

When I disable that (there's another domain controller - a linux one that shares internet)  then the internet connection that's hooked up to this server takes over.

XXX.XXX.71.45   <- thats the IP I want it to use,  and it works perfect if I have the LAN network card disabled....

XXX.XXX.71.42  <- thats the IP of the linux server's internet connection, which doesn't work when it's on.  Do you know how to tell Windows 2003 to use the 71.45 for internet, instead of routing through the local area network?
0
 
2hypeCommented:
For the Locale area network connection do not use a Default Gateway.  You should only have a default Gateway pointing to your router set in your Internet NIC
0
 
Nitro187Author Commented:
I put the default gateway on the "internal" network card to the one I use on the external network card, after all the warnings it gives me, the IP address is still of the internal gateway's IP, rather than it's own.

Any other thoughts?
0
 
Nitro187Author Commented:
never mind, it's working, thank you so much :)
0
 
2hypeCommented:
You have 2 network cards in your server.  One that is for the Lan and one that is for the Internet.

The Lan card's Default Gateway should be Blank. (nothing entered)
The INternet card's Default Gateway should point to your router (or if your server is the router it should point to what your ISP Gave you for a default gateway)
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now