Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2730
  • Last Modified:

W2K3 - How to remove Read-Only Attributes

In W2K3, by default folders created are read-only.  I want to change a particular folder that I created and all of its contents to not be read-only.  I went under the folders permissions and unchecked Read-Only, and then clicked on "Apply changes to this folder, subfolders and files."  Pressed apply and the settings would not take effect.  I am logged in as a Domain Admin, and have ownership of the folder.  

What I also have tried:

I have tried using the cmd prompt attrib -R -S <dir> /S.

Still no luck.

Any suggestions?
0
sbreen
Asked:
sbreen
  • 2
1 Solution
 
luv2smileCommented:
You are getting confused. The read only attribute on the gener tab of a folder's properties is NOT how you change whether a file is read only or not. IGNORE that little box...it really doesn't mean anything except that it is TELLING you some file or folder below it is read only....it does NOT control file/folder access.

(http://redmondmag.com/columns/article.asp?EditorialsID=652)

You need to change the NTFS permissions from read only for the users you wish and grant them what rights they need. You do this by going to the "security" tab. You can also click on the "advanced" button and then a user and edit to get even more options for setting NTFS permissions.
0
 
JamesDSCommented:
sbreen
Folders are not created read only, but shares are.
In the share permissions (not the security tab, but the share tab) set the permissions there as required.

Windows 2000 default settings for shares was everyone:full control

Cheers

JamesDS
0
 
luv2smileCommented:
OR

 if you meant that you went under the permissions button on the "share" tab then you need to again also go under the security tab and change the NTFS permissions because if the NTFS permissions were still set to read only then changing the share permissions wouldn't change anything.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now