no aspx pages will run on windows2003 server

Hello All,

I am mainly a web developer, not an admin guy, but I have 3 boxes,
- my workstation (xp pro)
- my development server (2003 built 2 months ago)
- my production server (2003 built 1+ year ago)

I am not the only developer, and in the past, i am not sure what went on with the production box, but no aspx page will run on that computer, on the others it works fine. I tried to configure the 2 servers the same. but no .aspx pages will get processed.

it works on the other 2 boxes, so I know a little about configuring it. I created an application, i have the .net 1.1 downloaded and installed.

i also ran the:
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspnet_regiis.exe -i -enable

here is the error page i get: (note i have a web.config and it as mode="Off" for custom errors)

Server Error in '/ztestnet' Application.
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>


here is an error on my event viewer:
Failed while creating the ASP.NET client side script files directories under c:\inetpub\wwwroot\fsbo\allsacramentofsbo.com. Error code: 80070003

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

but it only tells me about a few of the subfolders / applications i have.

any help would be great.
realprosystemsAsked:
Who is Participating?
 
raterusCommented:
Actually, the best way to test, is get on the server itself and try to access a page,  if you can't do this, create an entirely new web.config file, and put this as the content,

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>

This should work, then start putting values from the bad web.config into the new one, until you see what the problem is.
0
 
raterusCommented:
You may have a syntax error in your web.config file, it's really picky.  Sure you typed everything correctly?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.