copy files from novell 6.5 server to a linux box

over 6gb of data. How woudl I accomplish this
eberhardt2329Asked:
Who is Participating?
 
JammyPakConnect With a Mentor Commented:
so you ftp in as anon, it asks for a passwd (normal so far..) then what?
0
 
eberhardt2329Author Commented:
i am trying to use ftp to bot the novell server and the linix box, but it will not let me put file son the linux box says to make sure I have right to do this. The user I am logged in as is in the root group?
0
 
JammyPakCommented:
login to the linux box as root
cd to the directory you want to put stuff in

ftp to the novell box - as anon or whatever
mget *

this should bring all files down...mget -R is for recursive, and the command 'prompt' will toggle the interactive off and on (ie. the need to confirm each get)
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
eberhardt2329Author Commented:
thank you for the response. How do I manage rights on teh linux box for the ftp access. I would like to be able to upload as well. I created a user on teh linux box, logged in as the user. but it will not let me create or put anything in it as ftp. This user is the root group. I need to know how to do this, so I can give and take rights from ftp users. Also how do i limit what anonomous sees. Thank you
0
 
JammyPakCommented:
well, I use vsftpd as my ftp server...in the config file for that (/etc/vsftpd/vsftpd.conf) there's an option called 'write_enable' which can be turned off or on - this controls whether ppl can upload or not. Also, the user they're ftping in as needs to have write access to the folder on the target server.

if you configure 'local' logins (ie. real user accounts) then they are controlled by the ftp config (ex uploads enabled or not) but then also by the file system permissions on the ftp server. They'll need to have read and write permission to the directory on the ftp server.

if you login as anonymous, then everyone has the same permission...the files are either readable or not. The 'anonymous' is a real user...for vsftpd it's a user called 'ftp', so the rights of the 'ftp' user are the rights of anonymous.
0
 
eberhardt2329Author Commented:
i do not have vsftpd I did find the pub directory, just do not see where to allow writting to teh specific directory
0
 
eberhardt2329Author Commented:
i do not have a user called ftp in red hat user manager. if I create one will this work i WILL TRY AND LET YOU KNOW
0
 
eberhardt2329Author Commented:
i found the user called ftp, and went to click on proporties, but accidently clicked delete what do I do?
0
 
JammyPakCommented:
see if you have a /etc/passwd- file, or some other backup of that file in /etc
0
 
eberhardt2329Author Commented:
i have the file, but the user in there is teh one I created. After I accidently deleted the ftp user I created a new one, but now when I try to logon it asks me for a password how do I set teh anonomopus back upi?
0
 
eberhardt2329Author Commented:
before I did that bonehead this, I could got to ftp://ipaddress of server, and it would take me in with anonomous access, now when I do this, it asks for a password. I created a new ftp user, and put him the th eftp group, but how do I get it not to ask me for a password again?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.