Can't update WiFi adapter on IBM ThinkPad A31

Posted on 2005-04-13
Last Modified: 2013-11-24
I have an IBM ThinkPad A31 running Win2K, and I'm trying to install this driver update:

I download the .exe, unpack and run setup, which gives me this error at the end of the install:

IBM High Rate Wireless LAN MiniPCI Card Error

Error 1334. The file 'AEIWLNIC.inf' cannot be installed because the file cannot be found in cabinet file ''. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.

After I hit OK and cancel the install, it says:

Error: -1603 Fatal error during installation.
Consult Windows Installer Help (Msi.chm) or MSDN for more information.

The directory containing (C:\IBMTOOLS\DRIVERS\WLLANACT) also contains another directory called 2K, which in turn contains the file AEIWLNIC.inf.  If I try to update the driver via Device Manager, giving it that INF file, it says that the recommended driver (c:\winnt\inf\oem20.inf) is already installed.  I'm very confused.

I have found nothing on the internet about the above error, and I figure at the very least a few thousand people must have installed this thing.  What am I doing wrong?

Question by:madacebo
    LVL 8

    Accepted Solution

    All I can say is that I downloaded the driver, then I put it into a folder.  I ran the installer and changed the location where the installer wanted to unpack the files to, to my test folder where i downloaded the driver too.  Once it unpacked, I went and let the installer complete, and it completed with no error whatsoever.

    I would go into the users and passwords control panel and create a new administrator user and then logout of your current user and logon to that new administrator user and try the driver install again.

    LVL 8

    Expert Comment

    Also I would install the drivers while the card isn't in the laptop if it continues to give you problems.  Once the drivers are installed, then install the card and see if the card is autodetected properly at that point.

    LVL 15

    Assisted Solution

    I'd recommend doing the following:

    1) uninstall the drivers.
    2) search c:\winnt\ (and subfolders) for oem20.inf and for AEIWLNIC.inf.  Delete one or both from the folder under c:\winnt\ once found.  Leave them in the folder where the drivers were unpacked.
    3) restart the laptop, then reinstall the drivers.
    LVL 91

    Assisted Solution

    you can use the ibm feedback for this problem :

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    Suggested Solutions

    I originally posted this Article Here ( and thought I would now share with the Experts Exchange community. Driver Proble…
    Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now