• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 710
  • Last Modified:

Ping, but no internet

I have a home network with 4 boxes behind a SmoothWall and a DLink 614+ used as a wireless access point.

Four clients are 192.168.30.1 - 4, the SmoothWall is 192.168.30.250, the DLink is 192.168.30.100.

All the clients but one are behaving well.  The XP box sees all the boxes on the LAN and it will ping the Smoothie and the DLink.  It also pings YAHOO.com and other internet sites.

I can access the Smoothwall through IE.

However, an attempt to access the DLink through IE yields a "connection refused" error, as well as any attempt to access internet sites, either w/ IE or w/ Netscape.

The XP is configured w/ a static IP of 192.168.30.1 w/ Subnet 255.255.255.0 and the Gateway and DNS Server are set to the Smoothwall.

Everything looks the same as the boxes that are happy on the network, but this one surely does not connect.

What do I do now?

Capt
0
Glen Gibb
Asked:
Glen Gibb
  • 4
  • 4
  • 2
  • +2
4 Solutions
 
Reid PalmeiraTelecom EngineerCommented:
if the DLINK is a WiFi point can you try to hook into the wired LAN and see if that makes a difference?

alternatively, if you can ping and access the smoothwall it could be a setting in either the smoothwall or the DLINK that is blocking traffic from either that IP or MAC address.  Perhaps check the configuration of both to make sure you have not placed restrictions on either the IP or the MAC of that machine....as i think about it, you can check the IP block by simply swapping the static IP to another non-used IP in the same subnet. It won't help you if either device is blocking traffic at the MAC address but it's worth a shot since it's relatively quick to try

cheers
0
 
Giles_KennedyCommented:
presumably you have power cycled all hardware?
0
 
purplepomegraniteCommented:
>>However, an attempt to access the DLink through IE yields a "connection refused" error, as well as any attempt to access internet sites, either w/ IE or w/ Netscape.

Only on the one machine though, yes?

- Go into Control Panel, Internet Options.
- Click Connections tab, then click LAN Settings button.

Are there any proxies defined?  If so, ensure they are the same as on the other machines.
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
rindiCommented:
You should probably set the DNS server to your ISPs DNS servers, and not the smoothwall, except if that also acts as a DNS server. Also check your internet connection settings for a non existing proxy setting.
0
 
Glen GibbOwnerAuthor Commented:
Comments for all the experts:

RPalmeira22 -- I have tried the hard-wired connection versus the wireless one -- both behave exactly the same.
Giles -- Basic and what an easy solution it would be.  But everything has been rebooted many times, w/ no results.
Purple-- I was excited to try this solution.  Yes, only one misbehaving machine.  No proxies defined, however, which mirrors the settings on the other boxes that work.
Rindi--Smoothwall acts as DNS server, and does it well for 3 of 4 machines.  I double-checked all the settings to see that there were no typos.

Strangely, the behaviour seems as if the DNS is not set correctly and I fully expected to see something amiss there, but nothing seems to be out of place except that no browser can actually access the internet.

Experts, is there something I've overlooked?
0
 
purplepomegraniteCommented:
This is a good problem (um, in the you've got me scratching my head department!!).

On one site I manage there is a domain controller that has exactly the same issue.  It itself is the DNS, and it is configured correctly.  Pinging any host by name works, and internet applications (such as Norton Liveupdate) work fine.  Internet Explorer however doesn't work at all.  Unfortunately, due to the fact that internet isn't needed on the machine and I am not often there, I haven't spent any time looking into the issue.

Have you tried reinstalling Internet Explorer? http://support.microsoft.com/default.aspx?kbid=318378

And the other thing to try is to reinstall Winsock: http://www.tek-tips.com/faqs.cfm?fid=5174
(for some reason can't find the MS Knowledgebase article on that one, but the above link details the correct method).
0
 
rindiCommented:
Have you tried using a proper browser, like mozilla's firefox? If firefox works and ie doesn't, check the settings you have there.
0
 
Giles_KennedyCommented:
Doesn't sound like DNS if you can ping hosts on the internet by name.

The Firefox suggestion is a good one as that would indicate whether the problem is IE specific or not.
0
 
purplepomegraniteCommented:
The asker has already tried Netscape, which determines that the problem is not IE specific.  This means that my reinstall advice for IE should be skipped, and I would start with the reinstall Winsock.
0
 
purplepomegraniteCommented:
Thinking about it, another thing to try would be to swap the IP address of the machine that doesn't work with one of those that does... this would double check that the Smoothwall isn't blocking that IP.  This is along the lines of rpalmeira22's suggestion.
0
 
rindiCommented:
Now that you mention it, I remember too!

Anyway still use firefox and not ie, except for the autoupdates...

:-)
0
 
Glen GibbOwnerAuthor Commented:
Thanks for all the help, guys.  Wound up reformatting the drive because of other issues that were starting to crop up.  Of course, that reinstalls Winsock, which I'm sure was the source of the trouble.

Capt
0
 
rindiCommented:
thanx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

  • 4
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now