CMOS Setup

I received an message "Checking NVRAM" on my system.  The machine just hangs on Waiting.  After a bit of googling, I believe that the CMOS battery has died.  I swapped a CMOS battery from a machine that works.  Now it won't detect my primary master/slave or secondary master/slave etc when loading up.  Instead when I put a boot disk into the machine, I get the screen:  

XMS RAMdisk v1.91 (FU - 08/98): XMS manager required.  

Memory allocation error
Cannot
Memory allocation error
Cannot load COMMAND, system halted.  

Is there something I need to alter or press to get the CMOS battery to work in the new machine.  

The machine's BIOS is AMBIOS SIMPLE SETUP UTILITY - Version 1.23.  

The top option is Standard CMOS Setup.  There seems to be nothing in there which suggests Auto Setup.  Can someone help me as the machine won't boot.  

Thanks in advance.
robbied69Asked:
Who is Participating?
 
purplepomegraniteConnect With a Mentor Commented:
Have you got some spare memory you could try in the machine?

A machine will still work even if it has a failed CMOS battery - it just won't retain it's BIOS settings in the event of a power failure.
0
 
nobusCommented:
you can try the default options, or optimum settings if available.
Then check  if the disk drives are recognised ok, the ram is identified, and the cpu also.
If you post your motherboard model, we can help you further.
try also taking out the ram, and check the connector and slot for dust; then reseat it. i suggest you touch the metal casing first before taking it out . (while the system is open, it is a good opportunity to clean out all dust from fans  too.
0
 
ccchinCommented:
you can try boot with win98 se startup disk but u need disconnect with the HDD first..if then can boot to A prompt. That means your HDD is failure. If still get the same error. That means yurs MOBO problem.
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
al-hasanCommented:
robbied69: after replacing the CMOS battery, often you have to reset the CMOS. On the mainboard, there is a jumper close to that battery. Consult your mainboard documentation, please, to find it. This jumper must be pulled, or switched (depending on the model) for several seconds, sometimes a minute. Then the 'Checking NVRAM' should disappear, especially if you alter some settings in the BIOS. In some BIOS settings you can do a 'Clear NVRAM' as well. Worth to look for it.

If after this step, there will be still some problem, do as the previous posters suggest.

Best regards,
has.
0
 
CallandorCommented:
Some older motherboards don't automatically detect disks connected to it.  Boot into the BIOS and move the cursor on the standard settings page to the row designated Primary IDE controller and hit enter - it should do the auto detection at that point.  Do the same for the Secondary IDE controller, and then save settings.  You should be able to boot at this point.  I think you were using a floppy that creates a RAM disk from extended memory, which is from an old system.
0
 
nobusCommented:
what mobo do you have?
0
 
robbied69Author Commented:
Hi, thanks for all your ideas guys.  

I noticed in the BIOS that it said that the Primary Master/Slave and Secondary Master/Slave were not installed.  I don't understand why seeing everything is attached correctly. I've even put in a new power supplier and memory.  I'm assuming this is why I'm not getting anywhere.  Any other possibilities.  

Thanks again in advance.
0
 
purplepomegraniteCommented:
Check the leads (replace if you can) , try the hard-drive in another machine to be sure the HD is working.  If it is it could be a motherboard problem - i.e. time to replace.
0
 
CallandorCommented:
Posting your motherboard make and model will help.  You may have a setting in the BIOS to disable the Primary and Secondary IDE controller - enable it, and it should work.
0
 
robbied69Author Commented:
Hi,

It turned out that the HD had died.  When I was getting us to boot from the floppy, the floppy I used was broken, which was strange as I rebuilt a machine about 20 mins before with the same floppy, so I overlooked it.  I swapped HD, memory, CMOS battery with a machine of exactly the same spec and a good floppy.

When I started putting in the original bits of hardware, no errors occurred with the CMOS battery and the memory.

As soon as the hard drive went back in, the screen hung on "Checking NVRAM".  In the BIOS the primary master was "not installed".  

I have since put in a new hard drive and the machine has been rebuilt.  Thanks you guys for all the help.  
0
All Courses

From novice to tech pro — start learning today.