• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 655
  • Last Modified:

Message ID 305006 on pix 506e

Only the mailserver that has static statement can access the net.When other network computers try accessing the internet they return a blank page and syslog records message ID 305006 portmap translation failed... Please help me out I have read all answers in EE but nothing has worked

Config:
PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
domain-name ciscopix.com
clock timezone EAT 3
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit tcp any host x.x.x.149 eq imap4
access-list 100 permit tcp any host x.x.x.149 eq www
access-list 100 permit tcp any host x.x.x.149 eq pop3
access-list 100 permit icmp any any echo
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any unreachable
pager lines 24
logging on
logging monitor errors
logging host inside 192.168.0.20
icmp permit 192.168.0.0 255.255.255.0 inside
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.149 255.255.255.248
ip address inside 192.168.0.10 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.0.0 255.255.255.248 inside
pdm location 192.168.0.20 255.255.255.255 inside
pdm location 192.168.0.2 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) x.x.x.149 192.168.0.2 netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.145 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 5
dhcpd address 192.168.0.11-192.168.0.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
banner motd UNAUTHORISED ACCESS PROHIBITED
Cryptochecksum:c29916b8de334d4e39fd36413d1aa72a
: end

0
sarit2002
Asked:
sarit2002
  • 7
  • 6
1 Solution
 
lrmooreCommented:
That's correct...
>static (inside,outside) x.x.x.149 192.168.0.2 netmask 255.255.255.255 0 0
>ip address outside x.x.x.149 255.255.255.248

Same IP address as your outside. That means that ALL traffic gets forwarded to that one system only, and only if it meets the acl criteria or is response to an inside generated connection request.

Remove the static command.
If you don't have another public IP address, then decide which ports you really need to forward to that server, i.e. imap4, www, pop3, and create static port xlates
  static (inside,outside) tcp interface imap4 192.168.0.2 imap4 netmask 255.255.255.255
  static (inside,outside) tcp interface www 192.168.0.2 www netmask 255.255.255.255
  static (inside,outside) tcp interface pop3 192.168.0.2 pop3 netmask 255.255.255.255


0
 
sarit2002Author Commented:
What I want to accomplish in this config is:
1.) OWA, POP3 and IMAP4 clients can connect to my mailserver 192.168.0.2 and download emails
2.) ALL 30 clients computers in the network should access the internet
3.) Secure network
0
 
lrmooreCommented:
Done. Keep your access-list as it is, create the 3 static entries just as I posted them.

access-list 100 permit tcp any host x.x.x.149 eq imap4
access-list 100 permit tcp any host x.x.x.149 eq www
access-list 100 permit tcp any host x.x.x.149 eq pop3
access-list 100 permit icmp any any echo
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any unreachable
no static (inside,outside) x.x.x.149 192.168.0.2 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface imap4 192.168.0.2 imap4 netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.0.2 www netmask 255.255.255.255
static (inside,outside) tcp interface pop3 192.168.0.2 pop3 netmask 255.255.255.255
access-group 100 in interface outside

0
How to change the world, one degree at a time.

By embracing technology, we can solve even the biggest problems—including the gender gap.  By earning a degree from WGU, you have an opportunity to gain the knowledge, credentials, and experience it takes to thrive in today’s high-growth IT industry.

 
sarit2002Author Commented:
Thanks Irmoore, I can browse from any machine but now the mailserver is not receiving any emails. When I send an email from yahoo to my exchange account it is not delivered and it does not bounce back??
0
 
lrmooreCommented:
Add this to disable fixup. Exchange and fixup don't get along.
 no fixup protocol smtp 25
0
 
sarit2002Author Commented:
no fixup protocol smtp 25 done, but still no emails come through.
0
 
lrmooreCommented:
Save the config and reboot the PIX.
pix#write mem

Power it off. Wait 2 full minutes. Power it back on.
0
 
sarit2002Author Commented:
Following message now appears in syslog

106023: Deny tcp src outside x.x.y.21/25 dst inside x.x.x.149/1292 by access-group 100
0
 
lrmooreCommented:
Do'H! We forgot a static for smtp:

static (inside,outside) tcp interface smtp 192.168.0.2 smtp netmask 255.255.255.255
0
 
lrmooreCommented:
And the accompanying access-list entry:
  access-list 100 permit tcp any host x.x.x.149 eq smtp

now re-apply the access-list to the interface
  access-group 100 in interface outside


0
 
sarit2002Author Commented:
You guys are just wonderful what could I have done without EE. Cheers.
0
 
sarit2002Author Commented:
Everything seems to be okay with my firewall but this message keeps appearing in my syslog:
106023 Deny tcp src outside x.x.y.21/25 dist inside x.x.x.149/3559 (or 3556 or 3596 or 3594) by access-group 100. Do need to worry about it? Am I losing some emails?
0
 
lrmooreCommented:
I would not worry about it. If it was incomming email, the outside source would be a high port and the destination would be inside x.x.x.149/25
Since the inside destination is a high port, it can't be inbound email.
0

Featured Post

Put Machine Learning to Work--Protect Your Clients

Machine learning means Smarter Cybersecurity™ Solutions.
As technology continues to advance, managing and analyzing massive data sets just can’t be accomplished by humans alone. It requires huge amounts of memory and storage, as well as high-speed processing of the cloud.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now