Cisco VPN Client will not connect to PIX 501, error with virtual adapter

Posted on 2005-04-14
Last Modified: 2008-01-09

I am trying to connect a PC to a PIX using VPN Client. I know the PIX is set up correctly because other PC's can connect using the same security information etc.. However the PC that fails has WinXP SP2 where the others do not have SP2.

Im using the latest version of Ciscos VPN client
Windows FW is off and so is McAfee.
I have already tried de-installing and installing VPN CLient. After installing the VPNClient for the second time all my network interfaces had IP addreses of and would not appear in ipconfig! (as if i had no network interfaces)

A few expletives later... ! I used a program called winsockxpFIX (suggested in another EE thread) which returned my LAN interfaces to normal, but did not solve the VPNClient issue.

When i select the connection entry from within VPN Client and click connect i get the username and password screen appear, after entering the correct credentials The status bar on the VPN Client says "Securing Communications Channel ..." and after a while (minute or so) it says "Not Connected." Looiking in the VPN CLient Logs there are the following errors

Cisco Systems VPN Client Version
Copyright (C) 1998-2004 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Windows, WinNT
Running on: 5.1.2600 Service Pack 2
Config file directory: C:\Program Files\Cisco Systems\VPN Client\

1      14:45:58.180  04/14/05  Sev=Warning/2      IKE/0xA3000067
Received Unexpected InitialContact Notify (PLMgrNotify:886)

2      14:46:19.260  04/14/05  Sev=Warning/3      CVPND/0xA340000D
The virtual adapter was not recognized by the operating system.

3      14:46:19.260  04/14/05  Sev=Warning/2      CM/0xE310000A
The virtual adapter failed to enable

4      14:46:19.631  04/14/05  Sev=Warning/2      IKE/0xE3000099
Failed to active IPSec SA: Unable to enable Virtual Adapter (NavigatorQM:936)

5      14:46:19.631  04/14/05  Sev=Warning/2      IKE/0xE30000A5
Unexpected SW error occurred while processing Quick Mode negotiator:(Navigator:2202)

ERROR Number 2 is probably a big clue, except im not sure where to go from now. As this is the only PC with SP2 the obvious thing to suggest is to un-install SP2, however i would rather not do that unless the experts out their suggest i should.

Thanks in advance
Question by:matt_love
    LVL 79

    Accepted Solution

    >2      14:46:19.260  04/14/05  Sev=Warning/3     CVPND/0xA340000D
    The virtual adapter was not recognized by the operating system.
    Yes, this is a big clue..

    > I used a program called winsockxpFIX
    That's what broke it...

    Here's what I would do:
    Uninstall the VPN client
    Start | run | sfc /scannow
      (have your XP CD handy)
    Check your network connections. Everything working?
     Re-install the Cisco VPN client
    Try the VPN connection again.

    Author Comment

    Thanks lrmoore for the quick reply,

    tried the above,

    unfortunaltely after re-installing Cisco VPN client i had no ip addresses, when i ran ipconfig from the cmd prompt it returned " Windows IP Configuration" and then nothing, just the commend prompt. I could see the adapters from within Start | Settings | Network Connections and going into the TCP properties it showed the correct static ip addresses.

    I rebooted.. just in case !
    No change.

    One thing to note, on re-installing the Cisco VPN Client part way through it popped up a box saying it was installing a driver for the Tamosoft Network Driver did i want to continue as the driver was not signed for windows XP compatibility.
    Tamsoft provide a piece of software called Commview (which is like etherreal) a network packet sniffer, i havent had problems before with this however i decided to de-install the sniffre.

    I ran winsockxpFIX again and it seemed to restore my network and ipconfig returns what i would expect. Pings and the like work fine again.

    now without Commview installed im going to go thru your suggested process again, just in case the virtual adapter that commview installs is messing witht he Cisco VPN virtual adapter...

    Which is where i am at the moment.
    I will post back shortly (i hope !) with an update.

    LVL 79

    Expert Comment

    > just in case the virtual adapter that commview installs is messing witht he Cisco VPN virtual adapter...
    Good work, Watson! I have not had problems using WinPcap/Ethereal or Sniffer Pro on my laptop with the VPN client

    Author Comment

    In the words of Homer Simpson... Doh!

    Rebooted after performing another sfc /scannow and although ipconfig shows the adapters i cannot get into the TCP properties to change them instead when i try to open the properties of a Network connection a dialog box appears saying "Some of the controls on this property sheet are disabled because one or more other network property sheets are already open. To use these controls, close all these property sheets and then reopen this one" (There are no others open that i can see.)

    Luckily before i upgraded to XP SP2 and then installed VPN Client yesterday, i took a ghost image of my harddrive. Unless anyone has any other suggestions i will restore this ghost image tomorrow morning when im back at work and then try the following.

    Remove CommView
    Install VPN Client
    See what happens, if all well then re-install XP SP2..
    Will report back tomorrow AM.

    Author Comment

    having restored the image XP Pro SP1 and no Cisco VPN client installed
    I removed the Commview prog
    Installed Cisco VPN client
    Bingo! I can now connect without errors to my PIX.

    So the dilema now is to SP2 or not and also which packet sniffer should i go for,
    lrmoore - you said your laptop is using Ethereal or Sniffer Pro, is this under XP Pro SP2 ? Do you have a recommendation?

    Thanks for your advice.
    LVL 79

    Expert Comment

    Yes, I'm running XP Pro / SP2
    VPN Client
    I have both Ethereal and Sniffer Pro installed.
    Ethereal is free.
    Sniffer Pro is very expensive. My company pays for it.

    Author Comment

    Thanks for you help and advice in sorting this out for me.
    LVL 79

    Expert Comment

    Glad you got it working!

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
    Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
    Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now