autorun issue

Hi,

I reinstalled the os, then updated the os, installed nav.

When I insert a cd to install something, it doesn't start, and I have to go to my computer > explore > setup
I tried the cd on another pc, and autorun does its job.

I searched for the autorun, and got

autorun                                            c:\hp\bin                                                                     application
autorun                                            c:\hp\vinetlink                                                            application
autorun.exe-055703AF.pf                c:\windows\prefetch                                                   pf file
autorun                                            c:\programs\sonic\mydvd\player                                install info
autorun                                            c:\programs\sonic\mydvd\player\intervideo               install info

What is wrong, and how can I solve it?

Thank you
LVL 7
kenesoAsked:
Who is Participating?
 
LeeTutorretiredCommented:
Hmm!  Okay, try this:  The Microsoft AutoPlay Repair Wizard scans your computer devices to find defective AutoPlay settings, and attempts to fix those it finds. Download the Autofix utility from here:

http://download.microsoft.com/download/2/3/2/2326455e-a840-4c61-bc28-3afa1820b240/AutoFix.exe
0
 
LeeTutorretiredCommented:
Do you have the Autorun feature set to "Take no action"?  This is how you disable the autorun:  When you right click the drive icon in Windows Explorer, and select Properties from the context menu that scrolls out, you can then click the AutoPlay tab and choose "Take no action" for each type of CD (for example, music or multimedia) you wish to disable autoplay for.  So, conversely, choose an option other than "Take no action" if you want autorun to work.
0
 
LeeTutorretiredCommented:
If that doesn't work, then there may be a registry setting turning off Autorun:  you can edit the Registry.  Click Start, then Run, type REGEDIT and click OK.  In the Registry Editor window that opens up, navigate on the left pane to this key:
 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom
 
Click on the last subkey (Cdrom) in the left pane to show the contents of that "folder."  In the right pane, double-click the Autorun value, and type 1 for its value.  (To turn off autorun, the value is set to 0.)  If the Autorun value is not there, you can create it by right clicking at an empty spot in the right pane, and then selecting from the context menu Edit -> New -> DWORD Value, and typing "Autorun" for its name.  You may need to log out and back in or restart the computer for the change to take effect.
0
 
kenesoAuthor Commented:
The registry value is
AutoRun       0x00000001 (1)

In the properties of the drive

the "request action" is selected, I changed the music, and mixed, categories to open with mediaplayer, but still when inserting the software cd nothing happens.
0
 
kenesoAuthor Commented:
Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.