Need help stopping a program printing job automatically

A program we use - TimTalk 9 (tiltration software) does an operation then creates the results, then prints them to the printer and to a file. There is no option to stop this autmatic printing to paper and is a waste. Is there anyway to stop a printer automatically printing?
kerpoiseAsked:
Who is Participating?
 
wyliecoyoteukConnect With a Mentor Commented:
If you want to discard data, you can send it to a Null port.
The questioner  stated that the file was sent to a printer AND a file.
He wanted to stop it being printed automatically.
setting the default printer to print to nul would do that, and he could later print the file.
0
 
nobusCommented:
if you right click the printer in the printer section, you can select stop printing, after the job, select resume printing on that printer.
0
 
kerpoiseAuthor Commented:
This is true. Yes. But I dont have to open a dialogue box at any point. I would like to be able to spoll the whole session, then choose to print at a given time
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
nobusCommented:
well, if you first select stop printing, then spool your session, then choose resume printing; is that not what you want?
0
 
jonoakleyCommented:
The program doesn't give you a dialouge to choose a printer or to print for that matter. We can attribute this to poor program design.
Is there some type of interface with this program where you can set configuration variables or prameters. That would be the first place to look. Next is an associated text file containing the parameters. You will have to look for this or find someone intimate with this program.

One option is if you have any control over when the print takes place--.
Create a new printer using the Generic /Text Printer driver
Start --Settings-->Printers--> Add printer -->Next-->Local Printer uncheck the automatic find option--> Create a new port-->Local Port--> enter the name of a text file somewhere on you system-->Select Generic from Manufactures section and Generic /Text Onlyfrom printers-->Name the Printer-->
Set this as the default printer before you run your print function
0
 
joedCommented:
Turn off the printer?
0
 
wyliecoyoteukCommented:
You always create a null port, any files sent to this are discarded.

Set up a generic printer as default, as described by jonoakley, but when selecting a port,
 add port > local port> enter the string:

 NUL

As the results are also saved to a file you can print them later .


0
 
jonoakleyCommented:
Wylie - >>You are a wealth of information.
Haven't used that but it might be helpful in some other endevors.
I am a bit confused though because the first and last statement in your post seem to be contradictory.
Can I get you to elaborate a bit more?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.