• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4637
  • Last Modified:

External HD's - The specified network resource or device is no longer available - error


Windows XP Pro SP2

I have 3 external HD's in Firewire-cases/enclosures. When I switch them on - Explorer will show them as three drives and
I can access these drives. No problem sofar.
After a couple of minutes one of them (at random) still how in the directory tree, but when clicking on a subdirectory
on that drive, I get above error ("The specified network resource or device is no longer available")

Solution is: switch off and after a few seconds, switch on. The drive is accessable again.

Maybe after 10-15 minutes another drive reports the same and I have to switch off and on again.

It may well be that for half an hour everything is okay, or even the entire session, but it may also be that
after 15 minutes another drive reports the above.

It's a bit frustrating, the hardware is okay, all new stuff. If only 1 drive is switched on, no problem.
They all have their own firewire cable to the PC and own powersupply.

Does this sound familiar to anybody out there - what may be the solution.

This error never pops up in case the external drives are not active.

Thanks
brgds
--
0
wulffra
Asked:
wulffra
  • 14
  • 14
1 Solution
 
huntersvcsCommented:
Have you checked your MOBO manufacturer for BIOS update releases?  That's where I would start.  Another question, though:  How are you connecting 3 firewire devices?  Most of the MOBO's I've seen have a maximum of 2 firewire ports, and most only one.
0
 
originalbiffmalibuCommented:
Firewire is daisy-chainable.  Try removing the offending drive and testing the other two.  Repeat this with any combination of drives.  If it happens with all, try a new firewire driver or controller.  If it still happens, we'll look into a windows issue:)
0
 
wulffraAuthor Commented:
huntersvcs:
Mobo Asus A7V333 has the latest available BIOS. I had two ports, so I ran out of ports and bought a 4 port-card, 2 are connected on that card, 1 connected to the port on the Creative sound card.

originalbiffmalibu:
Yes, there are 2 firewireplugs at the back. Fyi the cases are of the  H51x Series from Mapower.
http://www.mapower.com/Product.asp?CateID=51&LineID=2
They are all separately connected, i.e. not daisy-chained.
Yesterday I was organizing and copying files from one to the other, etc. Each time another drive 'lost connection'
and I had to switch off and on. Every -say- 10 minutes or so. It drove me mad.

To both:
Question: may it have something to do with an aspi-driver?

Note I am using 'Bestcrypt' software (www.jetico.com), creating pw-protected drives. May that have something
to do with it?

Just wild guesses ...

Thank you.
brgds
-

0
Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

 
huntersvcsCommented:
OK, here are some things to look at:

I don't think Bestcrypt is causing the problem. That would normally only restrict initial access, not shut them down as you described -- but who knows!  It may have a problem protecting multiple drives at the same time.  You said if only one was connected, it worked fine!  Can you do without this software?  If so, get rid of it temporarily to see if the drives start running the way they should.

Check your energy savings settings to be sure everything is checked to stay on all the time.  There is one that could also shut down drives after a period of inactivity.
0
 
wulffraAuthor Commented:
As for Bestcrypt: regret I cannot temporarily exit that. There is no option like Exit or so. Except for the monitor (after 30mins)
no energy savings. Also, there is no inactivity on those drives, I loose connection after 10 minutes (roundabout).
When checking "My computer" hardware, the Firewire cards are working properly, using the same driver (latest).
Strange problem...
Is there a registry-setting on max.drives or so?
Driveletters are from C - N and P (DVD) Q: CDR and Z for virtual CD's and X for Daemon.
-
0
 
huntersvcsCommented:
Take a look at planned tasks.  I just checked mine and Norton AV performs a check every 5 minutes.  Got anything like that set up?
0
 
wulffraAuthor Commented:
Very peculiar. I switched on the drives again. Got into Windows Device manager. They showed up there, alright.
After a minute one was 'out'. Usually a 10 minutes. Switched off/on, etc. After 2 minutes another was gone, other
drive. Switched that off/on. THen the 3rd drive 'left'.  They just disappear from the device mgr.
Third one switch off/on. Now, maybe 30-40 minutes later, they are still available... beats me!!
NAV does not perform any check, unless I tell it to do so...
0
 
huntersvcsCommented:
Does indeed sound like a driver glitch.  Maybe Windows just reloaded the drivers.  Keep on eye on it.  The device mgr shows them available - have you tried accessing them as well?  Keep me posted on what happens.  You might just need to activate them once, uninstall them in the device manager, then reboot and let Windows reinstall the drivers -- but only if they start going out again!  Never fix a running system.
0
 
wulffraAuthor Commented:

They did not go out for some hours now... I'll try it again tomorrow. It is very peculiar. Don't tell me that it has to do
with the sequence of powering on. Can't be. I'll keep a close watch on this. It is really rediculous, this has been an
ongoing problem. Will get back here soon.
thanks sofar.
0
 
huntersvcsCommented:
I'll keep my fingers crossed!
0
 
wulffraAuthor Commented:
Come to think of it...

I had 2 on a separate 4port firewire card. 1 on a soundblaster card. I moved the 1 ex sb to the firewire card.
It did help though...

Then I wondered whether it may be an IRQ-sharing problem, though XP is said to properly handle IRQ-sharing (??)

Here are my IRQ's

(PCI) 16    ALL-IN-WONDER RADEON 8500 DV (Microsoft Corporation)
(PCI) 16    AVM ISDN-Controller FRITZ!Card PCI v2.0
(PCI) 16    OHCI Compliant IEEE 1394 Host Controller

(PCI) 17    NEC OHCI Compliant IEEE 1394 Host Controller
(PCI) 17    Texas Instruments OHCI Compliant IEEE 1394 Host Controller

(PCI) 18    Realtek RTL8139 Family PCI Fast Ethernet NIC

(PCI) 19    Creative SB Audigy
(PCI) 19    WinXP Promise MBFastTrak133 Lite (tm) Controller

1 firewireport is on the All-in-Wonder
1 on the sb

I can't figure out whether the 4port is nr.16 or either one of the 17's.

On the other hand, it is just a wild guess on this IRQ-thing, it may well be that it is not an IRQ-sharing
problem at all. Also, I haven't the faintest idea how to solve it (the save way...)

brgds
--
0
 
huntersvcsCommented:
I don't think it's an IRQ problem, otherwise they wouldn't start up at all.

Are the firewire devices cutting out again??? Two comments ago, you said they were up and running for hours!  But your last comment didn't mention it at all!  Is the problem back?
0
 
wulffraAuthor Commented:
Sometimes a crucual word is skipped ... in my last message I wrote:
"It did help though..." the word 'not' was missing.

I switched them on, one of them went out.
Then  I switched them all of and moved one plug from the audio-1394 port to a port on the  separate 4port.
Then switched them on and one went out after a couple of minutes. that did _not_ help much.

They have been off-power for a few hours now.

Switched them on again, all 3 now, correctly show up, can access contents.
One went out within a minute, switched it off and on again.
They are now on for abt. 15 minutes.
They are all set to 'master' (default).

It is rrreally strange. I have no exoctic stuff on my machine (like to keep the apps to a minimum for a max.speed).

1 RAID,0
2 internal hd's
and 3 external.

Just like to add something else (sorry off-topic)

Sometime in the near future I like to buy a new pc
mobo: Asus Asus P5AD2 Premium http://www.digital-daily.com/motherboard/asus-p5ad2-premium/
pc-case: Cooler Master CM Stacker STC-101 http://www.modthebox.com/review334_1.shtml

I'd like to put in:
a) 2x Diamondmax 10 SATA in RAID,0
b) 2x same also as RAID,0 (or IDE ?)
c) the 3 external drives, or at least 2
d) diskette drive/dvd-rom/dvd+rw

wud that all fit?

the externals are still on, 25 minutes now ...

weird...

brgds/
--






0
 
huntersvcsCommented:
Took a look at the specs for a couple of minutes.

1.  You have 11 5 1/4" bays, so no problem with physically mounting the 4 HDDs, 2 CD/DVDs, 1 FDD.

2.  There are a total of 8 USB (4 integrated and 4 extra) so no problem connecting the USB devices - controller problems with up to 6 drives using 3 different controllers:  no idea!  Could work, but you never know.

3.  Your case has 6 USB ports in front - you will only be able to use max 4 of these.

How are the USBs running?  In the future you might want to first start the PC - wait about 20 minutes - then start turning on the devices.

Rick
0
 
wulffraAuthor Commented:
Hello, thanks for yr comment. I'd like to mount: 7 HDD's in total, i.e. 4 new ones and 3 existing ones (the present external
drives) or 2 of the existing ones, totalling 6 HDDs. + 2DVD and 1 FDD.
The 4 new ones in 2 RAID,0 sets, the 3 as separate drives.
The Asus P5AD2 Premium offers a JOBD-RAID possibility.
The 3 external drives are all of the same type.
However, they are 'fully utilized', i.e. when configuring as JOBDRAID, all data is lost.
I should first move all data from the external drives to the new drive (RAID,0).
Then format the 'old' drives and configure them as JOBD-RAID.

The final picture wud be: 2x RAID,0 (2x2=4 HDDs)
one jobd - 3 drives.

Don't know though whether this is feasable...:-)

Well, anyway, as for the external drives (Firewire). They worked flawlessly yesterday, after some switching off/on
actions.

I'll give it a try again this evening.

Will let you know.

brgds
--



0
 
huntersvcsCommented:
First rule of thumb:  Save your data!  Go ahead and move it to the other drive, being sure EVERYTHING is there.  I would even physically remove the drive from the PC once the data is on it in order to prevent mistakes.  Then you can set up the RAID however you want knowing your data is safe.  When the RAID is up and running, COPY the data back to it and check.  If anything goes wrong you still got the original data, right?!

Have fun :-)

Rick
0
 
wulffraAuthor Commented:


Thanks.

later ....

What do you think of :

http://www.bustrace.com/products/delayedwrite.htm
http://support.microsoft.com/kb/885464

notice : (PCI) 17    NEC OHCI Compliant IEEE 1394 Host Controller above.

brgds

I am studying the pages right now ..
but maybe you cud hv a look at the support page of microsoft as well??

0
 
wulffraAuthor Commented:

I guess it is:
http://support.microsoft.com/default.aspx?scid=kb;en-us;885464

when looking for:
Ohci1394.sys 5.1.2600.2524

my Ohci1394.sys is v5.1.2600.2180

have sent m$ an e-mail asking to get this hotfix.

can't trace it on internet... :-(

   Date              Time   Version                  Size    File name
   ------------------------------------------------------------------------
   27-Sep-2004  22:19  5.1.2600.2524      61,056  Ohci1394.sys

maybe it helps...

brgds
--
0
 
huntersvcsCommented:
Yep, seen this before.  There is an issue with both USB and Firewire on SOME machines running SP2.  On one of my customer's machines (notebook) a PCMCIA adapter (USB/FW) wasn't working properly with an external DVD Burner.  What I did was copy the files needed from an XP machine with only SP1 on it over to his notebook (saving the originals, of course) just to see what would happen.  Would you believe it, the USB side was back up and running!

These weren't the newest versions, but I couldn't see paying Microsoft for a fix to their own software.

Let me know what happens.

Rick
0
 
huntersvcsCommented:
Where do we stand now?  Anything from MS?
0
 
wulffraAuthor Commented:
Hello again, well the problem isn't solved and my guess it is unsolvable. MS did not get back to me. I'll send a reminder.

a) I have software running named "Bestcrypt" (from Jetico.com). I have asked them whether Bestcrypt is interfering one way
   or the other. BC creates/uses password protected containers, like virtual drives.  
   There are some strang effects when BC-containers are mounted, I am in contact with the software makers. However, my guess is that is not BC that is causing the problem.

b) note following peculiar thing, with NO...(!)  BC-drives mounted.
- when I switch on the drives, they show up in Explorer in a couple of seconds
- they work fine and even after 10 minutes they are still there
- when I switch them off, they are fairly quickly gone from the Explorer tree.

- now I mounted a BC-drive  (external drives not switched on)
- I switch on external drives
- after a while they show up
- after a while one of them go out
- I switch off ALL drives
- it takes upt 45 seconds before they disappear from the Explorer tree
- when I switched them on again, they show up fairly quickly and sofar I noticed that they are their to stay,
  i.e. they usually donot go out

BUT I need to switch them all off and on again.

Still I donot think BC is interfering.

In the past I switched off only the drive that got out and was not accessable anymore.
Then another drive got out - I had to switch off and on thát drive. etc.

I have discovered that the problems are mostly solved when I switched them all off and on again for the 2nd
time - sofar I noticed that they remain available. This I discovered the last few days only. I could not
thoroughly test this though, cause I was out Friday.

Looks like something must be reset whilst switching off and on the 2nd time.

Still, it beats me...

brgds
-
0
 
wulffraAuthor Commented:

I think (!) I have the solution...
Goto Control Panel, select Drive Management, RMB-click "Properties" 2nd tab, there are 2 options.
"Optimize for quick removal" and "Optimize for performance".
The drives were set to the 1st one, "Quick Removal".
I have now selected the 2nd one.

This is the third day they have continuously been running, they did not go out, even if I switched  them on and off.

Peculiar...

brgds/Marcel.
0
 
huntersvcsCommented:
You know what - I'm beginning to suspect there are more bugs just like this one in XP.  I've come across at least two other instances where settings just didn't work.  Changing them, saving the change (sometimes with a reboot, but not always), and then going back to the original settings finally made them work.  The incorrect information was stored in the registry - resetting forces the registry to correct itself.  You say this is the third (or fourth) day?  Have you been powering down at night, or just letting them run continuous?  The solution may be close at hand.  Let me know what happens through Friday.  If they are still working properly, I think you're done!
0
 
wulffraAuthor Commented:
hello again, i have 'accepted' your answer got allocated the 500 points to you. You have put in a lot of time in this, for which
I thank you very much. Though tThe solution may be different from you suggestions, I feel you have put in your time and ideas.
That is a valuable contribution to this board. Thank you again! Good luck!
Best regards
--
0
 
huntersvcsCommented:
Thanks :-)
0
 
wulffraAuthor Commented:
Bad luck, they are dropping out again... :-((
Really rediculous. This is one of the reasons I want to have those drives installed into a new pc ...
Well anyway..
brgds-
--
0
 
huntersvcsCommented:
Did the changes you made under "Optimize for quick removal" and "Optimize for performance".
stay the same, or did they switch back?
0
 
wulffraAuthor Commented:
I changed them from "Optimize for quick removal" to "Optimize for performance". For a while it looked fine, but
the problem got back. They are still set to: "Optimize for performance".
(Maybe it has something to do with the bootsequence?? Found out that when I switch the drives on, before switching my pc on, the drives remain on. Cannot judge this for a longer period of time, I did this the 3rd time, with success).
0
 
huntersvcsCommented:
That's the same thing that happens with my USB FAX - won't be continually recognized unless it's turned on BEFORE the PC is.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 14
  • 14
Tackle projects and never again get stuck behind a technical roadblock.
Join Now