Group Policy Not Applying Correctly

Hello,

I am having an issue with a policy setting that we set about a year ago. We set a policy to change everyone's homepage to our companys website. Since that time, we have changed that address, and thus, I made the change in the policy. Unfortunantly, the policy works half the time. Some users will have the new address, while others will have the old address. I have examined every GPO to make sure I did not put the old address in another policy, and I did not. Any suggestions on how I can "tattoo" that new address to everyone.
detroitchassisAsked:
Who is Participating?
 
SPSMillerCommented:
I would also pose the following:  How was the setting originally made?  I have had problems in the past if settings such as this were made directly into the registry a policy would not overwrite them.  Since it keeps changing back I would suspect this is NOT it however.  If this is an XP machine you can also try GPRESULT from a command prompt.  This will give you a better understanding of what policies are being applied.  Perhaps there is a hidden GPO that you are not aware of or may be overlooking.  On 2000 I am not certain of the command that would provide this output.
0
 
weight01Commented:
Hi, just to confirm. You have set the home page in the GP through: User Config > Windows Settings > Internet Explorer Maint > URLs > Important URLS and then set the Homepage URL?

Steve
0
 
SPSMillerCommented:
Do you have multiple different policies for IE?  If so, they do not mix well like other policies.  Example, if you set one policy at Domain level and another more specific at OU level they will not merge together.  You will get one or the other.  Try combining them, or duplicating the domain setting in the OU setting.

If not, check this:

Internet Explorer polices are odd.  They do not always update, but you can change this.  You can force the policy to update on the machines:

Computer Configuration >> Administrative Templates >> System >> Group Policy
Internet Explorer Maintenance Policy = Enabled
Options:
>>Do not apply during periodic background processing = Enabled
>>Process even if the Group Policy objects have not changed = Enabled
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
detroitchassisAuthor Commented:
I went thru each GPO that was created to again make sure there was no cross-germination of policies, and there were not. I did have the updated URL in two policies though, both pointing to the new URL. One in a policy called, "InternetApps and Favorites" and in the "Default Domain Policy" I removed in setting from the Default Domain, and made the change in the Computer Configuration >> Administrative Templates >> System >> Group Policy
Internet Explorer Maintenance Policy = Enabled setting. I will let you know if that works.
0
 
detroitchassisAuthor Commented:
After making that change, the Group Policy is still reverting back to the old URL. It seems to be updating in the background every couple of hours or so. I just rebooted my machine, and it just changed my page back to the old page. Any other thoughts?
0
 
SPSMillerCommented:
Have you checked for local policies on the machine?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.