[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 393
  • Last Modified:

REMOTE DESKTOP CONNECTION NOT WORKING!! PLEASE HELP!! 500 POINTS!!

Hi,

I have been trying to get Remote Desktop Connection to work for 2 days now.  I am a Windows Server 2003 machine and my client computer is a Windows XP machine.  The XP machine is on my internal network so I tried to connect with the internal IP address of the server but still nothing.  I can't connect from an outside computer either.  I have a router and have opened Port 3389.  I have enabled Remote Desktop on the server machine but CANNOT SEEM TO LOGIN.  I enter the IP address of the server in Remote Desktop Connection of the client computer and an error alert just pops up and says connection cannot be made.

I did "netstat -a -n" and for 3389 it says CLOSE_WAIT.  

I HAVE SPENT 2 DAYS ON THIS!!  DOES ANYONE IN THE WORLD KNOW HOW TO GET THIS TO WORK??

Your help will be very much appreciated!!

Thank You
0
NAPSR
Asked:
NAPSR
  • 21
  • 11
  • 9
  • +6
1 Solution
 
gpriceeeCommented:
Is the logon you're using permitted in remote desktop?  Did you give your logon rights?
0
 
ngravattCommented:
do you have the windows firewall turned OFF on your Winodws XP computer.

do this to test the connection.

open a command prompt and type..

telnet 10.14.4.4 3389

where 10.14.4.4 is the IP address of the WIndows 2003 server.

If it works who will get a blank command prompt.  if it doesnt work, you will see an error.
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
NAPSRAuthor Commented:
I am just entering the IP address and the login screen asking for the login information won't even come up.  


I get a connection error when I did the prompt.
0
 
gpriceeeCommented:
From the 2003 CD, did you install remote desktop, or are you just using the XP one?

"3389 it says CLOSE_WAIT" is what you want.  If it says ESTABLISHED, someone is connected.
0
 
rindiCommented:
Is TS on the server running in administrative or application mode? Which version of XP is your desktop using, home or pro? You may need special licensing if you are running in application mode.
0
 
NAPSRAuthor Commented:
gpriceee,

I am using the Remote Desktop Connection that is pre-installed on XP.

How do I find out if TS is in admin or app mode?
0
 
gpriceeeCommented:
On 2003, Remote Desktop is only for remote desktop administration, and TS is for TS clients.
Install the Remote Desktop from the 2003 CD.
0
 
NAPSRAuthor Commented:
"Install the Remote Desktop from the 2003 CD."

Where do you want me to install this: server or client?  
0
 
gpriceeeCommented:
Client.
0
 
gpriceeeCommented:
Insert the CD
---> Perform Additional Tasks --> Setup remote Desktop Connection
0
 
ngravattCommented:
"I get a connection error when I did the prompt."

the means there is a problem on the 2003 server.  make sure remote desktop is enabled.

right click on my computer and go to the remote tab.  Enable remote desktop
0
 
rindiCommented:
When you installed TS on the server it will have asked you how you wanted it installed. In App mode you need licenses for your users, and in admin mode you don't, but then you are limited to 2 concurrent connections. The Preinstalled client on XP works no problem with using either mode, the progeam itself is the same, it is just the licensing that is different. Windows XP pro don't need a separate license, home does.
0
 
lrmooreCommented:
Quote from the link I provided in my first posting:
 "By default, Remote Desktop for Administration is installed when Windows Server 2003 is installed. However, Remote Desktop for Administration is disabled for security reasons."
You simply have to enable it. The link goes into plenty of detail on exactly how to enble it in Adminitration mode..
0
 
NAPSRAuthor Commented:
On server 2003, remote desktop is enabled.

The Remote Desktop Connection has already been installed.  It is automatically installed when XP in installed.  The problem is not the client.  I have tried accessing the server with win 98, win xp and windows server 2003.

Nothing works!!

There is some kind of problem with the server 2003 setting and I can't figure it out.  

rindi, I don't what you mean.  I don't remember how I installed but is there a way to check it now.
0
 
gpriceeeCommented:
"I have enabled Remote Desktop on the server"
My assumption is that remote desktop has been enabled.  Using remote desktop strictly from XP has a history of issues which usually are resolved quickly by simply installing the software from the 2003 CD.

The following link addresses several of the known issues: http://support.microsoft.com/default.aspx?scid=kb;en-us;304718
0
 
gpriceeeCommented:
Check out the link I just sent.  It will refer to having the latest adminpack.msi
0
 
NAPSRAuthor Commented:
"Change the session encryption level"

What level should I choose?
0
 
gpriceeeCommented:
128 is the default on the server
0
 
mikeleebrlaCommented:
i think yall are talking about two different things...  on a remote desktop connection one computer (the "client" connects remotely to a RDC "server").  The machine that you are physically sitting at when you attempt the connection is the "client" the remote machine is the "server".  NOTE:  XP can be the server.  Which machine are you using as the server, and which machine are you using as the client???

also note:  there is no such thing as TS app or TS admin mode on a 2003 server.  those are windows 2000 terms and are obsolete now.  When you install TS on a 2003 server you are actually installing what WAS called TS app mode back in 2000, you dont have a choice. If you want to install what WAS called TS admin mode on a 2003 server you just enable RDC just as you do on an XP box.

from the client side do a port scan of the server... is 3389 open?


0
 
gpriceeeCommented:
http://support.microsoft.com/default.aspx?scid=kb;en-us;814590

Quote from link:
"Change the session encryption level
By default, the encryption level for Terminal Services sessions is set to Client Compatible to provide the highest encryption level that is supported by the client. Other available settings are: • High - This setting provides bidirectional security by using a 128-bit cipher.
• Low - This setting uses 56-bit encryption.
• FIPS Compliant - All data is encrypted by using Federal Information Processing Standard 140-1 validated methods.
All levels use the standard RSA RC4 encryption.

To change the encryption level, follow these steps: 1. Click Start, point to All Programs, point to Administrative Tools, and then click Terminal Services Configuration.
2. In the left pane, click Connections.
3. In the right pane, right-click RDP-tcp, and then click Properties.
4. Click the General tab, click the encryption level that you want in the Encryption list, and then click OK."
0
 
NAPSRAuthor Commented:
The server: Windows Server 2003 at my office

The client: Windows XP machine or a Windows 98 machine

I have opened the port on the router....how do i do a port scan?
0
 
mikeleebrlaCommented:
you can download superscan 3 from here:

http://www.snapfiles.com/get/superscan.html

run it on the server (to scan itself) to see if port 3389 is actually open
then run in on the client to scan the IP of the server to see if port 3389 can be "seen" from the client.

if 3389 can be seen from the client then you can rule out it being a "networking" issue and the issue is OS related.  What is the exact error that you get?  do you ever get prompted for a username/password?
0
 
NAPSRAuthor Commented:
The error I get is:

"The client could not connect to the remote computer."...The rest just says to contact system admin.

I never get prompted for a username/password.  I am doing the scanfile now.

Just a sec..
0
 
mikeleebrlaCommented:
sounds like you are having networking issues then,, can you even ping the server from the client?
0
 
NAPSRAuthor Commented:
I ran scan on the server and the open ports listed does not include port 3389
0
 
NAPSRAuthor Commented:
Yes...I can ping the server from the client.  Should I just try to restart the router.
0
 
NAPSRAuthor Commented:
Even though I have it opened on the router, the superscan does not list that port as being open.  I even included that port in the port scan list.

Why is that port not being opened?

Thanks
0
 
NAPSRAuthor Commented:
THIS IS SO FRUSTRATING!!

I don't understand why PORT 3389 is not opening.  I have it forwarded in the router settings to the IP address of the server.

SOMEBODY...PLEASE HELP!!!
0
 
ShineOnCommented:
Do you have the firewall running on the server?
0
 
neteducationCommented:
on your server: is the service "Terminl Services" running ?

if not: start it.

if yes: restart it
0
 
NAPSRAuthor Commented:
I do not have the firewall running on the server.  I have symantec mail security for ms exchange, norton anti-virus and microsoft anti-spyware

Terminal Server is not installed.
Under Services, there is no option to restart the Terminal Services feature.


0
 
neteducationCommented:
Not sure if I got you right...

Under Start -> PRograms -> Administrative Tools -> Services

Do you have a Service that is called "Terminal Services" ?

If so you can select this and then in menu action -> all tasks -> Start /Restart

Or dont you have such a service ?
0
 
NAPSRAuthor Commented:
I have the "Terminal Services" listed there but the start/restart options are grayed out.
0
 
neteducationCommented:
what is he "start type" ? automatic ? manual? disabled?
0
 
neteducationCommented:
and the status... suppose there is one ?
0
 
NAPSRAuthor Commented:
the "start type" is manual
the "status" is started
0
 
neteducationCommented:
ok, that looks correct... and if you select that service you cannot stop it ?
0
 
NAPSRAuthor Commented:
Oh....I just restarted the server and the router and its working now!!!!

It gives me the prompt for the username and password now...and then when i enter the username and password, it says.

"The local policy of this system does not permit you to logon interactively"
0
 
NAPSRAuthor Commented:
I logged in as the "Administrator" and it worked perfectly!
0
 
neteducationCommented:
ok, so assign the right "logon locally" to this user in your local security policy (or possibly in your domain policy)
0
 
NAPSRAuthor Commented:
Is it not safe to login as the "Administrator"?  I can't find the "logon locally" option for the user.

0
 
NAPSRAuthor Commented:
I was able to login as the "Administrator" even though in the properties of this account under "Remote Access Permission (Dial-IN of VPN)", the "Deny Access" option is clicked.

Why did it let me login then?
0
 
neteducationCommented:
it's ok to login as administrator, no problem... you only need the other thing when you want to allow your users to get in. If this is about remote administration, then you are all set.

Else use Start -> Programs -> Administrative Tools -> Domain Contoller Policy (or Local Policy if you have) -> Security Setting -> Local Settings -> Assign User Rights -> Logon Locally
0
 
neteducationCommented:
Terminal Services are not controlled by the "Remote Access Permission" Flag
0
 
NAPSRAuthor Commented:
For the Administrator settings, should I grant it access also.
0
 
neteducationCommented:
Administrators have access by default
0
 
NAPSRAuthor Commented:
Can I access the office desktop computer?  I am running XP home which cannot do remote desktop but there is a third party software called TightVNC which would allow me to access it.

Do I login to the server and then try to access the desktop?
0
 
neteducationCommented:
VNC is a completly different protocol.

You can access the office desktop computer if it is running xp and has the apropriate service running... its not called terminal services there... but i dont remember the name in xp
0
 
NAPSRAuthor Commented:
Thank you very much for your help.  I will try to access this from my house to make sure it works and will let you know.

I will definitely assign you the points.
0
 
neteducationCommented:
ok... going to bed now... it's 2:30 am here :)
0
 
eatmeimadanishCommented:
Your problem sounds like you have no password set on any of the accounts.  Without a password remote desktop will not load.  
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 21
  • 11
  • 9
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now