• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5893
  • Last Modified:

C:\documents and settings\myprofile is not accessible...Access is denied error when trying to read Corrupted Windows data. The HD is connected to a working computer as a slave device.

My computer was running Windows XP won't boot.  It flashes a blue screen quickly.  I see the words "system dump", "call administrator" and registry error".  I pulled out the hard drive and put it in another computer in hopes of accessing 'My Documents' to retrieve my data.  When I attempt to navigate to the new drive, E:\documents and Settings\myprofile while on the new computer,  I get an error that says, "C:\documentsandsetting\myprofile is not accessible...Access is denied".  Is my data lost forever?  The 'myprofile' profile is password protected.  Again, the HD is connected to a working computer as a slave device.  I am able to access everything else on the hard drive fine, but my important data is stored under this profile is not accessible. Any suggestions are appreciated. I will be more than happy to elaborate. Thanks in advance.
0
SimpleTechSolutions
Asked:
SimpleTechSolutions
1 Solution
 
tebacherCommented:
You just need to take ownership of the profile and allow yourself access to it.  To do so:

-Open c:\documents and settings
-Right-click on "myprofile" and choose properties
-Click the Security tab
-Click the Advanced button
-Click the Owner tab
-Click your name in the list and check the "replace owner on subcontainers", & click OK.
-Then make sure your name is in the list back on the Security tab and that you have Full Control.
-Click OK
You should now be able to open your profile folder and do what you like with the data in it.

Keep in mind that these instructions are for WinXP, so if you are running a different OS let me know and I'll instruct differently.
0
 
francrlCommented:
one note the computer you are trying to do this on must be running XP Pro, and you have to turn of simple file sharing. to do this in My Computer click Tools>Folder Options. On the on the View tab scroll to the bottom and uncheck Use simple file sharing.

Also on repairining the original have you tried restoring the registry to an earlier date by booting the CD into Recovery Console? Earlier copies can be found in the c:\System Volume Information folder if System Restore was turned on., if not you can use the defaults located in c:\windows\repair
0
 
Eagle6990Commented:
Here is the Microsoft article on how to take ownership of files.

http://support.microsoft.com/default.aspx?scid=kb;en-us;308421
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Tackle projects and never again get stuck behind a technical roadblock.
Join Now