• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 181
  • Last Modified:

Redirect Folders using Group Policy

I am trying to extend my undestanding of GP and active directory.

Using Server 2003, I have set it up a domain controller "\\myserverdc". I have created a share "\\myserverdc\users" to which all domain users have full control.

In the active directory structure I have created an OU called "mydomain default" and in this I have placed the users on my domain. I have then configured a group policy for this OU in which I have set the redirect properties for "Desktop" and "My Documents":-

Target tab has:-
Setting = "Basic - Redirect everyone's folder to the same location"
Target folder location = "Create a folder for each user under the root path"
Root Path = "\\myserverdc\users"

Settings tab has following checked:-
Grant the user exclusive rights to ...
Move the contents of ...
Leave the folder in the new location ...

But it doesn't work, users log on and continue to get their local "Desktop" and "My Documents" and no folders are created on the server. Can anyone tell me what I missing here?
0
cescentman
Asked:
cescentman
  • 2
  • 2
1 Solution
 
Pete LongTechnical ConsultantCommented:
Mmm I Would try a different approach - this is how I do it, It might not be the definitive method, but it works for me

on your server create a share called home - give domain admins "Full Controll"and backup operators full controll - (ensure its NOT inheriting and rights (untick the inherit box)

on your user objects (Active DIrectory Users and computers) on the profile Tab, set it so that the H drive connects to

\\myserverdc\home\%username%

This will create the folder wih the correct permissions (so everyone cant see everyone elses)

Then in your redirection policy simply redirect "My DOcuments" to H:\

0
 
cescentmanAuthor Commented:
Thanks for the speedy response. It sounds as though it would do the job, I would prefer to be able to get the redirection. to work.

I'm probably being daft here but in your sugegstion you say:-

".... give domain admins "Full Controll"and backup operators full controll - (ensure its NOT inheriting and rights ...."

Wouldn't this prevent the Domain users from accessing the share?
0
 
Pete LongTechnical ConsultantCommented:
>>Wouldn't this prevent the Domain users from accessing the share

correct untill you..............

on your user objects (Active DIrectory Users and computers) on the profile Tab, set it so that the H drive connects to
\\myserverdc\home\%username%
This will create the folder wih the correct permissions (so everyone cant see everyone elses)

then everyone has rights to their own home directory :)
0
 
2hypeCommented:
After you logon to the workstation and the Desktop/My Documents Does not redirect it should leave a event view log on the computer with an explination why it did not redirect.

What are these errors?

Ensure the users have full permission to write to the share \\myserverdc\users.  Right click on the folder you are sharing. Click the Sharing Tab.  Click the Permissions box and ensure everyone has full control.
0
 
cescentmanAuthor Commented:
Once you suggested looking at the event log it all fell into place. The log showed a DNS error. I tracked it back to two DHCP servers on the system. This workstation was not using the Domain Controller as the primary DNS as soon as I fixed that it worked.

Thanks

Charlie
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now