Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 231
  • Last Modified:

to connect two cd drives

I recently purchased a cd writer. I want to connect this along with my current cd drive. But I couldnot. I am using windows 98. I kept the cd drive as master and the writer as slave. Still not working. But when I connect only one drive it works. Do I have to do anything on the bios or just connect the drives?
1 Solution
shofil: your combination should work. Check the cable, check the jumpers once more (why not try to change them to CD-reader = slave, CD-writer = master?), and please tell me: when each of these drives works alone on the bus, did you connect it to different connectors on the cable? Do you have the IDE-40pin cable or the IDE-80pin (with connectors in such beautiful colors like blue and black and grey)?

Basically you should try to connect the CD-writer as a slave, with the CD-reader off the cable. The CD-reader itself works anyway, right? Then leave the slave connected and put in the master.

As well check in the BIOS of your mainboard that all IDE channels are not disabled. What can you see when the BIOS does the power on self test (black screen with fast running messages)? There should be some table shortly visible, press <PAUSE> or <BREAK> (top right on keyboard) to see the results. Both your CD drives should be recognized here.

I have had the same problem in the past.  I find that the writer (for some wierd reason) likes to be set to master.  Set the writer to master connected to the middle of the cable and the reader as slave to the end of the cable.

Dr. Z

Normally you have two IDE channels, Primary and Secondary, each can have 2 drives, Master and Slave.

What I'd suggest for your installation:

- Hard drive is primary master
- CD-ROM is Primary slave
- Burner is Secondary Master

You need to set master-slave jumpers on each drive.  Note, on some hard drives, there are two master settings, "master with slave present" and "master without slave present", while other hard drives just have one single master setting regardless of whether or not a slave is present.

Second choice is to have the CD-ROM be Secondary slave, but for copying CDs from CD-ROM to the burner, this is less desireable as they would both be on the same channel.

In the bios of your computer, you need to make sure that you do not have any of the 4 possible drives that you will be actually using turned off (disabled).  Usually, set them to "Auto".
I assume that you have two hard disks on your primary IDE channel.  If so, take Watzman,s advice and split the HDs over the IDE channels with the burner as master on the second IDE.

Dr. Z
i suggest not to connect the cd drive any more.
Reasons :
-uses power
-what can you use it for : only on the fly copying, which can result in bad burns

my 2 cents ...

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now