[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Network path not found - isolated to 1 machine, all other network services fine

Posted on 2005-04-16
16
Medium Priority
?
2,505 Views
Last Modified: 2013-12-07
I have 3 PC's in a home network, used for sharing files and 2 printers.

Livingroom PC - Windows 2000 (Printers and important files shared here)
Laptop - Windows XP Home
Bedroom PC - Windows XP Pro (Run IIS for FTP serv. here)

Everything worked fine, I could hit \\LIVINGROOM and access the files and printer from both the laptop and bedroom PC.  However I recently needed to reconfigure everything because I added a Webramp (a router for dial-up... don't laugh ;)).  It has an onboard DHCP server, so I am now using that, instead of static IPs, it will also dish out the DNS server addy this way too.

Now my Internet seems to work dandy on all PCs, but I can't access any local resources from the bedroom PC.

I can resolve the IP of LIVINGROOM just fine (ping Livingroom works) and I can ping its IP directly, but typing \\LIVINGROOM gives me "The network path was not found".  My printers say "Unable to connect".

The laptop can access livingroom without any troubles.

It's gotta be a Windows file/print issue of some sort, on the bedroom computer, because I can FTP from livingroom to bedroom just fine.  But get nothing upon \\BEDROOM

I've checked that the file/print sharing is installed in the LAN connection, and I've tried turning my software firewall solution off on both machines, to no avail.  Both machines are in the same workgroup.
0
Comment
Question by:Brendan-H
  • 6
  • 6
  • 4
16 Comments
 
LVL 88

Expert Comment

by:rindi
ID: 13797478
Can you connect to the other PCs using the IP addresses of those and not the name? That should not be a problem as all network devices will allway get the same IP from your router, except if you tell it to give out another address, or if a PC hasn't connected for a very long time. If it works using the IP Address you can edit your hosts and lmhosts files on all PCs so that the correct IP addresses are resolved to the correct names. Those files are normally in ..\System32\drivers\etc\
0
 

Author Comment

by:Brendan-H
ID: 13798628
I tried entering \\192.168.0.4 into Start|Run but it gave me the same error.

IPs are being resolved perfectly, and other services (like FTP) work fine, just no file/print sharing.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13798657
Then check if you have any firewalls set to on on any of your PCs. Remember that XP SP2 has a new, builtin firewall which is automatically turned on. You can access it via the control panel and in the exceptions add file and printer sharing. similar options should be set in any 3rd party firewalls. Possibly your router also has a firewall setup?
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 

Author Comment

by:Brendan-H
ID: 13798797
"...and I've tried turning my software firewall solution off on both machines, to no avail."

As for the hardware firewall, normally routers only control traffic from the outside, the LAN is just a hub or switch, unaffected by the firewall.  Regardless, the other 2 PC's work fine on the same router.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13798916
It still looks like a firewall problem. There may still be some program acting as a firewall. I know, routers normally block traffic from the outside, but you never know what products are out there.
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13800374
The not so obvious solution is to try and use a form of domain name as the Workgroup.  Then all machines have this workgroup, and, their own computer name:

Example [this is proprietary and will not work for your home network, I'll provide a similar example for non-registered domains]:

Workgroup = Musics.com
on all machines

machine names:

Beethoven
Bach
www
Mozart

so, in the url of a browser, simply:

\\Musics.com

or any of these will work:

\\Bach
\\Beethoven
\\www
\\Mozart

For a home network, let's say the workgroup is myhouse.com

\\myhouse.com
\\bedroom
\\livingroom

and whatever else should all work.

directories must be shared for the object, and perhaps some adjustments may be necessary.  

If the improper protocol for authentication is used, the computer may be denied access.  Usually, this is CHAP.

The problem is most likely your configuration of workgroup and computernames, with a bad Auth Dialect between 2000 and one XP box.

If the above doesn't work, you may have to do some packet captures with Ethereal to find the proper Auth Dialects for all three.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13800386
For that to work, you will need some sort of dns server. An IP address on the other hand will work without a need for that. You could of course use the poor man's dns server, your "hosts" files, where you would have to add the ips of every PC and their corresponding name. This hosts file will have to be distributed to every PC. This means that a lot of administrative overhead is needed (This also adds more error possibilities). An IP address doesn't need any such overhead.

Also, for local access, NEVER use an official domain name (one that ends with .com, .net, .org etc.) I allways use the .local at the end, for the above example that would mean music.local.
This will prevent problems if you do eventually want to host an official site with the same name.
0
 

Author Comment

by:Brendan-H
ID: 13830200
Thanks for your ideas so far everyone!

I don't think I'll need to resort to my hosts file, nor do I think there's any kind of DNS problem: I can ping (and FTP) using hostnames (ie. they are resolving properly).  It's just file & print services that aren't working, and only on the 1 PC.

As for packet sniffing, that's a fascinating idea but what would I look for?  I'm not exactly a guru on reading packets.

Perhaps uninstalling and re-installing my network connections might help.. ?
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13841302
If the network connection is fully pingable, then it would seem that your file & print sharing is not working.  That is, if you can really ftp to domain/workgroup and actually login, but can't see files or share printers, then the permissions are most likely not set up for it.

Bedroom and Livingroom must agree on some things.  For one, Livingroom must allow something like "share this computer on the network" or something similar.  It must the proper services for a shared network printer and all other machines, under normal circumstances, must first add the network printer to "printers."  Some older machines will need a driver on the client side for communicating with that printer over the network.

A point to be made; I am going to disagree with rindi here "routers normally block traffic from the outside," and comment that routers are not firewalls, they are routers.  A router's sole job is to route packets.  By default, all routers allow all traffic, in and out, and not the other way around.  A router should never be a firewall.  You can appreciate this if you're working for Cisco and realise that your products route packets between points A and B, and what, a billion others(?), so you don't want them to waste their time babysitting both ends.  Their jobs is to send packets back and forth, no more, nor less [hopefully].

Point 2.:  It is advised that you don't use an official or Fully Qualified Domain Name [FQDN] unless you own one.  This is so inexpensive today that it is worth it to register a domain name.  for more than one reason.  At prices like $6.95 a year, I'd say you get your money's worth.  It avoids a lot of future problems too, like growth, careerwise, professionally, and at home.  If you were to use my domain name, it most likely won't work anyway, but if it did, I'd either say "welcome aboard" or ask you why.  Currently, it's pretty hard to get even remote clients to join an Internet domain [a lot of configuration work, approval from main servers, etc..]  But a server that went out and used my domain name would probably be stopped fairly quickly, unless we had an agreement.

Most DSL accounts come with a "home router."  This is different from a "router."  The home router can route up to 254 [more or less] IP Addresses within a private LAN.  A home router can additionally on Public IP Address at a time.

If you have a router in either livingroom or bedroom, it makes things a little easier.  If you don't, your connection is most likely computer-to-computer, or "null modem."  Normally, laptops are null modemed directly into some other larger desktop or whatever, to upload and download data at specific times they are "wired up."

From this:

"Livingroom PC - Windows 2000 (Printers and important files shared here)
Laptop - Windows XP Home
Bedroom PC - Windows XP Pro (Run IIS for FTP serv. here)"

at least two machines are acting as servers.  A server does not have to be a full Server machine to actually be "a server."  As your own experience shows, Livingroom is a "Print & File Server" and Bedroom is an "FTP Server."  There are many ways to turn a home computer into a server; adding Apache to Bedroom would turn it into a "Web Server" that would actually work like any Internet Web Server.  It would be harder to configure to get it on the Internet, but at home, Livingroom, laptop, and Bedroom itself could really share files a lot more easily.  Apache Web Server has versions for all Windows.  Apache also includes the ability to ftp directly from the url location window of any browser, such as Internet Explorer, with full security and login.

Packet capture and monitor is different from "packet sniffing."  Sniffing is more of a hacking experience, whereas packet capture is an administrator's tool.  What it would show you is the exact packet contents when you try to connect and get "network path not found."  But no permission to share files and printers will cause such an error.

I don't think you're quite ready for something like Ethereal, unless you are willing to put in time to read, understand, and implement such a tool.  It's free, by the way.  I think you have a simple file and print sharing problem, not a ping or dns type problem.

XP SP2 must specifically allow sharing.

So, at this point, I would ask for more information:

Are you using a router?
Name brand and model?
Can you see livingroom and bedroom in network neighborhood?
Have your used Windows Explorer to "search" for a computer?
Have you done "add a network share" on Livingroom and then looked for that share on Bedroom in Network Neighborhood?
Have you installed printers as "network printer" on livingroom?

These basic steps have to be completed properly first before you can do full file and printer sharing.  I think you probably missed "add a network share" for the directories you want to share on your network, and, the printer needs to be set up as well for "share this printer on the network."

Can you describe your set up a little more?
0
 
LVL 88

Assisted Solution

by:rindi
rindi earned 225 total points
ID: 13842415
I think I forgot to ask, did you disable "Simple file and printer Sharing"? If that is enabled usually nothing works anymore...
0
 

Author Comment

by:Brendan-H
ID: 13846847
GinEric, thanks for your very long response, however the problem definitely lies in the Bedroom PC.

You see, this is a long-established home network, the shares on the livingroom PC work fine, have for years.  The laptop sees them fine.  Yes, there's a printer share.

I'm definitely not looking to use my domain name with my home network.  The network is disconnected from the Internet as often as it's connected (and I'm not using Active Directory or anything)

I do have simple file and printer sharing checked.  But that just allows you to set permissions on file shares more easily.  (Works like Windows 2000 instead of XP Home... the right way)

My router is a dial-up router, Webramp M3t, and I'm using a SMC 7004VBR DSL router as a switch.  The Webramp only provides 10Mbps unswitched connections, so I chained this $20 DSL router on as to use it as a switch to increase internal speeds.  Before telling me to tear this apart, I should point out that it works beautifully for the other PC's.

  USR 56K modem <serial cable> Webramp Router <patch cable> SMC router acting as switch <patch cables> PC's
  (I have actually tried changing this to only use one hub or the other, same problem)

Software firewall problem, or maybe a Windows problem.

By the way, I'm an EE n00b, but definitely not new to networks ;)
0
 

Author Comment

by:Brendan-H
ID: 13846857
Correction, simple file sharing *un*checked
0
 
LVL 12

Accepted Solution

by:
GinEric earned 225 total points
ID: 13849181
Okay then.  If you're not new to networks, are you ready to try Ethereal or some packet capture software to get down into the nitty gritty of packet switching and network communication?  

http://www.Ethereal.com/

Versions for 2000 and XP are available, from what I know.  There are also some configurations needed for snmp packets forwarding or enabling on the routers.  If this gets to be too much, I think you can safely follow my first advice; check the authentication protocol.  Usually, for Windows, it is chap.  From the problems I have seen in the past, when everything else works, it is the "Agreed upon Dialect" that causes this failure at the packet level.  

There were issues with XP Home using PPPoE, ADSL client size limits, and some other general stuff; I don't know if XP Pro was affected because it didn't seem to show such faults.  If it is, indeed, a firewall problem, or any problem for that matter, you should have tons of reports in EventViewer.  You might want to start there and see if there are any reports about this "network path not found."

There is, as I understand, some early issue with 2000 and XP authentication, and authentication affects all sorts of things, including file and print sharing.  At least one solution which I lead someone to, was this "use protocol" thing.  Once he had his 2000 and XP machines agreeing on the same protocol, it worked.

Let's look at some EventViewer logs before concluding though.

0
 

Author Comment

by:Brendan-H
ID: 13855884
Well, I've been going through the event viewer, and I've uninstalled and re-installed my net connection, and almost pulled my hair out.

This is all I managed to dig up from the logs:
The browser was unable to retrieve a list of domains from the browser master \\LIVINGROOM on the network \Device\NetBT_Tcpip_{D2FBAB07-A1D4-4772-9977-1D8FB1A2587D}. The data is the error code.

Reinstalling network did nothing.

I fixed it... You know what I did?  Cleared out the firewall program and set it up again, and now it works.  I could have sworn I'd tried shutting it down earlier.  Maybe it's just quirky.

I have spent far too long on this...

I feel rediculous now, but I shall split these points up- you guys spent some serious time trying to help me (hope that's allowed).

So, to anyone reading this in the future: don't forget about your software firewall.  Even when it's off, it could be interfering.  Try shutting it down, and don't hesitate to uninstall it.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13857001
thanx.
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13857518
Thank you Brendan-H

Amazing solution, although even seemingly dead programs appear to be "freddies."
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unable to change the program that handles the scan event from a network attached Canon/Brother printer/scanner. This means you'll always have to choose which program handles this action, e.g. ControlCenter4 (in the case of a Brother).
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question