Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

how to install kdevelop on mandrake 10.1

Posted on 2005-04-16
25
Medium Priority
?
517 Views
Last Modified: 2013-12-06
Hi

I found the kdevelop package into the dvd , but when I install it, the installation stop because does not find a file.

There is an easy way to insatll it ? Please note that I am new to Linux ( windows user since yesterday) therefore I need step by step instructions ( I am just starting to learn command line etc...)
0
Comment
Question by:brillox
  • 13
  • 12
25 Comments
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13803943
System --> Configuration --> Packaging --> Install Softeware
and select kdevelop.
Or in any "shell console" type
rpmdrake
0
 

Author Comment

by:brillox
ID: 13804844
System --> Configuration --> Packaging --> Install Softeware

This is what I've done, but the installation geve me errors because does not find some files...
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13808043
> because does not find some files...
Could you describe more details about the error messages?
Did you allow for the installing all the dependent packages?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:brillox
ID: 13808255
while trying to insatll, the installation stop and I get this:

Emacs=21.3-15.1.101mdk is needed by(installed)emacs x11.21.3-15.1.101mdk emacs=21.3-15.1.101mdk is needed by(installed emacsx11-21.3.15.1.101mdk

Do you know why ???
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13808622
Well, some files in kdevelop require emacs-21.3-15.1.101mdk.
You need to allow for the installing all the dependent packages or check emacs-21.3-15.1.101mdk to be installed at the same time.
0
 

Author Comment

by:brillox
ID: 13808785
I allowed the installation of all the depending packaged that the installation wizard asked me to allow.... but the result is the above... any other solution??
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13808869
I don't have Mandrake 10.1 on hand now. Did you try check emacs-21.3-15.1.101mdk to be installed at the same time?
0
 

Author Comment

by:brillox
ID: 13810850
I give up before installing kdev the wizard say that need to unistall  emacs-21.3-15.1.101mdk for conflict with emacsx11.....  then say that he need this file...

Whos ay that linux is better than windows.. after two days I am alreday tired. Do I need to follow a Course to use a software on mandrake !!

and nobody seems to have an EASY solution !!
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13810942
> before installing kdev the wizard say that need to unistall  emacs-21.3-15.1.101mdk for conflict with emacsx11.....  
> then say that he need this file...
It could be some sort of bug with rpmdrake in Mandrake.
Try one more time to remove emacsx11-21.3.15.1.101mdk first.

What's your purpose of using Mandrake?
0
 

Author Comment

by:brillox
ID: 13811113
My purpose was  to try to move to Linux, but to be honest I do not think that is easy to do it because is too complicate to do anything. E.G. How I remove emacsx11=21.3.15.1.101 etc... I admit that Linux is very interesting and I would like to learn it, but I think that it takes too much
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13811144
> How I remove emacsx11=21.3.15.1.101
As root,
rpm -e `rpm -qa | grep -i emacsx11`

For playing Linux, you just hit the bug in Mandrake. How about other portion?
Command line, programing, servers....?
0
 

Author Comment

by:brillox
ID: 13811276
Thanks wesly for the rpm-etc...

but I do not understand what do you mean about portion, command line, programming, servers..
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13811289
I mean what's your feeling about those portions (command line, programming, servers) in Linux?
0
 

Author Comment

by:brillox
ID: 13811308
They are great, but I should be more advanced before to try to play with them
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13811352
> I should be more advanced before to try to play with them
I'm not sure what's the advanced you mean.
However, you need to understand the Linux more to be good at those.
0
 

Author Comment

by:brillox
ID: 13817518
When I tried to delete emaxcx11 I received this

[massimo@localhost massimo]$ su
[root@localhost massimo]# rpm -e `rpm -qa | grep -i emacsx11`
rpm: no packages given for erase
[root@localhost massimo]#

so if emacsx1 is not there why there is a conflict when I am trying to install kdevelop ?
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13817564
Could you post the output of
rpm -qa |grep -i emacs
0
 

Author Comment

by:brillox
ID: 13817782
below your required stuff...

[massimo@localhost massimo]$ su
[root@localhost massimo]# rpm -qa |grep -i emacs

emacs-21.3-15.1.101mdk
emacs-doc-21.3-15.1.101mdk
emacs-X11-21.3-15.1.101mdk

[root@localhost massimo]#
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13817930
rpm -e  emacs-X11-21.3-15.1.101mdk  emacs-doc-21.3-15.1.101mdk

It's emacs-X11, not emacsx11. You don't need emacs-doc, either.
0
 

Author Comment

by:brillox
ID: 13817968
after I copied an pasted your command I had this

[massimo@localhost massimo]$ su

[root@localhost massimo]#  rpm -e  emacs-X11-21.3-15.1.101mdk  emacs-doc-21.3-15.1.101mdk

grep: /var/lib/rpm/alternatives/emacs: No such file or directory

[root@localhost massimo]#
0
 

Author Comment

by:brillox
ID: 13817980
and I also tried this.. but

[massimo@localhost massimo]$ su
[root@localhost massimo]# pm -e  emacs-X11-21.3-15.1.101mdk
bash: pm: command not found
[root@localhost massimo]# rpm -e  emacs-X11-21.3-15.1.101mdk
error: package emacs-X11-21.3-15.1.101mdk is not installed
[root@localhost massimo]#
0
 

Author Comment

by:brillox
ID: 13818001
But now....

[root@localhost massimo]# rpm -qa |grep -i emacs
emacs-21.3-15.1.101mdk
[root@localhost massimo]#
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13818002
> grep: /var/lib/rpm/alternatives/emacs: No such file or directory
Where does the grep come from?
Mandrake is kind of weird.
Please try
rpm -e  emacs-X11  emacs-doc
0
 
LVL 38

Accepted Solution

by:
wesly_chen earned 1000 total points
ID: 13818016
I think you have remove them by rpm -e `rpm -qa |grep -i emacs-X11` or some sorts before you run
"rpm -e  emacs-X11-21.3-15.1.101mdk".

Anyway, try install kdevelop now.
0
 

Author Comment

by:brillox
ID: 13818072
YOU ARE MY HERO !!

I ACTUALLY INSTALLED KDEVELOP 3.0

I know that there is the 3.2 version, but I do not try to upgrade ( actually is 3 weeks that i am trying to install this version !!)

Thanks very much...

I have a lot to learn and I wish I could have a valid book to start to seriously learn Lin ux.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses
Course of the Month14 days, 13 hours left to enroll

577 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question